Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP General > Decimal value setting problem (ASP & ADODB.Recordset value & MSSQLServer & 2003 Server)

Reply
Thread Tools

Decimal value setting problem (ASP & ADODB.Recordset value & MSSQLServer & 2003 Server)

 
 
avcitamer
Guest
Posts: n/a
 
      09-17-2008
We upgraded our system and problem below occured, pleas help me...

Windows 2003 server SP1
When I set a decimal DB field value to "123,32" (using
ADODB.recordset ) updated value was ok (123.32)

Windows 2003 server SP2
Now when I set a decimal DB field value to "123,32" (using
ADODB.recordset ) updated value is (123.32)

Thanks

Systems
Windows 2003 server Enterprise SP2
SqlServer 2000 SP4
Activex Data Object 2.8~
IIS7, Classsical ASP

 
Reply With Quote
 
 
 
 
avcitamer
Guest
Posts: n/a
 
      09-17-2008
!!! Correction....!!!
in the second state updated value is (12332) ... sory...


On 17 Eylül, 14:25, avcitamer <(E-Mail Removed)> wrote:
> We upgraded our system and problem below occured, pleas help me...
>
> * * Windows 2003 server SP1
> * * * * When I set a decimal DB field value to "123,32" (using
> ADODB.recordset ) updated value was ok (123.32)
>
> * * Windows 2003 server SP2
> * * * * Now when I set a decimal DB field value to "123,32" (using
> ADODB.recordset ) updated value is (123.32)
>
> Thanks
>
> Systems
> * * * * Windows 2003 server Enterprise SP2
> * * * * SqlServer 2000 SP4
> * * * * Activex Data Object 2.8~
> * * * * IIS7, Classsical ASP


 
Reply With Quote
 
 
 
 
Bob Barrows [MVP]
Guest
Posts: n/a
 
      09-17-2008
avcitamer wrote:
> !!! Correction....!!!
> in the second state updated value is (12332) ... sory...
>
>
> On 17 Eylül, 14:25, avcitamer <(E-Mail Removed)> wrote:
>> We upgraded our system and problem below occured, pleas help me...
>>
>> Windows 2003 server SP1
>> When I set a decimal DB field value to "123,32" (using
>> ADODB.recordset ) updated value was ok (123.32)
>>
>> Windows 2003 server SP2
>> Now when I set a decimal DB field value to "123,32" (using
>> ADODB.recordset ) updated value is (123.32)
>>
>> Thanks
>>
>> Systems
>> Windows 2003 server Enterprise SP2
>> SqlServer 2000 SP4
>> Activex Data Object 2.8~
>> IIS7, Classsical ASP


It sounds like a Regional Settings issue. By default, regional settings are
US. Perhaps you had changed the Regional Settings of the IUSR account to UK,
and the SP restored them to default?

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"


 
Reply With Quote
 
avcitamer
Guest
Posts: n/a
 
      09-17-2008
How can I cange Regional Settings of the IUSR on windows 2003 server?

On 17 Eylül, 14:41, "Bob Barrows [MVP]" <(E-Mail Removed)>
wrote:
> avcitamer wrote:
> > !!! Correction....!!!
> > in the second state updated value is (12332) ... sory...

>
> > On 17 Eylül, 14:25, avcitamer <(E-Mail Removed)> wrote:
> >> We upgraded our system and problem below occured, pleas help me...

>
> >> Windows 2003 server SP1
> >> When I set a decimal DB field value to "123,32" (using
> >> ADODB.recordset ) updated value was ok (123.32)

>
> >> Windows 2003 server SP2
> >> Now when I set a decimal DB field value to "123,32" (using
> >> ADODB.recordset ) updated value is (123.32)

>
> >> Thanks

>
> >> Systems
> >> Windows 2003 server Enterprise SP2
> >> SqlServer 2000 SP4
> >> Activex Data Object 2.8~
> >> IIS7, Classsical ASP

>
> It sounds like a Regional Settings issue. *By default, regional settings are
> US. Perhaps you had changed the Regional Settings of the IUSR account to UK,
> and the SP restored them to default?
>
> --
> Microsoft MVP - ASP/ASP.NET
> Please reply to the newsgroup. This email account is my spam trap so I
> don't check it very often. If you must reply off-line, then remove the
> "NO SPAM"- Alıntıyı gizle -
>
> - Alıntıyı göster -


 
Reply With Quote
 
Bob Barrows [MVP]
Guest
Posts: n/a
 
      09-17-2008
Never done it myself - I try my best not to write code that is affected
by those settings. You could change the password of the account, log
onto the machine as that account and use the Regional Settings dialog.
But changing the IUSR password can have unwanted consequences, so you
can edit the Registry, HKEY_Users/<IUSR node>/Control
Panel/International

The trick will be to identify the IUSR node ... maybe someone who has
done this can jump in. Or perhaps someone has a script to change the
regional settings of the IUSR account. You can try the .inetserver.iis
group, or the .scripting.vbscript group.

avcitamer wrote:
> How can I cange Regional Settings of the IUSR on windows 2003 server?
>
> On 17 Eylül, 14:41, "Bob Barrows [MVP]" <(E-Mail Removed)>
> wrote:
>> avcitamer wrote:
>>> !!! Correction....!!!
>>> in the second state updated value is (12332) ... sory...

>>
>>> On 17 Eylül, 14:25, avcitamer <(E-Mail Removed)> wrote:
>>>> We upgraded our system and problem below occured, pleas help me...

>>
>>>> Windows 2003 server SP1
>>>> When I set a decimal DB field value to "123,32" (using
>>>> ADODB.recordset ) updated value was ok (123.32)

>>
>>>> Windows 2003 server SP2
>>>> Now when I set a decimal DB field value to "123,32" (using
>>>> ADODB.recordset ) updated value is (123.32)

>>
>>>> Thanks

>>
>>>> Systems
>>>> Windows 2003 server Enterprise SP2
>>>> SqlServer 2000 SP4
>>>> Activex Data Object 2.8~
>>>> IIS7, Classsical ASP

>>
>> It sounds like a Regional Settings issue. By default, regional
>> settings are US. Perhaps you had changed the Regional Settings of
>> the IUSR account to UK, and the SP restored them to default?
>>
>> --
>> Microsoft MVP - ASP/ASP.NET
>> Please reply to the newsgroup. This email account is my spam trap so
>> I don't check it very often. If you must reply off-line, then remove
>> the "NO SPAM"- Alıntıyı gizle -
>>
>> - Alıntıyı göster -


--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.


 
Reply With Quote
 
avcitamer
Guest
Posts: n/a
 
      09-18-2008
On 17 Eylül, 17:33, "Bob Barrows [MVP]" <(E-Mail Removed)>
wrote:
> Never done it myself - I try my best not to write code that is affected
> by those settings. You could change the password of the account, log
> onto the machine as that account and use the Regional Settings dialog.
> But changing the IUSR password can have unwanted consequences, so you
> can edit the Registry, HKEY_Users/<IUSR node>/Control
> Panel/International
>
> The trick will be to identify the IUSR node ... maybe someone who has
> done this can jump in. Or perhaps someone has a script to change the
> regional settings of the IUSR account. You can try the .inetserver.iis
> group, or the .scripting.vbscript group.
>
>
>
>
>
> avcitamer wrote:
> > How can I cange Regional Settings of the IUSR on windows 2003 server?

>
> > On 17 Eylül, 14:41, "Bob Barrows [MVP]" <(E-Mail Removed)>
> > wrote:
> >> avcitamer wrote:
> >>> !!! Correction....!!!
> >>> in the second state updated value is (12332) ... sory...

>
> >>> On 17 Eylül, 14:25, avcitamer <(E-Mail Removed)> wrote:
> >>>> We upgraded our system and problem below occured, pleas help me...

>
> >>>> Windows 2003 server SP1
> >>>> When I set a decimal DB field value to "123,32" (using
> >>>> ADODB.recordset ) updated value was ok (123.32)

>
> >>>> Windows 2003 server SP2
> >>>> Now when I set a decimal DB field value to "123,32" (using
> >>>> ADODB.recordset ) updated value is (123.32)

>
> >>>> Thanks

>
> >>>> Systems
> >>>> Windows 2003 server Enterprise SP2
> >>>> SqlServer 2000 SP4
> >>>> Activex Data Object 2.8~
> >>>> IIS7, Classsical ASP

>
> >> It sounds like a Regional Settings issue. By default, regional
> >> settings are US. Perhaps you had changed the Regional Settings of
> >> the IUSR account to UK, and the SP restored them to default?

>
> >> --
> >> Microsoft MVP - ASP/ASP.NET
> >> Please reply to the newsgroup. This email account is my spam trap so
> >> I don't check it very often. If you must reply off-line, then remove
> >> the "NO SPAM"- Alýntýyý gizle -

>
> >> - Alýntýyý göster -

>
> --
> Microsoft MVP -- ASP/ASP.NET
> Please reply to the newsgroup. The email account listed in my From
> header is my spam trap, so I don't check it very often. You will get a
> quicker response by posting to the newsgroup.- Alıntıyı gizle -
>
> - Alıntıyı göster -


i solved it by the helps of you.

I checked the checkbox as shown below. It solved...
Regional Settings-->Advenced-->Default User Account Settings--
>[x]Apply all settings to then current user account to the default

user profile.

thanks alot.
 
Reply With Quote
 
Bob Barrows [MVP]
Guest
Posts: n/a
 
      09-18-2008
avcitamer wrote:
> On 17 Eylül, 17:33, "Bob Barrows [MVP]" <(E-Mail Removed)>
> wrote:
>> Never done it myself - I try my best not to write code that is
>> affected by those settings. You could change the password of the
>> account, log onto the machine as that account and use the Regional
>> Settings dialog. But changing the IUSR password can have unwanted
>> consequences, so you can edit the Registry, HKEY_Users/<IUSR
>> node>/Control Panel/International
>>
>> The trick will be to identify the IUSR node ... maybe someone who has
>> done this can jump in. Or perhaps someone has a script to change the
>> regional settings of the IUSR account. You can try the
>> .inetserver.iis group, or the .scripting.vbscript group.

>
> i solved it by the helps of you.
>
> I checked the checkbox as shown below. It solved...
> Regional Settings-->Advenced-->Default User Account Settings--
>> [x]Apply all settings to then current user account to the default

> user profile.
>
> thanks alot.


Good to know - thanks for the follow-up.

--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Value of type Decimal cannot be converted to 1 dimensional array of Decimal Neal Software 0 03-20-2011 03:08 AM
how to convert from Decimal('1.23456789') to Decimal('1.234') valpa Python 11 03-24-2009 07:11 AM
Error: Cannot convert Decimal("0.0000") to Decimal Vitaliy Python 1 05-29-2008 10:36 AM
TypeError: unsupported operand type(s) for -: 'Decimal' and 'Decimal'. Why? Gilbert Fine Python 8 08-01-2007 01:58 AM
Decimal to Packed Decimal Conversion in C++ Ven C++ 3 08-01-2006 03:56 PM



Advertisments