Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP General > Method POST not working

Reply
Thread Tools

Method POST not working

 
 
BLUESTAR
Guest
Posts: n/a
 
      07-15-2008
Here is the link of the website
http://www.smartcharlotte2050.com/YourThoughts.asp

I have been told to change only the form action part of this site.which is
to "response.asp"
Here the method POST is not working,and I dont know how to solve this
problem

I have tried making my own sample. asp page with 4 textareas as in
YourThoughts.asp,and also I have kept the textarea name and ID same as that.

My sample asp is working perfectly fine,in my page method POST is working. I
need to insert content of textarea in database,

But in YourThoughts.asp nothing is being inserted in database .after
clicking the submit button, the page just redirects to response.asp.

Please please help me, how to solve this problem.


Thank You

 
Reply With Quote
 
 
 
 
BLUESTAR
Guest
Posts: n/a
 
      07-15-2008
I forgot to add,is it because YourThoughts.asp have multiple forms,but as far
as I know ASP can have multiple form,also I tried deleting the form "which I
am not suppose to as they dont want any changes in their website" but still
the problem persist.

Please do reply!!!!!!!!

Thank You

"BLUESTAR" wrote:

> Here is the link of the website
> http://www.smartcharlotte2050.com/YourThoughts.asp
>
> I have been told to change only the form action part of this site.which is
> to "response.asp"
> Here the method POST is not working,and I dont know how to solve this
> problem
>
> I have tried making my own sample. asp page with 4 textareas as in
> YourThoughts.asp,and also I have kept the textarea name and ID same as that.
>
> My sample asp is working perfectly fine,in my page method POST is working. I
> need to insert content of textarea in database,
>
> But in YourThoughts.asp nothing is being inserted in database .after
> clicking the submit button, the page just redirects to response.asp.
>
> Please please help me, how to solve this problem.
>
>
> Thank You
>

 
Reply With Quote
 
 
 
 
Mike Brind [MVP]
Guest
Posts: n/a
 
      07-15-2008

"BLUESTAR" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Here is the link of the website
> http://www.smartcharlotte2050.com/YourThoughts.asp
>
> I have been told to change only the form action part of this site.which is
> to "response.asp"
> Here the method POST is not working,and I dont know how to solve this
> problem
>
> I have tried making my own sample. asp page with 4 textareas as in
> YourThoughts.asp,and also I have kept the textarea name and ID same as
> that.
>
> My sample asp is working perfectly fine,in my page method POST is working.
> I
> need to insert content of textarea in database,
>
> But in YourThoughts.asp nothing is being inserted in database .after
> clicking the submit button, the page just redirects to response.asp.
>
> Please please help me, how to solve this problem.
>
>
> Thank You


Since this group deals with asp (which runs on the server and is not
accessible via the browser) perhaps you should post the code that you are
trying to "get to work" and explain the symptoms that lead you to believe it
"is not working".

--
Mike Brind
MVP - ASP/ASP.NET


 
Reply With Quote
 
Old Pedant
Guest
Posts: n/a
 
      07-15-2008
So where is the code for "response.asp"?????


 
Reply With Quote
 
Old Pedant
Guest
Posts: n/a
 
      07-15-2008
"BLUESTAR" wrote:
> I forgot to add,is it because YourThoughts.asp have multiple forms,but as far
> as I know ASP can have multiple form


Nothing to do with ASP. HTML allows as many <FORM> tags on a page as you
want. Only restriction is that they CAN NOT be nested (you can't have a
<FORM> tag *inside* another <FORM>....</FORM> range).

And *ONLY* the <FORM> that is actually submitted by the user will be posted
to the ACTION= specified in that one <FORM>. All other forms are ignored.

This is true whether you are using ASP or PHP or JSP or even just using a
<FORM> to go to another HTML page.

As Mike said, no code, no help. We can't read your mind.


 
Reply With Quote
 
BLUESTAR
Guest
Posts: n/a
 
      07-16-2008

Okay somehow I have solved the error,but now i am stuck in new error.

this is the response.asp code
<%
Set db=Server.CreateObject ("ADODB.Connection")
db.Open "DSN=mysurvey;"
strDate=Date()
for i=1 to 4
res=Request.Form("Your Thoughts Q"&i)
sSQL = "INSERT INTO survey (ID,Response,Date) "
sSQL=sSQL & " VALUES ( '"
sSQL=sSQL & i & "','"
sSQL=sSQL & res & "','"
sSQL=sSQL & strDate & "')"
db.Execute sSQL
Next
db.Close
Response.Write ("Your data has been successfully send.Thanks for your
response!!!")

%>
this the link of the website from where data will be stored in database.
http://www.smartcharlotte2050.com/YourThoughts.asp

The error I am getting

HTTP 500.100 - Internal Server Error - ASP error
Internet Information Services

Technical Information (for support personnel)

* Error Type:
Microsoft OLE DB Provider for ODBC Drivers (0x80040E14)
[Microsoft][ODBC Microsoft Access Driver] Syntax error in INSERT INTO
statement.
/testasp/SurveyResponse.asp, line 13

* Browser Type:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.16)
Gecko/20080702 Firefox/2.0.0.16

* Page:
POST 93 bytes to /testasp/SurveyResponse.asp

* POST Data:

Your+Thoughts+Q1=gf&Your+Thoughts+Q2=dd&Your+Thoug hts+Q3=cc&Your+Thoughts+Q4=bb&Submit=Submit

* Time:
Wednesday, July 16, 2008,

I have even tried the following,but problem persist.

In IE, turn off the "Friendly HTTP error messages" by choosing tools -
internet options - advanced. The full error messages as well as the line
number of the error will then be displayed.


Thanks Again for your support

"Old Pedant" wrote:

> So where is the code for "response.asp"?????
>
>

 
Reply With Quote
 
BLUESTAR
Guest
Posts: n/a
 
      07-16-2008

one more thing to add,the insert statement is working perfectly fine and
even response.asp is working correctly when i run it in sql server 2005.but
when i used Access 2007 the problem occurs.and i will have use Access
only..no escape.

i have configured my connection string same as before,but i don no where am
i wrong
"Old Pedant" wrote:

> So where is the code for "response.asp"?????
>
>

 
Reply With Quote
 
Bob Barrows [MVP]
Guest
Posts: n/a
 
      07-16-2008
BLUESTAR wrote:
> Okay somehow I have solved the error,but now i am stuck in new error.
>
> this is the response.asp code
> <%
> Set db=Server.CreateObject ("ADODB.Connection")
> db.Open "DSN=mysurvey;"
> strDate=Date()
> for i=1 to 4
> res=Request.Form("Your Thoughts Q"&i)
> sSQL = "INSERT INTO survey (ID,Response,Date) "
> sSQL=sSQL & " VALUES ( '"
> sSQL=sSQL & i & "','"
> sSQL=sSQL & res & "','"
> sSQL=sSQL & strDate & "')"
> db.Execute sSQL
> Next
> db.Close
> Response.Write ("Your data has been successfully send.Thanks for your
> response!!!")
>
> %>

<snip>
> * Error Type:
> Microsoft OLE DB Provider for ODBC Drivers (0x80040E14)
> [Microsoft][ODBC Microsoft Access Driver] Syntax error in
> INSERT INTO statement.
> /testasp/SurveyResponse.asp, line 13
>


You cannot debug a sql statement without knowing what it is. Insert the
following before the Execute statement:

'***********comment out when finished debugging*******
Response.Write sSQL & "<BR>"
Response.End
'***********comment out when finished debugging*******

Run the page and look at the resulting sql statement. The error should
stick out like a sore thumb. If not post it here.

Further points to consider:
Your use of dynamic sql is leaving you vulnerable to hackers using sql
injection:
http://mvp.unixwiz.net/techtips/sql-injection.html
http://www.sqlsecurity.com/DesktopDefault.aspx?tabid=23

See here for a better, more secure way to execute your queries by using
parameter markers (tokens):
http://groups-beta.google.com/group/...e36562fee7804e

Personally, I prefer using stored procedures, or saved parameter queries
as they are known in Access:

Access:
http://www.google.com/groups?hl=en&l...TNGP12.phx.gbl

http://groups.google.com/groups?hl=e...tngp13.phx.gbl

SQL Server:
http://groups.google.com/group/micro...09dc1701?hl=en


>
> I have even tried the following,but problem persist.
>
> In IE, turn off the "Friendly HTTP error messages" by choosing tools -
> internet options - advanced. The full error messages as well as the
> line number of the error will then be displayed.
>

Friendly Errors was already disabled
--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.


 
Reply With Quote
 
BLUESTAR
Guest
Posts: n/a
 
      07-16-2008

thanks for reply

but after adding Response.Write sSQL & "<BR>"
Response.End

I am getting this
INSERT INTO survey (ID,Response,todaydate) VALUES ( '1','s','7/16/2008')
but i have used for loop which will insert 4 datas,but here i am showed only
one.

so what do you think ,my INSERT query is correct?????
but nothing is being inserted in database.
my problem is i am not use to Microsoft Access,

Please do reply

Thanks
"BLUESTAR" wrote:

>
> one more thing to add,the insert statement is working perfectly fine and
> even response.asp is working correctly when i run it in sql server 2005.but
> when i used Access 2007 the problem occurs.and i will have use Access
> only..no escape.
>
> i have configured my connection string same as before,but i don no where am
> i wrong
> "Old Pedant" wrote:
>
> > So where is the code for "response.asp"?????
> >
> >

 
Reply With Quote
 
BLUESTAR
Guest
Posts: n/a
 
      07-16-2008

Now I am getting this error
rror Type:
Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
[Microsoft][ODBC Microsoft Access Driver] Operation must use an updateable
query.
/testasp/SurveyResponse.asp, line 16

line 16 is db.Execute sSQL



"BLUESTAR" wrote:

>
> thanks for reply
>
> but after adding Response.Write sSQL & "<BR>"
> Response.End
>
> I am getting this
> INSERT INTO survey (ID,Response,todaydate) VALUES ( '1','s','7/16/2008')
> but i have used for loop which will insert 4 datas,but here i am showed only
> one.
>
> so what do you think ,my INSERT query is correct?????
> but nothing is being inserted in database.
> my problem is i am not use to Microsoft Access,
>
> Please do reply
>
> Thanks
> "BLUESTAR" wrote:
>
> >
> > one more thing to add,the insert statement is working perfectly fine and
> > even response.asp is working correctly when i run it in sql server 2005.but
> > when i used Access 2007 the problem occurs.and i will have use Access
> > only..no escape.
> >
> > i have configured my connection string same as before,but i don no where am
> > i wrong
> > "Old Pedant" wrote:
> >
> > > So where is the code for "response.asp"?????
> > >
> > >

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
method def in method vs method def in block Kyung won Cheon Ruby 0 11-21-2008 08:48 AM
HttpWebRequest Post with ClientCertificates working in Debug and VS, but not working in IIS calebmeii@gmail.com ASP .Net 0 06-29-2007 04:55 PM
Post data via the Post method in asp.net? (URGENT) Vishal ASP .Net 1 12-21-2004 06:14 AM
Post post post. Shel-hed Computer Support 2 11-08-2003 07:41 AM
ASP, FORMS, POST METHOD And Post with out form(???) Don Glover the younger ASP General 0 07-13-2003 02:47 AM



Advertisments