Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP General > ASP.NET application ends unexpectedly

Reply
Thread Tools

ASP.NET application ends unexpectedly

 
 
Olivier GIL
Guest
Posts: n/a
 
      01-24-2008
Hello,

I wrote an ASP.NET 2.0 application that ends unexpectedly sometimes,
generally when I launch resource consuming methods like intensive database
accesses.

No application error is generated, and no event is logged on Windows event
log.

I tried to use ProcessModelInfo.GetCurrentProcessInfo in my Application_End
handler to get the ShutdownReason, but the code throws then an HttpException
saying that the process metrics are only available if ASP process model is
enabled.

Though, ASP process model seems to be active on my machine.config as it is
enabled by default :

<section name="processModel"
type="System.Web.Configuration.ProcessModelSection , System.Web,
Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"
allowDefinition="MachineOnly" allowLocation="false" />

<processModel autoConfig="true" />

I use .NET 2.0 and IIS 5.1 (XP Pro version).

How can I trace the reason why my application end ?

--
Olivier GIL
LAFON SA
 
Reply With Quote
 
 
 
 
Olivier GIL
Guest
Posts: n/a
 
      01-25-2008
Hi,

How should I turn tracing on ?
--
Olivier GIL
LAFON SA


"Jon Paal [MSMD]" wrote:

> turn on tracing and post further questions here:
>
> microsoft.public.dotnet.framework.aspnet
>
>
>

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Visual Studio Shuts Down Unexpectedly When Loading Project - ASP.NET Web Application running against IIS Cramer ASP .Net 1 04-08-2008 11:20 AM
aspnet_wp.exe stopped unexpectedly and Server Application Unavailable Paul Wasowicz ASP .Net 1 04-04-2006 09:20 PM
server application aspnet_wp.exe stopped unexpectedly unavailable phancey@2bytes.co.uk ASP .Net 4 05-16-2005 01:01 PM
Server Application Unavailable / aspnet_wp.exe (PID: 384) stopped unexpectedly. Erik Lindeblom ASP .Net 2 01-13-2005 08:03 AM
HttpModule not firing when Session/Application ends =?Utf-8?B?V2lsbA==?= ASP .Net 2 01-23-2004 09:56 AM



Advertisments