Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP General > Data Access Vista/IIS&/Access2000

Reply
Thread Tools

Data Access Vista/IIS&/Access2000

 
 
hugh welford
Guest
Posts: n/a
 
      08-26-2007
Hi

Have just installed IIS7 on Vista and am trying to access a .mdb file
through ASP. Getting server error.

I think the problem is in the file permission. Under XP Pro/IIS6 is used to
have to set the .mdb file security via windows explorer to give
IUSR_machinename full permissions on this file for anonymous web access.

Cant seem to do this with Vista explorer - says object cannot be found.

Also, getting conflicting statements from IIS Help - it tells me firstly
that

a. By default, IIS 7.0 uses IUSR as the account for anonymous access.
This account is created when you install IIS 7.0.

and then

b. Similarly, a new Windows built-in account named IUSRS replaces the
local IUSR_MachineName anonymous account from IIS 6.0.

Anyway, whatever syntax I use, I cant seem to add anonymous web user
permission to daters.mdb via the security tab in Windown Explorer.

Any help greatly appreciated - getting very frustrated

Thanks

Hugh

 
Reply With Quote
 
 
 
 
Bob Milutinovic
Guest
Posts: n/a
 
      08-27-2007
"hugh welford" <(E-Mail Removed)> wrote in message
news:%(E-Mail Removed)...
> Hi
>
> Have just installed IIS7 on Vista and am trying to access a .mdb file
> through ASP. Getting server error.


I know this is a Microsoft group and I'll get shot down for saying this,
but...

1. Remove Vista
2. Revert to XP Pro (or preferably Server 2003)
3. Wait 18 months to 2 years for sufficient servicepacks to render Vista
usable.

Past experience has shown (think back even to MS-DOS 4) that you should
never trust a new operating system for any critical use. Might be great for
games, but wait 'til it's had at least the major failings ironed out before
using it for work.

--
Bob Milutinovic
Cognicom - "Australia's Web Presence Specialists"
http://www.cognicom.net.au/
telephone (0417) 45-77-66
facsimile (02) 9824-2240


 
Reply With Quote
 
 
 
 
Bob Barrows [MVP]
Guest
Posts: n/a
 
      08-27-2007
hugh welford wrote:
> Hi
>
> Have just installed IIS7 on Vista and am trying to access a .mdb file
> through ASP. Getting server error.
>


Huh? What is the error message?

> I think the problem is in the file permission.


Why? Does the error message give you a clue?
If it IS a file permission error, you need to figure out how to assign
Modify permissions for the folder containing the file to ALL users of the
database file. Try posting to a Vista group for help with that, or maybe
someone in the iis group will be able to help.

--
Microsoft MVP - ASP/ASP.NET
Please reply to the newsgroup. This email account is my spam trap so I
don't check it very often. If you must reply off-line, then remove the
"NO SPAM"


 
Reply With Quote
 
hugh welford
Guest
Posts: n/a
 
      08-27-2007
thanks Bob - already thinking along these lines

hugh


"Bob Milutinovic" <(E-Mail Removed)> wrote in message
news:%(E-Mail Removed)...
> "hugh welford" <(E-Mail Removed)> wrote in message
> news:%(E-Mail Removed)...
>> Hi
>>
>> Have just installed IIS7 on Vista and am trying to access a .mdb file
>> through ASP. Getting server error.

>
> I know this is a Microsoft group and I'll get shot down for saying this,
> but...
>
> 1. Remove Vista
> 2. Revert to XP Pro (or preferably Server 2003)
> 3. Wait 18 months to 2 years for sufficient servicepacks to render Vista
> usable.
>
> Past experience has shown (think back even to MS-DOS 4) that you should
> never trust a new operating system for any critical use. Might be great
> for games, but wait 'til it's had at least the major failings ironed out
> before using it for work.
>
> --
> Bob Milutinovic
> Cognicom - "Australia's Web Presence Specialists"
> http://www.cognicom.net.au/
> telephone (0417) 45-77-66
> facsimile (02) 9824-2240
>
>


 
Reply With Quote
 
hugh welford
Guest
Posts: n/a
 
      08-27-2007
Hi Bob

Thanks for reply.

The error merssage is the non-specific "An error occurred on the server when
processing the URL" - not much help is it?

I am assuming that the error is a permissions problem, as I have not been
able to set the full permissions for the file - hence the post. I will
re-post in vista and iis groups as suggested - thanks.

Hugh

"Bob Barrows [MVP]" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> hugh welford wrote:
>> Hi
>>
>> Have just installed IIS7 on Vista and am trying to access a .mdb file
>> through ASP. Getting server error.
>>

>
> Huh? What is the error message?
>
>> I think the problem is in the file permission.

>
> Why? Does the error message give you a clue?
> If it IS a file permission error, you need to figure out how to assign
> Modify permissions for the folder containing the file to ALL users of the
> database file. Try posting to a Vista group for help with that, or maybe
> someone in the iis group will be able to help.
>
> --
> Microsoft MVP - ASP/ASP.NET
> Please reply to the newsgroup. This email account is my spam trap so I
> don't check it very often. If you must reply off-line, then remove the
> "NO SPAM"
>


 
Reply With Quote
 
Bob Barrows [MVP]
Guest
Posts: n/a
 
      08-27-2007
Well your first step should be to shut off "friendly errors".
This can be done in IIS Manager and may also need to be done in the
browser you are using.



hugh welford wrote:
> Hi Bob
>
> Thanks for reply.
>
> The error merssage is the non-specific "An error occurred on the
> server when processing the URL" - not much help is it?
>
> I am assuming that the error is a permissions problem, as I have not
> been able to set the full permissions for the file - hence the post.
> I will re-post in vista and iis groups as suggested - thanks.
>
> Hugh
>
> "Bob Barrows [MVP]" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>> hugh welford wrote:
>>> Hi
>>>
>>> Have just installed IIS7 on Vista and am trying to access a .mdb
>>> file through ASP. Getting server error.
>>>

>>
>> Huh? What is the error message?
>>
>>> I think the problem is in the file permission.

>>
>> Why? Does the error message give you a clue?
>> If it IS a file permission error, you need to figure out how to
>> assign Modify permissions for the folder containing the file to ALL
>> users of the database file. Try posting to a Vista group for help
>> with that, or maybe someone in the iis group will be able to help.
>>
>> --
>> Microsoft MVP - ASP/ASP.NET
>> Please reply to the newsgroup. This email account is my spam trap so
>> I don't check it very often. If you must reply off-line, then remove
>> the "NO SPAM"


--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.


 
Reply With Quote
 
hugh welford
Guest
Posts: n/a
 
      08-27-2007
Thanks Bob.

Made a few changes, and now getting unspecified error on trying to open a
connection with the string

cst = "Provider=Microsoft.Jet.OLEDB.4.0;" & "Data
Source=c:/access/brits/daters.mdb"

Presume new Provider with Vista.

Any idea what the correct string should be under Vista???

Thanks

Hugh


"Bob Barrows [MVP]" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Well your first step should be to shut off "friendly errors".
> This can be done in IIS Manager and may also need to be done in the
> browser you are using.
>
>
>
> hugh welford wrote:
>> Hi Bob
>>
>> Thanks for reply.
>>
>> The error merssage is the non-specific "An error occurred on the
>> server when processing the URL" - not much help is it?
>>
>> I am assuming that the error is a permissions problem, as I have not
>> been able to set the full permissions for the file - hence the post.
>> I will re-post in vista and iis groups as suggested - thanks.
>>
>> Hugh
>>
>> "Bob Barrows [MVP]" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed)...
>>> hugh welford wrote:
>>>> Hi
>>>>
>>>> Have just installed IIS7 on Vista and am trying to access a .mdb
>>>> file through ASP. Getting server error.
>>>>
>>>
>>> Huh? What is the error message?
>>>
>>>> I think the problem is in the file permission.
>>>
>>> Why? Does the error message give you a clue?
>>> If it IS a file permission error, you need to figure out how to
>>> assign Modify permissions for the folder containing the file to ALL
>>> users of the database file. Try posting to a Vista group for help
>>> with that, or maybe someone in the iis group will be able to help.
>>>
>>> --
>>> Microsoft MVP - ASP/ASP.NET
>>> Please reply to the newsgroup. This email account is my spam trap so
>>> I don't check it very often. If you must reply off-line, then remove
>>> the "NO SPAM"

>
> --
> Microsoft MVP -- ASP/ASP.NET
> Please reply to the newsgroup. The email account listed in my From
> header is my spam trap, so I don't check it very often. You will get a
> quicker response by posting to the newsgroup.
>
>


 
Reply With Quote
 
Bob Barrows [MVP]
Guest
Posts: n/a
 
      08-27-2007
No, there is no new provider for Vista per se.
However, there IS a new provider for Access 2007 if that is what you are
using. See www.connectionstrings.com

hugh welford wrote:
> Thanks Bob.
>
> Made a few changes, and now getting unspecified error on trying to
> open a connection with the string
>
> cst = "Provider=Microsoft.Jet.OLEDB.4.0;" & "Data
> Source=c:/access/brits/daters.mdb"
>
> Presume new Provider with Vista.
>
> Any idea what the correct string should be under Vista???
>
> Thanks
>
> Hugh
>
>
> "Bob Barrows [MVP]" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>> Well your first step should be to shut off "friendly errors".
>> This can be done in IIS Manager and may also need to be done in the
>> browser you are using.
>>
>>
>>
>> hugh welford wrote:
>>> Hi Bob
>>>
>>> Thanks for reply.
>>>
>>> The error merssage is the non-specific "An error occurred on the
>>> server when processing the URL" - not much help is it?
>>>
>>> I am assuming that the error is a permissions problem, as I have not
>>> been able to set the full permissions for the file - hence the post.
>>> I will re-post in vista and iis groups as suggested - thanks.
>>>
>>> Hugh
>>>
>>> "Bob Barrows [MVP]" <(E-Mail Removed)> wrote in message
>>> news:(E-Mail Removed)...
>>>> hugh welford wrote:
>>>>> Hi
>>>>>
>>>>> Have just installed IIS7 on Vista and am trying to access a .mdb
>>>>> file through ASP. Getting server error.
>>>>>
>>>>
>>>> Huh? What is the error message?
>>>>
>>>>> I think the problem is in the file permission.
>>>>
>>>> Why? Does the error message give you a clue?
>>>> If it IS a file permission error, you need to figure out how to
>>>> assign Modify permissions for the folder containing the file to ALL
>>>> users of the database file. Try posting to a Vista group for help
>>>> with that, or maybe someone in the iis group will be able to help.
>>>>
>>>> --
>>>> Microsoft MVP - ASP/ASP.NET
>>>> Please reply to the newsgroup. This email account is my spam trap
>>>> so I don't check it very often. If you must reply off-line, then
>>>> remove the "NO SPAM"

>>
>> --
>> Microsoft MVP -- ASP/ASP.NET
>> Please reply to the newsgroup. The email account listed in my From
>> header is my spam trap, so I don't check it very often. You will get
>> a quicker response by posting to the newsgroup.


--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.


 
Reply With Quote
 
hugh welford
Guest
Posts: n/a
 
      08-27-2007
Thanks again, Bob.

It was permissions after all - it appears the following must have full
control permissions for IUSR and IIS_IUSRS accounts

a. The .mdb file to be accessed
b. C:\Windows\Temp
c. C:\Windows\ServiceProfiles\NetworkService\AppData\ Local\Temp

Hope this is useful

Regards

Hugh


"Bob Barrows [MVP]" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> No, there is no new provider for Vista per se.
> However, there IS a new provider for Access 2007 if that is what you are
> using. See www.connectionstrings.com
>
> hugh welford wrote:
>> Thanks Bob.
>>
>> Made a few changes, and now getting unspecified error on trying to
>> open a connection with the string
>>
>> cst = "Provider=Microsoft.Jet.OLEDB.4.0;" & "Data
>> Source=c:/access/brits/daters.mdb"
>>
>> Presume new Provider with Vista.
>>
>> Any idea what the correct string should be under Vista???
>>
>> Thanks
>>
>> Hugh
>>
>>
>> "Bob Barrows [MVP]" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed)...
>>> Well your first step should be to shut off "friendly errors".
>>> This can be done in IIS Manager and may also need to be done in the
>>> browser you are using.
>>>
>>>
>>>
>>> hugh welford wrote:
>>>> Hi Bob
>>>>
>>>> Thanks for reply.
>>>>
>>>> The error merssage is the non-specific "An error occurred on the
>>>> server when processing the URL" - not much help is it?
>>>>
>>>> I am assuming that the error is a permissions problem, as I have not
>>>> been able to set the full permissions for the file - hence the post.
>>>> I will re-post in vista and iis groups as suggested - thanks.
>>>>
>>>> Hugh
>>>>
>>>> "Bob Barrows [MVP]" <(E-Mail Removed)> wrote in message
>>>> news:(E-Mail Removed)...
>>>>> hugh welford wrote:
>>>>>> Hi
>>>>>>
>>>>>> Have just installed IIS7 on Vista and am trying to access a .mdb
>>>>>> file through ASP. Getting server error.
>>>>>>
>>>>>
>>>>> Huh? What is the error message?
>>>>>
>>>>>> I think the problem is in the file permission.
>>>>>
>>>>> Why? Does the error message give you a clue?
>>>>> If it IS a file permission error, you need to figure out how to
>>>>> assign Modify permissions for the folder containing the file to ALL
>>>>> users of the database file. Try posting to a Vista group for help
>>>>> with that, or maybe someone in the iis group will be able to help.
>>>>>
>>>>> --
>>>>> Microsoft MVP - ASP/ASP.NET
>>>>> Please reply to the newsgroup. This email account is my spam trap
>>>>> so I don't check it very often. If you must reply off-line, then
>>>>> remove the "NO SPAM"
>>>
>>> --
>>> Microsoft MVP -- ASP/ASP.NET
>>> Please reply to the newsgroup. The email account listed in my From
>>> header is my spam trap, so I don't check it very often. You will get
>>> a quicker response by posting to the newsgroup.

>
> --
> Microsoft MVP -- ASP/ASP.NET
> Please reply to the newsgroup. The email account listed in my From
> header is my spam trap, so I don't check it very often. You will get a
> quicker response by posting to the newsgroup.
>
>


 
Reply With Quote
 
Bob Barrows [MVP]
Guest
Posts: n/a
 
      08-28-2007
"Full" permissions is overkill. All that is required is "Modify". The
users do not need the ability to assign permissions. Always work from
the standpoint of assigning the least level of permission required to
perform the task. In this case, users need to be able to create, modify
and delete a locking file to enable multi-user access to the mdb file.
The only permission required for that is "Modify", known as "Read/Write"
in some OSs.

hugh welford wrote:
> Thanks again, Bob.
>
> It was permissions after all - it appears the following must have full
> control permissions for IUSR and IIS_IUSRS accounts
>
> a. The .mdb file to be accessed
> b. C:\Windows\Temp
> c. C:\Windows\ServiceProfiles\NetworkService\AppData\ Local\Temp
>
> Hope this is useful
>
> Regards
>
> Hugh
>
>
> "Bob Barrows [MVP]" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
>> No, there is no new provider for Vista per se.
>> However, there IS a new provider for Access 2007 if that is what you
>> are using. See www.connectionstrings.com
>>
>> hugh welford wrote:
>>> Thanks Bob.
>>>
>>> Made a few changes, and now getting unspecified error on trying to
>>> open a connection with the string
>>>
>>> cst = "Provider=Microsoft.Jet.OLEDB.4.0;" & "Data
>>> Source=c:/access/brits/daters.mdb"
>>>
>>> Presume new Provider with Vista.
>>>
>>> Any idea what the correct string should be under Vista???
>>>
>>> Thanks
>>>
>>> Hugh
>>>
>>>
>>> "Bob Barrows [MVP]" <(E-Mail Removed)> wrote in message
>>> news:(E-Mail Removed)...
>>>> Well your first step should be to shut off "friendly errors".
>>>> This can be done in IIS Manager and may also need to be done in the
>>>> browser you are using.
>>>>
>>>>
>>>>
>>>> hugh welford wrote:
>>>>> Hi Bob
>>>>>
>>>>> Thanks for reply.
>>>>>
>>>>> The error merssage is the non-specific "An error occurred on the
>>>>> server when processing the URL" - not much help is it?
>>>>>
>>>>> I am assuming that the error is a permissions problem, as I have
>>>>> not been able to set the full permissions for the file - hence
>>>>> the post. I will re-post in vista and iis groups as suggested -
>>>>> thanks.
>>>>>
>>>>> Hugh
>>>>>
>>>>> "Bob Barrows [MVP]" <(E-Mail Removed)> wrote in message
>>>>> news:(E-Mail Removed)...
>>>>>> hugh welford wrote:
>>>>>>> Hi
>>>>>>>
>>>>>>> Have just installed IIS7 on Vista and am trying to access a .mdb
>>>>>>> file through ASP. Getting server error.
>>>>>>>
>>>>>>
>>>>>> Huh? What is the error message?
>>>>>>
>>>>>>> I think the problem is in the file permission.
>>>>>>
>>>>>> Why? Does the error message give you a clue?
>>>>>> If it IS a file permission error, you need to figure out how to
>>>>>> assign Modify permissions for the folder containing the file to
>>>>>> ALL users of the database file. Try posting to a Vista group for
>>>>>> help with that, or maybe someone in the iis group will be able
>>>>>> to help.
>>>>>>
>>>>>> --
>>>>>> Microsoft MVP - ASP/ASP.NET
>>>>>> Please reply to the newsgroup. This email account is my spam trap
>>>>>> so I don't check it very often. If you must reply off-line, then
>>>>>> remove the "NO SPAM"
>>>>
>>>> --
>>>> Microsoft MVP -- ASP/ASP.NET
>>>> Please reply to the newsgroup. The email account listed in my From
>>>> header is my spam trap, so I don't check it very often. You will
>>>> get a quicker response by posting to the newsgroup.

>>
>> --
>> Microsoft MVP -- ASP/ASP.NET
>> Please reply to the newsgroup. The email account listed in my From
>> header is my spam trap, so I don't check it very often. You will get
>> a quicker response by posting to the newsgroup.


--
Microsoft MVP -- ASP/ASP.NET
Please reply to the newsgroup. The email account listed in my From
header is my spam trap, so I don't check it very often. You will get a
quicker response by posting to the newsgroup.


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XML data access or DB data access ? Savvoulidis Iordanis ASP .Net 2 01-07-2009 10:47 PM
Very annoying error: Access to the path is denied. ASP.NET is not authorized to access the requested resource. Consider granting access rights to the resource to the ASP.NET request identity Jay ASP .Net 2 08-20-2007 07:38 PM
403 Forbidden: You were denied access because: Access denied by access control list Southern Kiwi NZ Computing 6 03-19-2006 05:19 AM
How do I let people access the internet via an access point but not allow them access to my network yar Wireless Networking 4 09-21-2004 03:48 AM
data access error with access 97 (jet) david ASP .Net 2 11-24-2003 09:18 PM



Advertisments