Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > the development environment is overzealously formatting my html when switching from design to code view

Reply
Thread Tools

the development environment is overzealously formatting my html when switching from design to code view

 
 
Jacob Crossley
Guest
Posts: n/a
 
      06-09-2004
Please tell me there is a way to prevent this annoyance ; - )

I'm into writing perfectly indented html, but the .net dev environment is
being overzealous and messing up my html formatting.

for example, I originally write:

<table>
<tr>
<td>
<asp:label id="lblSuccess" runat="server">
</asp:/label>
</td>
</tr>
</table>

then the dev environment switches it to something like:

<table>
<tr>
<td><asp:label id="lblSuccess" runat="server"></asp:/label>
</td></tr></table>


I'm running the latest version of .net --version 7.1.3088
I've run through the tools/options and placed the envirionment to do the
least amount of microsoftesque-preemptive formatting.

Please HELP!!! If there is no solution I think I'm gonna code .net stuff in
notepad until I can get a linux, bsd or UNIX job...lol jk. I've been an MS
developer for years!



 
Reply With Quote
 
 
 
 
Curt_C [MVP]
Guest
Posts: n/a
 
      06-09-2004
it's a setting in the options of VS.....

--
Curt Christianson
Owner/Lead Developer, DF-Software
Site: http://www.Darkfalz.com
Blog: http://blog.Darkfalz.com


"Jacob Crossley" <(E-Mail Removed)> wrote in message
news:dTHxc.405$(E-Mail Removed)...
> Please tell me there is a way to prevent this annoyance ; - )
>
> I'm into writing perfectly indented html, but the .net dev environment is
> being overzealous and messing up my html formatting.
>
> for example, I originally write:
>
> <table>
> <tr>
> <td>
> <asp:label id="lblSuccess" runat="server">
> </asp:/label>
> </td>
> </tr>
> </table>
>
> then the dev environment switches it to something like:
>
> <table>
> <tr>
> <td><asp:label id="lblSuccess" runat="server"></asp:/label>
> </td></tr></table>
>
>
> I'm running the latest version of .net --version 7.1.3088
> I've run through the tools/options and placed the envirionment to do the
> least amount of microsoftesque-preemptive formatting.
>
> Please HELP!!! If there is no solution I think I'm gonna code .net stuff

in
> notepad until I can get a linux, bsd or UNIX job...lol jk. I've been an

MS
> developer for years!
>
>
>



 
Reply With Quote
 
 
 
 
Jacob Crossley
Guest
Posts: n/a
 
      06-09-2004
which setting? I've tried them all!


"Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
news:(E-Mail Removed)...
> it's a setting in the options of VS.....
>
> --
> Curt Christianson
> Owner/Lead Developer, DF-Software
> Site: http://www.Darkfalz.com
> Blog: http://blog.Darkfalz.com
>
>
> "Jacob Crossley" <(E-Mail Removed)> wrote in message
> news:dTHxc.405$(E-Mail Removed)...
> > Please tell me there is a way to prevent this annoyance ; - )
> >
> > I'm into writing perfectly indented html, but the .net dev environment

is
> > being overzealous and messing up my html formatting.
> >
> > for example, I originally write:
> >
> > <table>
> > <tr>
> > <td>
> > <asp:label id="lblSuccess" runat="server">
> > </asp:/label>
> > </td>
> > </tr>
> > </table>
> >
> > then the dev environment switches it to something like:
> >
> > <table>
> > <tr>
> > <td><asp:label id="lblSuccess" runat="server"></asp:/label>
> > </td></tr></table>
> >
> >
> > I'm running the latest version of .net --version 7.1.3088
> > I've run through the tools/options and placed the envirionment to do the
> > least amount of microsoftesque-preemptive formatting.
> >
> > Please HELP!!! If there is no solution I think I'm gonna code .net

stuff
> in
> > notepad until I can get a linux, bsd or UNIX job...lol jk. I've been an

> MS
> > developer for years!
> >
> >
> >

>
>




 
Reply With Quote
 
Curt_C [MVP]
Guest
Posts: n/a
 
      06-09-2004
Tools
Options
Text Editor
HTML/XML
Format

Try the settings there.

--
Curt Christianson
Owner/Lead Developer, DF-Software
Site: http://www.Darkfalz.com
Blog: http://blog.Darkfalz.com


"Jacob Crossley" <(E-Mail Removed)> wrote in message
news:_7Jxc.408$(E-Mail Removed)...
> which setting? I've tried them all!
>
>
> "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
> news:(E-Mail Removed)...
> > it's a setting in the options of VS.....
> >
> > --
> > Curt Christianson
> > Owner/Lead Developer, DF-Software
> > Site: http://www.Darkfalz.com
> > Blog: http://blog.Darkfalz.com
> >
> >
> > "Jacob Crossley" <(E-Mail Removed)> wrote in message
> > news:dTHxc.405$(E-Mail Removed)...
> > > Please tell me there is a way to prevent this annoyance ; - )
> > >
> > > I'm into writing perfectly indented html, but the .net dev environment

> is
> > > being overzealous and messing up my html formatting.
> > >
> > > for example, I originally write:
> > >
> > > <table>
> > > <tr>
> > > <td>
> > > <asp:label id="lblSuccess" runat="server">
> > > </asp:/label>
> > > </td>
> > > </tr>
> > > </table>
> > >
> > > then the dev environment switches it to something like:
> > >
> > > <table>
> > > <tr>
> > > <td><asp:label id="lblSuccess" runat="server"></asp:/label>
> > > </td></tr></table>
> > >
> > >
> > > I'm running the latest version of .net --version 7.1.3088
> > > I've run through the tools/options and placed the envirionment to do

the
> > > least amount of microsoftesque-preemptive formatting.
> > >
> > > Please HELP!!! If there is no solution I think I'm gonna code .net

> stuff
> > in
> > > notepad until I can get a linux, bsd or UNIX job...lol jk. I've been

an
> > MS
> > > developer for years!
> > >
> > >
> > >

> >
> >

>
>
>



 
Reply With Quote
 
Jacob Crossley
Guest
Posts: n/a
 
      06-09-2004
You are wrong. You are just guessing. Its best not to answer questions
unless you have a specific and tested answer. Please excuse my bluntness.
"Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
news:%(E-Mail Removed)...
> Tools
> Options
> Text Editor
> HTML/XML
> Format
>
> Try the settings there.
>
> --
> Curt Christianson
> Owner/Lead Developer, DF-Software
> Site: http://www.Darkfalz.com
> Blog: http://blog.Darkfalz.com
>
>
> "Jacob Crossley" <(E-Mail Removed)> wrote in message
> news:_7Jxc.408$(E-Mail Removed)...
> > which setting? I've tried them all!
> >
> >
> > "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
> > news:(E-Mail Removed)...
> > > it's a setting in the options of VS.....
> > >
> > > --
> > > Curt Christianson
> > > Owner/Lead Developer, DF-Software
> > > Site: http://www.Darkfalz.com
> > > Blog: http://blog.Darkfalz.com
> > >
> > >
> > > "Jacob Crossley" <(E-Mail Removed)> wrote in message
> > > news:dTHxc.405$(E-Mail Removed)...
> > > > Please tell me there is a way to prevent this annoyance ; - )
> > > >
> > > > I'm into writing perfectly indented html, but the .net dev

environment
> > is
> > > > being overzealous and messing up my html formatting.
> > > >
> > > > for example, I originally write:
> > > >
> > > > <table>
> > > > <tr>
> > > > <td>
> > > > <asp:label id="lblSuccess" runat="server">
> > > > </asp:/label>
> > > > </td>
> > > > </tr>
> > > > </table>
> > > >
> > > > then the dev environment switches it to something like:
> > > >
> > > > <table>
> > > > <tr>
> > > > <td><asp:label id="lblSuccess" runat="server"></asp:/label>
> > > > </td></tr></table>
> > > >
> > > >
> > > > I'm running the latest version of .net --version 7.1.3088
> > > > I've run through the tools/options and placed the envirionment to do

> the
> > > > least amount of microsoftesque-preemptive formatting.
> > > >
> > > > Please HELP!!! If there is no solution I think I'm gonna code .net

> > stuff
> > > in
> > > > notepad until I can get a linux, bsd or UNIX job...lol jk. I've

been
> an
> > > MS
> > > > developer for years!
> > > >
> > > >
> > > >
> > >
> > >

> >
> >
> >

>
>




 
Reply With Quote
 
Curt_C [MVP]
Guest
Posts: n/a
 
      06-09-2004
Yeah, whatever you say.

PLONK - Killfile

--
Curt Christianson
Owner/Lead Developer, DF-Software
Site: http://www.Darkfalz.com
Blog: http://blog.Darkfalz.com


"Jacob Crossley" <(E-Mail Removed)> wrote in message
news:6IJxc.410$(E-Mail Removed)...
> You are wrong. You are just guessing. Its best not to answer questions
> unless you have a specific and tested answer. Please excuse my bluntness.
> "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
> news:%(E-Mail Removed)...
> > Tools
> > Options
> > Text Editor
> > HTML/XML
> > Format
> >
> > Try the settings there.
> >
> > --
> > Curt Christianson
> > Owner/Lead Developer, DF-Software
> > Site: http://www.Darkfalz.com
> > Blog: http://blog.Darkfalz.com
> >
> >
> > "Jacob Crossley" <(E-Mail Removed)> wrote in message
> > news:_7Jxc.408$(E-Mail Removed)...
> > > which setting? I've tried them all!
> > >
> > >
> > > "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
> > > news:(E-Mail Removed)...
> > > > it's a setting in the options of VS.....
> > > >
> > > > --
> > > > Curt Christianson
> > > > Owner/Lead Developer, DF-Software
> > > > Site: http://www.Darkfalz.com
> > > > Blog: http://blog.Darkfalz.com
> > > >
> > > >
> > > > "Jacob Crossley" <(E-Mail Removed)> wrote in message
> > > > news:dTHxc.405$(E-Mail Removed)...
> > > > > Please tell me there is a way to prevent this annoyance ; - )
> > > > >
> > > > > I'm into writing perfectly indented html, but the .net dev

> environment
> > > is
> > > > > being overzealous and messing up my html formatting.
> > > > >
> > > > > for example, I originally write:
> > > > >
> > > > > <table>
> > > > > <tr>
> > > > > <td>
> > > > > <asp:label id="lblSuccess" runat="server">
> > > > > </asp:/label>
> > > > > </td>
> > > > > </tr>
> > > > > </table>
> > > > >
> > > > > then the dev environment switches it to something like:
> > > > >
> > > > > <table>
> > > > > <tr>
> > > > > <td><asp:label id="lblSuccess"

runat="server"></asp:/label>
> > > > > </td></tr></table>
> > > > >
> > > > >
> > > > > I'm running the latest version of .net --version 7.1.3088
> > > > > I've run through the tools/options and placed the envirionment to

do
> > the
> > > > > least amount of microsoftesque-preemptive formatting.
> > > > >
> > > > > Please HELP!!! If there is no solution I think I'm gonna code

..net
> > > stuff
> > > > in
> > > > > notepad until I can get a linux, bsd or UNIX job...lol jk. I've

> been
> > an
> > > > MS
> > > > > developer for years!
> > > > >
> > > > >
> > > > >
> > > >
> > > >
> > >
> > >
> > >

> >
> >

>
>
>



 
Reply With Quote
 
Jacob Crossley
Guest
Posts: n/a
 
      06-09-2004
See the problem is that you acted like you know the answer, so now a
microsoft employee monitoring this board will assume that my question was
answered. At the bottom of my initial post I mentioned I had already run
through the tools /options. of VS and put them all on settings that do the
least amount of work.

Nothing against you personally, but please don't give unspecific answers
that don't work. That diminishes the quality of the board for the rest of
us. Also be sure to read the full thread before answering. If you'd have
done that in this case, you'd have known that even your third attempt to
answer was inadequate. Were you such a pain in the a## to your teachers when
you were in school---always wanting cheap credit for rushing to give the
obvious answer that all the other students knew, but not exactly what the
teacher asked for?


"Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
news:(E-Mail Removed)...
> Yeah, whatever you say.
>
> PLONK - Killfile
>
> --
> Curt Christianson
> Owner/Lead Developer, DF-Software
> Site: http://www.Darkfalz.com
> Blog: http://blog.Darkfalz.com
>
>
> "Jacob Crossley" <(E-Mail Removed)> wrote in message
> news:6IJxc.410$(E-Mail Removed)...
> > You are wrong. You are just guessing. Its best not to answer questions
> > unless you have a specific and tested answer. Please excuse my

bluntness.
> > "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
> > news:%(E-Mail Removed)...
> > > Tools
> > > Options
> > > Text Editor
> > > HTML/XML
> > > Format
> > >
> > > Try the settings there.
> > >
> > > --
> > > Curt Christianson
> > > Owner/Lead Developer, DF-Software
> > > Site: http://www.Darkfalz.com
> > > Blog: http://blog.Darkfalz.com
> > >
> > >
> > > "Jacob Crossley" <(E-Mail Removed)> wrote in message
> > > news:_7Jxc.408$(E-Mail Removed)...
> > > > which setting? I've tried them all!
> > > >
> > > >
> > > > "Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
> > > > news:(E-Mail Removed)...
> > > > > it's a setting in the options of VS.....
> > > > >
> > > > > --
> > > > > Curt Christianson
> > > > > Owner/Lead Developer, DF-Software
> > > > > Site: http://www.Darkfalz.com
> > > > > Blog: http://blog.Darkfalz.com
> > > > >
> > > > >
> > > > > "Jacob Crossley" <(E-Mail Removed)> wrote in message
> > > > > news:dTHxc.405$(E-Mail Removed)...
> > > > > > Please tell me there is a way to prevent this annoyance ; - )
> > > > > >
> > > > > > I'm into writing perfectly indented html, but the .net dev

> > environment
> > > > is
> > > > > > being overzealous and messing up my html formatting.
> > > > > >
> > > > > > for example, I originally write:
> > > > > >
> > > > > > <table>
> > > > > > <tr>
> > > > > > <td>
> > > > > > <asp:label id="lblSuccess" runat="server">
> > > > > > </asp:/label>
> > > > > > </td>
> > > > > > </tr>
> > > > > > </table>
> > > > > >
> > > > > > then the dev environment switches it to something like:
> > > > > >
> > > > > > <table>
> > > > > > <tr>
> > > > > > <td><asp:label id="lblSuccess"

> runat="server"></asp:/label>
> > > > > > </td></tr></table>
> > > > > >
> > > > > >
> > > > > > I'm running the latest version of .net --version 7.1.3088
> > > > > > I've run through the tools/options and placed the envirionment

to
> do
> > > the
> > > > > > least amount of microsoftesque-preemptive formatting.
> > > > > >
> > > > > > Please HELP!!! If there is no solution I think I'm gonna code

> .net
> > > > stuff
> > > > > in
> > > > > > notepad until I can get a linux, bsd or UNIX job...lol jk. I've

> > been
> > > an
> > > > > MS
> > > > > > developer for years!
> > > > > >
> > > > > >
> > > > > >
> > > > >
> > > > >
> > > >
> > > >
> > > >
> > >
> > >

> >
> >
> >

>
>




 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need to update other WebControls when switching from html to design view robert.minter@tallan.com ASP .Net Building Controls 1 07-21-2005 01:50 AM
VS 2003 hang saving .aspx file or switching design view ES ASP .Net 0 10-22-2004 04:04 PM
development environment architecture for ASP.NET development team Akhlaq Khan ASP .Net 4 09-27-2004 01:33 PM
Web Controls switching from Design view to HTML view causing problems Ziyad Makki ASP .Net Web Controls 1 08-23-2004 07:13 PM
Wierd error when going to Design View from HTML view VB Programmer ASP .Net 1 07-10-2003 03:20 PM



Advertisments