Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > testing my aspx on another machine - problems.

Reply
Thread Tools

testing my aspx on another machine - problems.

 
 
Martin Dew
Guest
Posts: n/a
 
      06-07-2004
I have been developing a small aspx web site. This has been developed using
visual studio 2003 and with codebehind pages written in c#. It works really
well on my development machine (win xp sp1, IIS installed and updated from
windows update).

I have tried to deploy this to another machine to test the deployment of
it(Win XP all upto date with patches aswell). I have copied all files and
folders from my projects directory (C:\Inetpub\wwwroot\Foldername) to an
identical folder on the new machine. I have set up a virtual web in IIS and
I can hit the main page fine on this new machaine, however some items on the
web page do not display, namely the System.Web.UI.WebControls.TextBox
controls on the mainpage. I have .net framewerk 1.1 installed on both
machines. any images also do not seem to display on the new machine , as
though the url is not being found. The ImageUrl property of the
System.Web.UI.WebControls.Image object has this value "images\insert.gif"
and works fine on my development machine, so I can only assume that these
problem are encountered due to something being missing on my new machine
which allows these objects to be translated from the html to be drawn on
screen.

Can anyone help with this as I am ready to deploy to test, and this is
holding me up.

T.I.A

Martin


 
Reply With Quote
 
 
 
 
John Saunders
Guest
Posts: n/a
 
      06-07-2004
"Martin Dew" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> I have been developing a small aspx web site. This has been developed

using
> visual studio 2003 and with codebehind pages written in c#. It works

really
> well on my development machine (win xp sp1, IIS installed and updated from
> windows update).
>
> I have tried to deploy this to another machine to test the deployment of
> it(Win XP all upto date with patches aswell). I have copied all files and
> folders from my projects directory (C:\Inetpub\wwwroot\Foldername) to an
> identical folder on the new machine. I have set up a virtual web in IIS

and
> I can hit the main page fine on this new machaine, however some items on

the
> web page do not display, namely the System.Web.UI.WebControls.TextBox
> controls on the mainpage.


Martin, use View Source in IE and see what's being rendered.

If you're seeing things like <asp:TextBox/> being rendered, then you don't
have ASP.NET configured. Run "aspnet_regiis -i" and see if that fixes
things.
--
John Saunders
johnwsaundersiii at hotmail


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FAQ 9.6 How do I download a file from the user's machine? How do I open a file on another machine? PerlFAQ Server Perl Misc 0 04-09-2011 04:00 PM
How to copy a file from one machine to another machine Nico Grubert Python 1 09-21-2005 10:53 AM
Re: How to copy a file from one machine to another machine Steve Holden Python 0 09-21-2005 10:29 AM
adding main.aspx.vb & main.aspx.resx under aspx John M ASP .Net 1 05-29-2005 09:27 PM



Advertisments