Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP General > codepage problem

Reply
Thread Tools

codepage problem

 
 
Savas Ates
Guest
Posts: n/a
 
      08-24-2004
i looked at msdn page an found the Turkish Codepade=1254

my code is
<%@LANGUAGE="VBSCRIPT" CODEPAGE="1254" %>
<%
citytr="Iğdır"
response.write citytr
response.end
%>

The result im waiting Iğdır

but the result Igdir the codepage is certainly right. but i think something
goes wrong..

please help me....


 
Reply With Quote
 
 
 
 
joker
Guest
Posts: n/a
 
      08-24-2004
I just ran that code on my IIS 5.1 server & I got the following result
"Iğdır" (without the quotes of course). So it's not the code.

Please post the following.

OS & SP of the server.

OS & SP of the client.

What browser & version are you using on the client?

What is the result if you view the source?


Savas Ates wrote:

> i looked at msdn page an found the Turkish Codepade=1254
>
> my code is
> <%@LANGUAGE="VBSCRIPT" CODEPAGE="1254" %>
> <%
> citytr="Iğdır"
> response.write citytr
> response.end
> %>
>
> The result im waiting Iğdır
>
> but the result Igdir the codepage is certainly right. but i think something
> goes wrong..
>
> please help me....
>
>


 
Reply With Quote
 
 
 
 
Savas Ates
Guest
Posts: n/a
 
      08-24-2004
can u send your code
did u add something to that code..

i solve the problem by adding that meta tag

<meta http-equiv="Content-Type" content="text/html; charset=windows-1254">

but is it necessary .. i think it musnt be... my os is winxp proffessional
and all service pack was installed and explorer is the default of win Xp
Prof...


 
Reply With Quote
 
joker
Guest
Posts: n/a
 
      08-25-2004
<%@LANGUAGE="VBSCRIPT" CODEPAGE="1254" %>
<%
dim citytr="Iğdır"
response.write citytr
response.end
%>

The only change I made is actually declaring the variable as a variable
because it is something I always do. Mainly because I always enabled
option explicit.

Are you running SP1 or SP2 on your IE?

It might be that SP2 for either IIS or IE fixes this.

Also once again check the source by selecting view source.

Savas Ates wrote:

> can u send your code
> did u add something to that code..
>
> i solve the problem by adding that meta tag
>
> <meta http-equiv="Content-Type" content="text/html; charset=windows-1254">
>
> but is it necessary .. i think it musnt be... my os is winxp proffessional
> and all service pack was installed and explorer is the default of win Xp
> Prof...
>
>


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Codepage problem ssijakovic@gmail.com ASP General 1 02-23-2007 12:02 AM
cookie codepage problem on iis 5.0 eyal.herlin@gmail.com ASP General 9 01-31-2007 12:49 PM
Codepage problem Daatmor ASP .Net 4 06-17-2005 03:03 PM
Which Codepage and Charset i should used? Benny Ng ASP .Net 0 06-17-2004 07:46 PM
Culture and Codepage question Mike Prager ASP .Net 2 08-30-2003 07:22 PM



Advertisments