Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP General > need quick helpp

Reply
Thread Tools

need quick helpp

 
 
Savas Ates
Guest
Posts: n/a
 
      07-21-2004
i have an web page. it use frame set .. but main frame is one server the
other frame is another server. when i want to set a cookie or session from
child frame.. it doesnt work...


i research the problem from msn
i tried
<%Response.Buffer = True
response.AddHeader "CP","CAO PSA OUR"%>

CAUSE
Internet Explorer 6.0 introduced support for the Platform for Privacy
Preferences (P3P) Project. The P3P standard notes that if a FRAMESET or a
parent window references another site inside a FRAME or inside a child
window, the child site is considered third party content. Internet Explorer,
which uses the default privacy setting of Medium, silently rejects cookies
sent from third party sites.
RESOLUTION
You can add a P3P compact policy header to your child content, and you can
declare that no malicious actions are performed with the data of the user.
If Internet Explorer detects a satisfactory policy, then Internet Explorer
permits the cookie to be set.

Visit the following MSDN Web site for a complete list of satisfactory and
unsatisfactory policy codes:

Privacy in Internet Explorer 6
http://msdn.microsoft.com/library/de...us/dnpriv/html
/ie6privacyfeature.asp

A simple compact policy that fulfills this criteria follows:


P3P: CP="CAO PSA OUR"

This code sample shows that your site provides you access to your own
contact information (CAO), that any analyzed data is only "pseudo-analyzed",
which means that the data is connected to your online persona and not to
your physical identity (PSA), and that your data is not supplied to any
outside agencies for those agencies to use (OUR).

You can set this header if you use the Response.AddHeader method in an ASP
page. In ASP.NET, you can use the Response.AppendHeader method. You can use
the IIS Management Snap-In (inetmgr) to add to a static file.


************************************************** *******************

and i dont have a permission in main frame and its server...

Follow these steps to add this header to a static file:
1.. Click Start, click Run, and then type inetmgr.
2.. In the left navigation page, click the appropriate file or directory
in your Web site to which you want to add the header, right-click the file,
and then click Properties.
3.. Click the HTTP Headers tab.
4.. In the Custom HTTP Headers group box, click Add.
5.. Type P3P for the header name, and then for the compact policy string,
type CP=..., where "..." is the appropriate code for your compact policy.
this will made in child server or main server?

please help me quickly???




 
Reply With Quote
 
 
 
 
John
Guest
Posts: n/a
 
      07-21-2004
That doens't work cross domain or you have to change setting in MSIE (extra,
options, securty)


 
Reply With Quote
 
 
 
 
P whittaker
Guest
Posts: n/a
 
      07-23-2004
I have a similar problem with a cloaking site which is on a different server to the site it is calling. If the first site I go into when I log in is the cloaking site then the session cookies are blocked. If however I have been to the child site first before calling the cloaked site then everything works. I have set up a p3p policy for the child site but there isn't one for the cloaking site. I am desperate to know how I can get it to work if the first site that is called is the cloaking site.


Thanks




--
Knutsford Software Ltd


"John" wrote:

> That doens't work cross domain or you have to change setting in MSIE (extra,
> options, securty)
>
>
>

 
Reply With Quote
 
BTR
Guest
Posts: n/a
 
      07-27-2004
On Fri, 23 Jul 2004 07:21:02 -0700, "P whittaker"
<(E-Mail Removed)> wrote:

>I have a similar problem with a cloaking site which is on a different server to the site it is calling. If the first site I go into when I log in is the cloaking site then the session cookies are blocked. If however I have been to the child site first before calling the cloaked site then everything works. I have set up a p3p policy for the child site but there isn't one for the cloaking site. I am desperate to know how I can get it to work if the first site that is called is the cloaking site.
>
>
>Thanks



If you are using sessions and SSL - sessions arent transfered to the
other server without using server-side session token, eg:
www.mysite.com?sessionID=123

OR

I stumbled across this script the other day looking for a similar
solution to the issue I was having. It may help you.

http://www.tele-pro.co.uk/scripts/xsess/

Good Luck
- Bastard


 
Reply With Quote
 
BTR
Guest
Posts: n/a
 
      07-28-2004
What sort of cloaking software are you using?

- Bastard

On Tue, 27 Jul 2004 04:21:39 GMT, BTR <(E-Mail Removed)> wrote:

>On Fri, 23 Jul 2004 07:21:02 -0700, "P whittaker"
><(E-Mail Removed)> wrote:
>
>>I have a similar problem with a cloaking site which is on a different server to the site it is calling. If the first site I go into when I log in is the cloaking site then the session cookies are blocked. If however I have been to the child site first before calling the cloaked site then everything works. I have set up a p3p policy for the child site but there isn't one for the cloaking site. I am desperate to know how I can get it to work if the first site that is called is the cloaking site.
>>
>>
>>Thanks

>
>
>If you are using sessions and SSL - sessions arent transfered to the
>other server without using server-side session token, eg:
>www.mysite.com?sessionID=123
>
>OR
>
>I stumbled across this script the other day looking for a similar
>solution to the issue I was having. It may help you.
>
>http://www.tele-pro.co.uk/scripts/xsess/
>
>Good Luck
>- Bastard
>


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
i need your helpp muhammad4828 Hardware 1 08-31-2011 02:59 PM
HELPP...problem connecting via wireless!! bluebear Wireless Networking 0 06-25-2007 03:10 PM
file and menu processes at C Helpp !! DeLiLlaH C Programming 9 06-10-2007 07:59 AM
helpp babydouloveme@aim.com Computer Support 2 04-08-2007 11:59 PM
Sony Dsc-w series, Canon SD series, or Fuji Finepix f30????? HELPP!! shofosho Digital Photography 0 07-13-2006 04:45 AM



Advertisments