Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP General > ASP file system object question ...

Reply
Thread Tools

ASP file system object question ...

 
 
Rick Simons
Guest
Posts: n/a
 
      07-07-2004
I have multiple IIS servers, all the same version and patch level. However,
a recursive file display page that works on 2 of my servers, doesn't work on
the third.


strPhysicalPath = Server.MapPath(".")
strPhysicalPath = strPhysicalPath & "\"
Set objFSO = Server.CreateObject("Scripting.FileSystemObject")
For Each file In objFSO.GetFolder(strPhysicalPath).Files

Like I said, it works on all the other IIS boxes except one. The page just
processes, but never displays an error, timeout or otherwise. it just sits
there. I've checked the IIS settings and they are the same as the machines
that the script works on. I've reinstalled IIS to see if it was something
with iislockdown, but still nothing. i've even formatted and installed
clean just to make sure there were no 3rd party security applications
causing trouble behind the scenes.

Does anyone have any thoughts about what it could be in IIS that is causing
this to fail?


 
Reply With Quote
 
 
 
 
Aaron [SQL Server MVP]
Guest
Posts: n/a
 
      07-07-2004
Norton VirusTM?
http://www.aspfaq.com/2180

--
http://www.aspfaq.com/
(Reverse address to reply.)




"Rick Simons" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> I have multiple IIS servers, all the same version and patch level.

However,
> a recursive file display page that works on 2 of my servers, doesn't work

on
> the third.
>
>
> strPhysicalPath = Server.MapPath(".")
> strPhysicalPath = strPhysicalPath & "\"
> Set objFSO = Server.CreateObject("Scripting.FileSystemObject")
> For Each file In objFSO.GetFolder(strPhysicalPath).Files
>
> Like I said, it works on all the other IIS boxes except one. The page

just
> processes, but never displays an error, timeout or otherwise. it just

sits
> there. I've checked the IIS settings and they are the same as the

machines
> that the script works on. I've reinstalled IIS to see if it was something
> with iislockdown, but still nothing. i've even formatted and installed
> clean just to make sure there were no 3rd party security applications
> causing trouble behind the scenes.
>
> Does anyone have any thoughts about what it could be in IIS that is

causing
> this to fail?
>
>



 
Reply With Quote
 
 
 
 
Rick Simons
Guest
Posts: n/a
 
      07-07-2004
I added iusr_hostname to read & execute, read and list folder contents
security credentials on the folder and still having the same problem.

I changed it to try to hit a different folder and same issue. Any thoughts?
It is very simple code, just created to show all xyz file extensions in a
folder and create a link ... very simple. Frustrating though to see it work
on two servers but fail on a 3rd.


"Curt_C [MVP]" <software_AT_darkfalz.com> wrote in message
news:%(E-Mail Removed)...
> permissions might be an issue. check those.
> Also, try pointing to a different folder once, as a test.
>
> --
> Curt Christianson
> Owner/Lead Developer, DF-Software
> Site: http://www.Darkfalz.com
> Blog: http://blog.Darkfalz.com
>
>
> "Rick Simons" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > I have multiple IIS servers, all the same version and patch level.

> However,
> > a recursive file display page that works on 2 of my servers, doesn't

work
> on
> > the third.
> >
> >
> > strPhysicalPath = Server.MapPath(".")
> > strPhysicalPath = strPhysicalPath & "\"
> > Set objFSO = Server.CreateObject("Scripting.FileSystemObject")
> > For Each file In objFSO.GetFolder(strPhysicalPath).Files
> >
> > Like I said, it works on all the other IIS boxes except one. The page

> just
> > processes, but never displays an error, timeout or otherwise. it just

> sits
> > there. I've checked the IIS settings and they are the same as the

> machines
> > that the script works on. I've reinstalled IIS to see if it was

something
> > with iislockdown, but still nothing. i've even formatted and installed
> > clean just to make sure there were no 3rd party security applications
> > causing trouble behind the scenes.
> >
> > Does anyone have any thoughts about what it could be in IIS that is

> causing
> > this to fail?
> >
> >

>
>



 
Reply With Quote
 
Rick Simons
Guest
Posts: n/a
 
      07-07-2004
Thanks Aaron, I believe it is the norton script blocker as that is on server
x but not y and z.

I appreciate your time,

Rick.



"Aaron [SQL Server MVP]" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Norton VirusTM?
> http://www.aspfaq.com/2180
>
> --
> http://www.aspfaq.com/
> (Reverse address to reply.)
>
>
>
>
> "Rick Simons" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > I have multiple IIS servers, all the same version and patch level.

> However,
> > a recursive file display page that works on 2 of my servers, doesn't

work
> on
> > the third.
> >
> >
> > strPhysicalPath = Server.MapPath(".")
> > strPhysicalPath = strPhysicalPath & "\"
> > Set objFSO = Server.CreateObject("Scripting.FileSystemObject")
> > For Each file In objFSO.GetFolder(strPhysicalPath).Files
> >
> > Like I said, it works on all the other IIS boxes except one. The page

> just
> > processes, but never displays an error, timeout or otherwise. it just

> sits
> > there. I've checked the IIS settings and they are the same as the

> machines
> > that the script works on. I've reinstalled IIS to see if it was

something
> > with iislockdown, but still nothing. i've even formatted and installed
> > clean just to make sure there were no 3rd party security applications
> > causing trouble behind the scenes.
> >
> > Does anyone have any thoughts about what it could be in IIS that is

> causing
> > this to fail?
> >
> >

>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
File System Object - not deleting file Lise ASP General 3 06-08-2006 03:14 PM
Object reference not set to an instance of an object. System.Web.UI.WebControls.ListItemCollection.SaveViewState() System.Web.UI.WebControls.ListControl.SaveViewState() Brano ASP .Net 3 11-08-2005 12:29 PM
Object creation - Do we really need to create a parent for a derieved object - can't the base object just point to an already created base object jon wayne C++ 9 09-22-2005 02:06 AM
System.Security.SecurityException: Error de solicitud de permiso de tipo System.Net.WebPermission, System, Version=1.0.5000.0, Culture=neutral, PublicKeyToken=b77a5c561934e089. Luis Esteban Valencia ASP .Net 0 07-14-2005 01:43 PM
Why are sender and object used as in sender As System.Object, ByVal e As System.EventArgs? Showjumper ASP .Net 2 08-02-2003 10:53 PM



Advertisments