Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP General > Unwarranted Error?

Reply
Thread Tools

Unwarranted Error?

 
 
fruddy
Guest
Posts: n/a
 
      01-09-2004
Hi everyone,
I'm getting the following error:

ADODB.Recordset (0x800A0CC1)
Item cannot be found in the collection corresponding to the requested
name or ordinal.

Now we all know that it means I'm trying to refer to a column that does
not exist in the DB (SQL Server), yet it definitely, absolutely
exists....

The recordset is created by a stored procedure... this column is even
used on other pages in the same application, yet doesn't work on this
particular page?

This site doesn't get this error in the development environment at all,
just when I've pushed it to live.

Even when I view the results of executing this stored procedure in query
analyser, it returns the column and a value!!!

Could there be another cause of this???

Thanks for any suggestions....


*** Sent via Developersdex http://www.developersdex.com ***
Don't just participate in USENET...get rewarded for it!
 
Reply With Quote
 
 
 
 
Aaron Bertrand [MVP]
Guest
Posts: n/a
 
      01-09-2004
Put SET NOCOUNT ON at the beginning of the stored procedure.

--
Aaron Bertrand
SQL Server MVP
http://www.aspfaq.com/




"fruddy" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hi everyone,
> I'm getting the following error:
>
> ADODB.Recordset (0x800A0CC1)
> Item cannot be found in the collection corresponding to the requested
> name or ordinal.
>
> Now we all know that it means I'm trying to refer to a column that does
> not exist in the DB (SQL Server), yet it definitely, absolutely
> exists....
>
> The recordset is created by a stored procedure... this column is even
> used on other pages in the same application, yet doesn't work on this
> particular page?
>
> This site doesn't get this error in the development environment at all,
> just when I've pushed it to live.
>
> Even when I view the results of executing this stored procedure in query
> analyser, it returns the column and a value!!!
>
> Could there be another cause of this???
>
> Thanks for any suggestions....
>
>
> *** Sent via Developersdex http://www.developersdex.com ***
> Don't just participate in USENET...get rewarded for it!



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off




Advertisments