Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP General > CDO messages - migrated to Exchange 2003 - quit working

Reply
Thread Tools

CDO messages - migrated to Exchange 2003 - quit working

 
 
Tom Petersen
Guest
Posts: n/a
 
      11-17-2003
Our person who hosts our email recently migrated to Exchange 2003 and my ASP
emailing code quit working. I was getting this error:
CDO.Message.1 (0x80040213)
The transport failed to connect to the server.
Because I forgot to change the server name here:
With cdoConfig.Fields
.Item(cdoSendUsingMethod) = cdoSendUsingPort
.Item(cdoSMTPServer) = "mail.whatever.com"
.Update
End With

I changed the server name, and that was the only code I changed and now I
get this:
Error Type:
(0x8004020F)
It's failing on the .Send

Here is the applicable code.
<!--METADATA TYPE="typelib" UUID="CD000000-8B95-11D1-82DB-00C04FB1625D"
NAME="CDO for Windows 2000 Library" -->

Set cdoConfig = Server.CreateObject("CDO.Configuration")

With cdoConfig.Fields
.Item(cdoSendUsingMethod) = cdoSendUsingPort
.Item(cdoSMTPServer) = "correct.mail.com"
.Update
End With

Set cdoMessage = Server.CreateObject("CDO.Message")
With cdoMessage
Set .Configuration = cdoConfig
.From = strEmail
.To = "(E-Mail Removed); http://www.velocityreviews.com/forums/(E-Mail Removed)"
.Cc = strmEmail
.Subject = "Maintenance Request"
.TextBody = strBody
.Send
End With
Set cdoMessage = Nothing
Set cdoConfig = Nothing

I don't know if cdoSendUsingPort is set or if that is a constant (25), just
that it worked before.
Is it possible the Exchange Server is blocking anything or not now that I
don't get the 1st error?


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Expresion Expected Error - VS 2005 - Migrated from VS 2003 John Banks ASP .Net Building Controls 2 01-27-2007 03:48 AM
Migrated web site still runs in IIS rather than ASP Development Se =?Utf-8?B?R3JlZyBTbWFsdGVy?= ASP .Net 3 11-14-2005 05:33 PM
"CDO for Windows 2000 Library" on Exchange 2003 Andyza ASP General 3 10-26-2005 11:36 AM
Acessing MS Exchange 2003 - problems with CDO Nitec Dev ASP General 0 11-26-2003 10:33 AM
CDO for Windows 2000 vs CDO for Exchange 2000 ASP .Net 2 07-11-2003 12:31 PM



Advertisments