Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Services > I Can Reference One Service Endpoint In My App But Not The Other.

Reply
Thread Tools

I Can Reference One Service Endpoint In My App But Not The Other.

 
 
pbd22
Guest
Posts: n/a
 
      07-21-2009

Hi.

After compiling my web service library (hosting two service endpoints)
and attempting to call them from my Web client, I am noticing that I
am able to call/see one but not the other and
I can't sort out why this is happening.

Below are my endpoint references (Trade and Authentication) in
App.config. I am wondering if the reason that TradeServiceClient is
available in my Web client but AuthServiceClient is not is that I am
using the same port for the base addresses? Would this matter?

Any ideas out there? Thanks in advance.

<services>
<service behaviorConfiguration="WebAPILibrary.WebAPIBehavio r"
name="SpoonSys.WebAPI.Trade.TradeService">
<endpoint address="" binding="wsHttpBinding"
contract="SpoonSys.WebAPI.Trade.ITradeService">
<identity>
<dns value="localhost" />
</identity>
</endpoint>
<endpoint address="mex" binding="mexHttpBinding"
contract="IMetadataExchange" />
<host>
<baseAddresses>
<add baseAddress="http://localhost:8731/
Design_Time_Addresses/WebAPILibrary/Trade/" />
</baseAddresses>
</host>
</service>
<service behaviorConfiguration="WebAPILibrary.WebAPIBehavio r"
name="SpoonSys.WebAPI.Authentication.AuthService">
<endpoint address="" binding="wsHttpBinding"
contract="SpoonSys.WebAPI.Authentication.IAuthServ ice">
<identity>
<dns value="localhost" />
</identity>
</endpoint>
<endpoint address="mex" binding="mexHttpBinding"
contract="IMetadataExchange" />
<host>
<baseAddresses>
<add baseAddress="http://localhost:8731/
Design_Time_Addresses/WebAPILibrary/Authentication/" />
</baseAddresses>
</host>
</service>
</services>
 
Reply With Quote
 
 
 
 
pbd22
Guest
Posts: n/a
 
      07-22-2009
On Jul 21, 12:20*pm, pbd22 <(E-Mail Removed)> wrote:
> Hi.
>
> After compiling my web service library (hosting two service endpoints)
> and attempting to call them from my Web client, I am noticing that I
> am able to call/see one but not the other and
> I can't sort out why this is happening.
>
> Below are my endpoint references (Trade and Authentication) in
> App.config. I am wondering if the reason that TradeServiceClient is
> available in my Web client but AuthServiceClient is not is that I am
> using the same port for the base addresses? Would this matter?
>
> Any ideas out there? Thanks in advance.
>
> <services>
> * * * <service behaviorConfiguration="WebAPILibrary.WebAPIBehavio r"
> name="SpoonSys.WebAPI.Trade.TradeService">
> * * * * <endpoint address="" binding="wsHttpBinding"
> contract="SpoonSys.WebAPI.Trade.ITradeService">
> * * * * * <identity>
> * * * * * * <dns value="localhost" />
> * * * * * </identity>
> * * * * </endpoint>
> * * * * <endpoint address="mex" binding="mexHttpBinding"
> contract="IMetadataExchange" />
> * * * * <host>
> * * * * * <baseAddresses>
> * * * * * * <add baseAddress="http://localhost:8731/
> Design_Time_Addresses/WebAPILibrary/Trade/" />
> * * * * * </baseAddresses>
> * * * * </host>
> * * * </service>
> * * * <service behaviorConfiguration="WebAPILibrary.WebAPIBehavio r"
> name="SpoonSys.WebAPI.Authentication.AuthService">
> * * * * <endpoint address="" binding="wsHttpBinding"
> contract="SpoonSys.WebAPI.Authentication.IAuthServ ice">
> * * * * * <identity>
> * * * * * * <dns value="localhost" />
> * * * * * </identity>
> * * * * </endpoint>
> * * * * <endpoint address="mex" binding="mexHttpBinding"
> contract="IMetadataExchange" />
> * * * * <host>
> * * * * * <baseAddresses>
> * * * * * * <add baseAddress="http://localhost:8731/
> Design_Time_Addresses/WebAPILibrary/Authentication/" />
> * * * * * </baseAddresses>
> * * * * </host>
> * * * </service>
> * * </services>


I am curious why I am not getting a response to this - anything else i
can provide?
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Re: GRE Tunnel problem with one endpoint in NAT News Reader Cisco 4 05-05-2008 05:52 PM
Can't access Web Service thru DLL (but can thru Windows App) THTB ASP .Net Web Services 0 05-17-2007 06:43 PM
Cannot make a Web Reference to Web Service created (HTTP Endpoint) on SQL 2005 stored procedure tovbinm@gmail.com ASP .Net 0 05-21-2006 08:20 AM
debug Windows app works but, not web app =?Utf-8?B?R2lhbmNhcmxv?= ASP .Net 0 09-26-2005 06:16 PM
endpoint vpn router to endpoint vpn router problem Mike Doty Cisco 1 10-02-2004 07:41 PM



Advertisments