Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Services > .NET 3 and 1.1 interop

Reply
Thread Tools

.NET 3 and 1.1 interop

 
 
CatchExAs@googlemail.com
Guest
Posts: n/a
 
      09-17-2007
Hi, sorry for the x-post and thanks in advance for any help you can
provide.

I'm attempting to call a .NET 3 web service from a .NET 1.1 rich
client. I've successfully consumed the service in Visual Studio by
adding a static web reference. Unfortunately at runtime I get the
horrible exception attached below.

Is there something I've done that is obviously wrong? Which tools can
I use to investigate this problem further?

Many thanks,

Nick


Unhandled Exception: System.IO.FileNotFoundException: File or assembly
name pyiwi__w.dll, or one of its dependencies, was not found.
File name: "pyiwi__w.dll"
at System.Reflection.Assembly.nLoad(AssemblyName fileName, String
codeBase, Boolean isStringized, Evidence assemblySecurity, Boolean
throwOnFileNotFound, Assembly locationHint, StackCrawlMark& stackMark)
at System.Reflection.Assembly.InternalLoad(AssemblyNa me
assemblyRef, Boolean stringized, Evidence assemblySecurity,
StackCrawlMark& stackMark)
at System.Reflection.Assembly.Load(AssemblyName assemblyRef,
Evidence assemblySecurity)
at System.CodeDom.Compiler.CompilerResults.get_Compil edAssembly()
at System.CodeDom.Compiler.CompilerResults.get_Compil edAssembly()
at System.Xml.Serialization.Compiler.Compile()
at System.Xml.Serialization.TempAssembly..ctor(XmlMap ping[]
xmlMappings)
at System.Xml.Serialization.XmlSerializer.FromMapping s(XmlMapping[]
mappings)
at System.Web.Services.Protocols.SoapClientType..ctor (Type type)
at System.Web.Services.Protocols.SoapHttpClientProtoc ol..ctor()
at MBTestHarness.mb64srv01.SetDiagnosticsService..cto r() in c:
\scratch\mbtestharness\web references\mb64srv01\reference.cs:line 32
at MBTestHarness.Form1.button1_Click(Object sender, EventArgs e) in
c:\scratch\mbtestharness\form1.cs:line 105
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventAr gs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons
button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.ControlNativeWindow.OnMessage (Message& m)
at System.Windows.Forms.ControlNativeWindow.WndProc(M essage& m)
at System.Windows.Forms.NativeWindow.DebuggableCallba ck(IntPtr
hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
at System.Windows.ForThe program '[3228] MBTestHarness.exe' has
exited with code 0 (0x0).
ms.UnsafeNativeMethods.DispatchMessageW(MSG& msg)
at
System.Windows.Forms.ComponentManager.System.Windo ws.Forms.UnsafeNativeMethods
+IMsoComponentManager.FPushMessageLoop(Int32 dwComponentID, Int32
reason, Int32 pvLoopData)
at System.Windows.Forms.ThreadContext.RunMessageLoopI nner(Int32
reason, ApplicationContext context)
at System.Windows.Forms.ThreadContext.RunMessageLoop( Int32 reason,
ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at MBTestHarness.Form1.Main() in c:\scratch\mbtestharness
\form1.cs:line 100

=== Pre-bind state information ===
LOG: Where-ref bind. Location = C:\DOCUME~1\wiltonn\LOCALS~1\Temp
\pyiwi__w.dll
LOG: Appbase = C:\Scratch\MBTestHarness\bin\Debug\
LOG: Initial PrivatePath = NULL
Calling assembly : (Unknown).
===

LOG: Policy not being applied to reference at this time (private,
custom, partial, or location-based assembly bind).
LOG: Attempting download of new URL file:///C:/DOCUME~1/wiltonn/LOCALS~1/Temp/pyiwi__w.dll.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error with TreeView Control (MSCOMCTL.OCX) via COM Interop from ASP.NET and Service Pack MarkD ASP .Net 0 08-03-2005 02:44 PM
ACTIVEX, WEB FORMS, AND INTEROP ISSUE Jeffery Franzen ASP .Net 3 05-01-2005 07:37 PM
Interop and windows 2003 server Carmen ASP .Net 0 03-17-2005 11:52 AM
Issue with ASP.NET client, COM Interop, and Identity impersonation Anil Krishnamurthy ASP .Net 12 10-05-2004 10:05 PM
DSOFILE and Interop Issues Paul Perot ASP .Net 0 05-31-2004 04:40 PM



Advertisments