Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Services > Wierd problem when dserializing array of custom types in response

Reply
Thread Tools

Wierd problem when dserializing array of custom types in response

 
 
Navin Mishra
Guest
Posts: n/a
 
      12-11-2006
Hi,

I'm facing wierd problem when deserializing array of custom types in
response from ASP.NET web service. I'm seeing SOAP response is sent all
right to client but the client proxy deserializes all fields of custom types
in array element as null somehow. I tried explicitly giving the namespace
and type for array elements but that didn't help.

[XmlArrayAttribute(Form = System.Xml.Schema.XmlSchemaForm.Unqualified)]

[XmlArrayItemAttribute(Type = typeof(MyType), Form =
System.Xml.Schema.XmlSchemaForm.Qualified, Namespace =
http://www.mynamespce, IsNullable = true)]

public MyType[] myArray;

I do have same type MyType in a different namespace also but when I give
correct namespace why it should still cause problem ? I couldn't make it
work try what I may...

Any ideas what might be going on ?

Thanks in advance and regards

Navin






 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with rendering page using 'Response.Redirect' and 'Response.OutputStream' André ASP .Net 3 12-01-2006 07:20 AM
Where are ref types that are members of value types stored? Sathyaish ASP .Net 2 05-22-2005 07:32 PM
Response.Redirect and Response.AddHeader problem S.Kartikeyan ASP .Net 0 03-01-2004 05:02 AM
wierd Array of Hash result superfly2 Perl Misc 1 09-12-2003 07:38 PM
Wierd result from hash array Pacman Perl Misc 3 09-11-2003 10:02 PM



Advertisments