Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Services > Override the generated soap:address in WSDL

Reply
Thread Tools

Override the generated soap:address in WSDL

 
 
MP
Guest
Posts: n/a
 
      12-06-2006
Hi all,
I have a problem with my web service: when installed to certain servers
(e.g. load balanced) the URL specified in soap:address gets changed to a
private address, making the service unusable. Is there any way to override
the soap:address generated by the web service or other way round this?
Thanks


 
Reply With Quote
 
 
 
 
John Saunders
Guest
Posts: n/a
 
      12-06-2006
"MP" <(E-Mail Removed)> wrote in message
news:4576ac6f$0$27105$(E-Mail Removed)...
> Hi all,
> I have a problem with my web service: when installed to certain servers
> (e.g. load balanced) the URL specified in soap:address gets changed to a
> private address, making the service unusable. Is there any way to override
> the soap:address generated by the web service or other way round this?


Consider how the address is being used. It's simply used as the default URL
for the web service in the client. If you set the Web Reference to Dynamic,
you will be able to set the URL in the application config file.

You can also set the URL at runtime by setting the Url property of the
proxy.

John


 
Reply With Quote
 
 
 
 
John Saunders
Guest
Posts: n/a
 
      12-07-2006
"MP" <(E-Mail Removed)> wrote in message
news:45770435$0$2447$(E-Mail Removed)...
> Hi John,
> thanks for the reply.
> Unfortunately your suggestion doesn't apply to my situation.
> I try to explain it better:
> my web service receives calls from a non-.NET application, so I have no
> proxy.
> When I try to retrieve the WSDL from the browser using for instance an URL
> like this:
> https://mysite.com/....?WSDL
> the downloaded WSDL contains a <soap:address> like this:
> http://mysite.com:81/...?WSDL
> and I think this is why the client gets a misleading error message "xml
> document must have a top level node".
> This is why I'm looking for something that allows me to control that URL
> in the WSDL (or to any other workaround).


I'm afraid I have no suggestions. I use hand-written WSDLs, so I would never
have seen the problem.

I wonder if the ?WSDL at the end is normal, though. I think that the
<soap:address> is meant to be the address of the service, not of the WSDL.

John


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn off Auto Generated WSDL, so I can use my static custom wsdl casucci@gmail.com ASP .Net Web Services 3 10-07-2008 06:38 PM
Override the generated soap:address Oscar Thornell ASP .Net Web Services 0 11-25-2005 07:55 AM
wsdl.exe fails with WebMethods generated wsdl file mrnu ASP .Net Web Services 0 06-07-2004 04:51 PM
How do I override the soap:address field in the auto-generated WSDL document? Ray Johnson ASP .Net Web Services 1 01-13-2004 06:31 AM
OVERride "binding" name and "portType" name in WSDL Bilge ASP .Net Web Services 0 11-21-2003 09:52 PM



Advertisments