Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Services > FramingFormatException (WSE306) on Soap/TCP receive

Reply
Thread Tools

FramingFormatException (WSE306) on Soap/TCP receive

 
 
GS
Guest
Posts: n/a
 
      10-12-2006
We are using Soap over TCP (WSE 3.0) and occasionally encounter the
following exception:

soap.tcp Message Receive Failure:
Microsoft.Web.Services3.Messaging.Framing.FramingF ormatException:
WSE306: The framed record should have the following version: 1. Instead,
the framed record contains the following version: 14.
at Microsoft.Web.Services3.Messaging.Framing.FramingR ecord.ReadHeader()
at
Microsoft.Web.Services3.Messaging.Framing.FramingR ecord..ctor(Stream
stream, Int32 maxRecordLength)
at Microsoft.Web.Services3.Messaging.Framing.FramingR eader.ReadRecord()
at
Microsoft.Web.Services3.Messaging.SoapMtomFormatte rWithFraming.Microsoft.Web.Services3.Messaging.ISo apFormatter.Deserialize(Stream
stream)
at
Microsoft.Web.Services3.Messaging.SoapTcpConnectio n.DeserializeMessage()
at
Microsoft.Web.Services3.Messaging.SoapTcpConnectio n.EndReceive(IAsyncResult
ar)
at
Microsoft.Web.Services3.Messaging.SoapTcpTransport .OnReceiveComplete(IAsyncResult
ar)

Can anyone help in resolving this?
 
Reply With Quote
 
 
 
 
guillaume StEtienne FR
Guest
Posts: n/a
 
      10-27-2006
same problem here, we just use the HelloWorld sample

[WebMethod()]
public string HelloWorld() {
return "Hello World";
}
with WSE 3 enabled

but the error occurs when invoking this service from a J2EE/ AXIS client
and we've got exactly the same error (always)
where url is : soap.tcp://DEV-GSE:500/TestService/


helllllp !

"GS" wrote:

> We are using Soap over TCP (WSE 3.0) and occasionally encounter the
> following exception:
>
> soap.tcp Message Receive Failure:
> Microsoft.Web.Services3.Messaging.Framing.FramingF ormatException:
> WSE306: The framed record should have the following version: 1. Instead,
> the framed record contains the following version: 14.
> at Microsoft.Web.Services3.Messaging.Framing.FramingR ecord.ReadHeader()
> at
> Microsoft.Web.Services3.Messaging.Framing.FramingR ecord..ctor(Stream
> stream, Int32 maxRecordLength)
> at Microsoft.Web.Services3.Messaging.Framing.FramingR eader.ReadRecord()
> at
> Microsoft.Web.Services3.Messaging.SoapMtomFormatte rWithFraming.Microsoft.Web.Services3.Messaging.ISo apFormatter.Deserialize(Stream
> stream)
> at
> Microsoft.Web.Services3.Messaging.SoapTcpConnectio n.DeserializeMessage()
> at
> Microsoft.Web.Services3.Messaging.SoapTcpConnectio n.EndReceive(IAsyncResult
> ar)
> at
> Microsoft.Web.Services3.Messaging.SoapTcpTransport .OnReceiveComplete(IAsyncResult
> ar)
>
> Can anyone help in resolving this?
>

 
Reply With Quote
 
 
 
 
guillaume StEtienne FR
Guest
Posts: n/a
 
      11-23-2006
nop

we're the only 3 ones in the world, I guess...
this page is top rated in google, so I think we're alone.

Guillaume

"Prasad" wrote:

>
> > We are using Soap over TCP (WSE 3.0) and occasionally encounter the
> > following exception:
> >
> > soap.tcp Message Receive Failure:
> > Microsoft.Web.Services3.Messaging.Framing.FramingF ormatException:
> > WSE306: The framed record should have the following version: 1. Instead,
> > the framed record contains the following version: 14.
> > at Microsoft.Web.Services3.Messaging.Framing.FramingR ecord.ReadHeader()
> > at
> > Microsoft.Web.Services3.Messaging.Framing.FramingR ecord..ctor(Stream
> > stream, Int32 maxRecordLength)
> > at Microsoft.Web.Services3.Messaging.Framing.FramingR eader.ReadRecord()
> > at
> > Microsoft.Web.Services3.Messaging.SoapMtomFormatte rWithFraming.Microsoft.Web.Services3.Messaging.ISo apFormatter.Deserialize(Stream
> > stream)
> > at
> > Microsoft.Web.Services3.Messaging.SoapTcpConnectio n.DeserializeMessage()
> > at
> > Microsoft.Web.Services3.Messaging.SoapTcpConnectio n.EndReceive(IAsyncResult
> > ar)
> > at
> > Microsoft.Web.Services3.Messaging.SoapTcpTransport .OnReceiveComplete(IAsyncResult
> > ar)
> >
> > Can anyone help in resolving this?

>
> I am facing same issue. Did you find a solution?
>
> BizTalk Utilities - Frustration free BizTalk Adapters
> http://www.topxml.com/biztalkutilities
>

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NO RECEIVE SIGNAL =?Utf-8?B?TUlDaGVyb2tlZQ==?= Wireless Networking 4 10-28-2005 08:57 AM
Thunderbird 1.0.6. will not receive mail. ( NEWBIE ) Ron Firefox 8 08-18-2005 03:09 PM
can't receive email Jack Martin Firefox 3 08-15-2005 03:52 PM
Can't receive e mails in Outlook Express =?Utf-8?B?amFjcQ==?= Wireless Networking 1 02-09-2005 06:41 PM
How can my application receive PnP notifications from a n/w device =?Utf-8?B?TmV0d29ya2luZyBEZXZlbG9wZXI=?= Wireless Networking 1 11-25-2004 12:34 AM



Advertisments