Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Services > helloworld comes up with 404.

Reply
Thread Tools

helloworld comes up with 404.

 
 
nevin
Guest
Posts: n/a
 
      10-06-2006
Hi I am trying to load a new web service onto a production box and it's
just not working so I am now trying with helloworld which doesn't work
either.

I cannot publish to the server as vs2005 tells me the IIS on that box
doesn't have FPE even though it does so I copied the published files
from my dev box to the production server and manually created the
application setting in IIS.

the root folder of the app is in the wwwroot of the server so
http://server/helloworld/service.asmx should work but it gives a 404
error.

if I set directory browsing on the helloworld directory and go there I
can see all the files of the application in the directory. clicking
service.asmx gives 404!!
the IIS admin tool can also see the folder and all the files and
folders in the app directory.

The settings in IIS are exactly the same as on my dev box...I am an
admin on both machines and the asp.net user has full rights to the
directory and it's set to anonymous access on that directory.

I have no idea where to go now so can someone please give me any ideas?
thanks
Nev

 
Reply With Quote
 
 
 
 
nevin
Guest
Posts: n/a
 
      10-06-2006

nevin wrote:
> Hi I am trying to load a new web service onto a production box and it's
> just not working so I am now trying with helloworld which doesn't work
> either.
>
> I cannot publish to the server as vs2005 tells me the IIS on that box
> doesn't have FPE even though it does so I copied the published files
> from my dev box to the production server and manually created the
> application setting in IIS.
>
> the root folder of the app is in the wwwroot of the server so
> http://server/helloworld/service.asmx should work but it gives a 404
> error.
>
> if I set directory browsing on the helloworld directory and go there I
> can see all the files of the application in the directory. clicking
> service.asmx gives 404!!
> the IIS admin tool can also see the folder and all the files and
> folders in the app directory.
>
> The settings in IIS are exactly the same as on my dev box...I am an
> admin on both machines and the asp.net user has full rights to the
> directory and it's set to anonymous access on that directory.
>
> I have no idea where to go now so can someone please give me any ideas?
> thanks
> Nev


Solved it almost straight after I posted this (even though I spent ages
searching previously)
Basically on win2003 server you have to forcibly allow asp.net and I
had not done that..doh!!

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ANN: HELLOWORLD Leo Wong Java 4 07-09-2005 10:28 PM
helloworld portlet gluraski Java 0 06-09-2005 09:10 AM
Trouble compiling HelloWorld with vbc Mister.programmer ASP .Net 3 02-11-2005 03:15 PM
Tomcat running under apache/mod-jk hangs after calling HelloWorld servlet exactly 9 times Java 0 01-18-2004 01:24 PM
Cannot run 'HelloWorld' servlet in Tomcat environment the_JAVA_Rookie Java 5 08-19-2003 12:19 PM



Advertisments