Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Services > Invoke from localhost

Reply
Thread Tools

Invoke from localhost

 
 
Keith McDonald
Guest
Posts: n/a
 
      06-16-2006
We have a server that we had to reinstall IIS. Now when testing a web
service via http://localhost.... The Invoke does function anymore.
Clicking the button does absolutely nothing, no popup or anything.

Ideas?

Thanks,
Keith

 
Reply With Quote
 
 
 
 
Simon Hart
Guest
Posts: n/a
 
      06-18-2006
Try re-registering COM object aspnet_isapi.dll which can be found in your
..NET directory for example run this at the command-line:

c:\windows\system32\regsvr32
c:\windows\microsoft.net\framework\v1.1.4322\aspne t_asapi.dll

Regards
Simon.

"Keith McDonald" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) oups.com...
> We have a server that we had to reinstall IIS. Now when testing a web
> service via http://localhost.... The Invoke does function anymore.
> Clicking the button does absolutely nothing, no popup or anything.
>
> Ideas?
>
> Thanks,
> Keith
>



 
Reply With Quote
 
 
 
 
Keith McDonald
Guest
Posts: n/a
 
      06-19-2006
Reregistering worked OK but still have the same issue...

Thanks for the help on this....

Simon Hart wrote:
> Try re-registering COM object aspnet_isapi.dll which can be found in your
> .NET directory for example run this at the command-line:
>
> c:\windows\system32\regsvr32
> c:\windows\microsoft.net\framework\v1.1.4322\aspne t_asapi.dll
>
> Regards
> Simon.
>
> "Keith McDonald" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed) oups.com...
> > We have a server that we had to reinstall IIS. Now when testing a web
> > service via http://localhost.... The Invoke does function anymore.
> > Clicking the button does absolutely nothing, no popup or anything.
> >
> > Ideas?
> >
> > Thanks,
> > Keith
> >


 
Reply With Quote
 
Simon Hart
Guest
Posts: n/a
 
      06-19-2006
Sorry, I just re-read your post and relised what I told you would not fix
the problem. This problem does sound strange. Have you tried invoking your
service via Web Service Studio?

If you don't have Web Service Studio, you can get it from here:
http://www.gotdotnet.com/team/tools/...c/default.aspx

Simon.

"Keith McDonald" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) ups.com...
> Reregistering worked OK but still have the same issue...
>
> Thanks for the help on this....
>
> Simon Hart wrote:
>> Try re-registering COM object aspnet_isapi.dll which can be found in your
>> .NET directory for example run this at the command-line:
>>
>> c:\windows\system32\regsvr32
>> c:\windows\microsoft.net\framework\v1.1.4322\aspne t_asapi.dll
>>
>> Regards
>> Simon.
>>
>> "Keith McDonald" <(E-Mail Removed)> wrote in message
>> news:(E-Mail Removed) oups.com...
>> > We have a server that we had to reinstall IIS. Now when testing a web
>> > service via http://localhost.... The Invoke does function anymore.
>> > Clicking the button does absolutely nothing, no popup or anything.
>> >
>> > Ideas?
>> >
>> > Thanks,
>> > Keith
>> >

>



 
Reply With Quote
 
Scott M.
Guest
Posts: n/a
 
      06-20-2006
Have you run "aspregiis -i" ?




"Keith McDonald" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) oups.com...
> We have a server that we had to reinstall IIS. Now when testing a web
> service via http://localhost.... The Invoke does function anymore.
> Clicking the button does absolutely nothing, no popup or anything.
>
> Ideas?
>
> Thanks,
> Keith
>



 
Reply With Quote
 
Keith McDonald
Guest
Posts: n/a
 
      06-27-2006
Thanks for the tip but same problem. After install did have to set Web
Extensions to Allow but still the Invoke button doesn't work...

Scott M. wrote:
> Have you run "aspregiis -i" ?
>
>
>
>
> "Keith McDonald" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed) oups.com...
> > We have a server that we had to reinstall IIS. Now when testing a web
> > service via http://localhost.... The Invoke does function anymore.
> > Clicking the button does absolutely nothing, no popup or anything.
> >
> > Ideas?
> >
> > Thanks,
> > Keith
> >


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Limit Ring server to localhost only. RingFinger.new('localhost')apparently doesn't work koicat Ruby 0 07-02-2010 08:01 PM
change from "//localhost:numbers/" to just "//localhost/"? =?Utf-8?B?S2VuTGVl?= ASP .Net 5 02-12-2006 05:14 AM
Localhost isn't localhost EdwardH Java 20 10-01-2005 12:08 AM
Can I Reset the Root from localhost/myproject/ to localhost/ Alex ASP .Net 4 02-08-2005 01:45 PM
HttpModule -- how to intercept urls like http://localhost/abc/def or http://localhost/abc/def/ where abc, def are non virtual dir Jiong Feng ASP .Net 0 11-19-2003 05:29 AM



Advertisments