Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Services > Parser error "could not create type" w .NET Framework 2.0

Reply
Thread Tools

Parser error "could not create type" w .NET Framework 2.0

 
 
Joakim Sundén
Guest
Posts: n/a
 
      11-10-2005
Hi.
I have created a simple web service project, only using the HelloWorld
sample already there, with Visual Studio 2005. If I browse the web service
..asmx file by right-clicking it using the new built-in web server everything
works just fine.

All attempts to access the service through IIS fails with the parser error
"Could not create type 'Service1'" with a reference to line 1 of the .asmx
file:

<%@ WebService Language="C#" CodeBehind="~/App_Code/Service1.cs"
Class="Service1" %>

This is true if I publish the site/service with precompilation or if I copy
it to a different location. Whatever I do I can only get it to work with the
built-in web server. Can someone please help me figuring out what is wrong?

I have configured the web site to use ASP.NET 2.0 so that is not the problem.

/Joakim
 
Reply With Quote
 
 
 
 
Roy Kiesler
Guest
Posts: n/a
 
      11-17-2005
I'm running into the very same error -- has anyone been able to figure
this out?

Parser Error Message: Could not create type 'Service'.

Source Error:

Line 1: <%@ WebService Language="C#"
CodeBehind="/APDemo/App_Code/Service.cs" Class="Service" %>

Source File: /APDemo/Service.asmx Line: 1

Version Information: Microsoft .NET Framework Version:2.0.50727.42;
ASP.NET Version:2.0.50727.42


Joakim Sundén wrote:
> Hi.
> I have created a simple web service project, only using the HelloWorld
> sample already there, with Visual Studio 2005. If I browse the web service
> .asmx file by right-clicking it using the new built-in web server everything
> works just fine.
>
> All attempts to access the service through IIS fails with the parser error
> "Could not create type 'Service1'" with a reference to line 1 of the .asmx
> file:
>
> <%@ WebService Language="C#" CodeBehind="~/App_Code/Service1.cs"
> Class="Service1" %>
>
> This is true if I publish the site/service with precompilation or if I copy
> it to a different location. Whatever I do I can only get it to work with the
> built-in web server. Can someone please help me figuring out what is wrong?
>
> I have configured the web site to use ASP.NET 2.0 so that is not the problem.
>
> /Joakim

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
import parser does not import parser.py in same dir on win Joel Hedlund Python 2 11-11-2006 03:46 PM
XML::Parser Installation error: XML-Parser-2.34 Sean Perl Misc 3 10-03-2006 01:23 AM
XML::Parser Installation error: XML-Parser-2.34 Sean Perl Misc 0 10-02-2006 06:20 PM
Dynamically create classes for spark-parser-framework Diez B. Roggisch Python 1 12-15-2003 07:59 PM
Parser Error Message: Could not load the assembly 'Microsoft.Saturn.Framework.Mobile ... Lukasz ASP .Net Mobile 0 11-07-2003 09:52 AM



Advertisments