Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Services > Custom error page for 500 in webservices

Reply
Thread Tools

Custom error page for 500 in webservices

 
 
Nadagouda
Guest
Posts: n/a
 
      05-17-2005
Hi,

Im trying http:\\localhost\WebService1\Service1.asmx?wsdl=. I am getting
http 500 internal error instead of that i want to use mycustom page.
I tried all the following options.
1. IIS customerros tab and edit properties to point to mypage for 500.
2. web.config <customErrors mode=on defaultredirect="mypage.html"
<error status coode = 500 redirect="mypage.html"
3.global.asax
application error
using server.getlasterror
4. .htaccess
errordocument 500/mypage.html
none of the options worked.
5. finally i tried to update defaultwsdlhelpgenerator.aspx or using
myhelppagegenerator i got the error. I was not able to put
<webServices> element in web.config

please provide me solution for this issue.

thanks
Nadagouda



 
Reply With Quote
 
 
 
 
Yunus Emre ALPÖZEN [MCAD.NET]
Guest
Posts: n/a
 
      05-17-2005
Try http://localhost/WebService1/Service1.asmx?wsdl remove "=."...


--

Thanks,
Yunus Emre ALPÖZEN
BSc, MCAD.NET

"Nadagouda" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hi,
>
> Im trying http:\\localhost\WebService1\Service1.asmx?wsdl=. I am getting
> http 500 internal error instead of that i want to use mycustom page.
> I tried all the following options.
> 1. IIS customerros tab and edit properties to point to mypage for 500.
> 2. web.config <customErrors mode=on defaultredirect="mypage.html"
> <error status coode = 500 redirect="mypage.html"
> 3.global.asax
> application error
> using server.getlasterror
> 4. .htaccess
> errordocument 500/mypage.html
> none of the options worked.
> 5. finally i tried to update defaultwsdlhelpgenerator.aspx or using
> myhelppagegenerator i got the error. I was not able to put
> <webServices> element in web.config
>
> please provide me solution for this issue.
>
> thanks
> Nadagouda
>
>
>



 
Reply With Quote
 
 
 
 
Nadagouda
Guest
Posts: n/a
 
      05-18-2005
hi,
I know that , I want to handle this scenario if user types likes that i
dont want him/her to see standard 500 page , instead show my custom page.

they may try like wsdl =
and also service1.asxxxx
its now allowing me to use custom page for these particular cases when i
type wsdl= and also if i give wrong file extensions

Thanks
Gouda

"Yunus Emre ALPĂ–ZEN [MCAD.NET]" wrote:

> Try http://localhost/WebService1/Service1.asmx?wsdl remove "=."...
>
>
> --
>
> Thanks,
> Yunus Emre ALPĂ–ZEN
> BSc, MCAD.NET
>
> "Nadagouda" <(E-Mail Removed)> wrote in message
> news:(E-Mail Removed)...
> > Hi,
> >
> > Im trying http:\\localhost\WebService1\Service1.asmx?wsdl=. I am getting
> > http 500 internal error instead of that i want to use mycustom page.
> > I tried all the following options.
> > 1. IIS customerros tab and edit properties to point to mypage for 500.
> > 2. web.config <customErrors mode=on defaultredirect="mypage.html"
> > <error status coode = 500 redirect="mypage.html"
> > 3.global.asax
> > application error
> > using server.getlasterror
> > 4. .htaccess
> > errordocument 500/mypage.html
> > none of the options worked.
> > 5. finally i tried to update defaultwsdlhelpgenerator.aspx or using
> > myhelppagegenerator i got the error. I was not able to put
> > <webServices> element in web.config
> >
> > please provide me solution for this issue.
> >
> > thanks
> > Nadagouda
> >
> >
> >

>
>
>

 
Reply With Quote
 
Nadagouda
Guest
Posts: n/a
 
      05-18-2005
sorry
its NOT allowing me to use custom page for these particular cases when i
> type "wsdl= "and also if i give wrong file extensions "Service1.asxxx"


"Nadagouda" wrote:

> hi,
> I know that , I want to handle this scenario if user types likes that i
> dont want him/her to see standard 500 page , instead show my custom page.
>
> they may try like wsdl =
> and also service1.asxxxx
> its now allowing me to use custom page for these particular cases when i
> type wsdl= and also if i give wrong file extensions
>
> Thanks
> Gouda
>
> "Yunus Emre ALPĂ–ZEN [MCAD.NET]" wrote:
>
> > Try http://localhost/WebService1/Service1.asmx?wsdl remove "=."...
> >
> >
> > --
> >
> > Thanks,
> > Yunus Emre ALPĂ–ZEN
> > BSc, MCAD.NET
> >
> > "Nadagouda" <(E-Mail Removed)> wrote in message
> > news:(E-Mail Removed)...
> > > Hi,
> > >
> > > Im trying http:\\localhost\WebService1\Service1.asmx?wsdl=. I am getting
> > > http 500 internal error instead of that i want to use mycustom page.
> > > I tried all the following options.
> > > 1. IIS customerros tab and edit properties to point to mypage for 500.
> > > 2. web.config <customErrors mode=on defaultredirect="mypage.html"
> > > <error status coode = 500 redirect="mypage.html"
> > > 3.global.asax
> > > application error
> > > using server.getlasterror
> > > 4. .htaccess
> > > errordocument 500/mypage.html
> > > none of the options worked.
> > > 5. finally i tried to update defaultwsdlhelpgenerator.aspx or using
> > > myhelppagegenerator i got the error. I was not able to put
> > > <webServices> element in web.config
> > >
> > > please provide me solution for this issue.
> > >
> > > thanks
> > > Nadagouda
> > >
> > >
> > >

> >
> >
> >

 
Reply With Quote
 
Nadagouda
Guest
Posts: n/a
 
      05-18-2005
sorry
its NOT allowing me to use custom page for these particular cases when i
> type "wsdl= "and also if i give wrong file extensions "Service1.asxxx"




"Nadagouda" wrote:

> hi,
> I know that , I want to handle this scenario if user types likes that i
> dont want him/her to see standard 500 page , instead show my custom page.
>
> they may try like wsdl =
> and also service1.asxxxx
> its now allowing me to use custom page for these particular cases when i
> type wsdl= and also if i give wrong file extensions
>
> Thanks
> Gouda
>
> "Yunus Emre ALPĂ–ZEN [MCAD.NET]" wrote:
>
> > Try http://localhost/WebService1/Service1.asmx?wsdl remove "=."...
> >
> >
> > --
> >
> > Thanks,
> > Yunus Emre ALPĂ–ZEN
> > BSc, MCAD.NET
> >
> > "Nadagouda" <(E-Mail Removed)> wrote in message
> > news:(E-Mail Removed)...
> > > Hi,
> > >
> > > Im trying http:\\localhost\WebService1\Service1.asmx?wsdl=. I am getting
> > > http 500 internal error instead of that i want to use mycustom page.
> > > I tried all the following options.
> > > 1. IIS customerros tab and edit properties to point to mypage for 500.
> > > 2. web.config <customErrors mode=on defaultredirect="mypage.html"
> > > <error status coode = 500 redirect="mypage.html"
> > > 3.global.asax
> > > application error
> > > using server.getlasterror
> > > 4. .htaccess
> > > errordocument 500/mypage.html
> > > none of the options worked.
> > > 5. finally i tried to update defaultwsdlhelpgenerator.aspx or using
> > > myhelppagegenerator i got the error. I was not able to put
> > > <webServices> element in web.config
> > >
> > > please provide me solution for this issue.
> > >
> > > thanks
> > > Nadagouda
> > >
> > >
> > >

> >
> >
> >

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to retrive 404 error page to my custom error page Sujan Javascript 1 03-10-2006 05:08 PM
PIX log reporting 169.254.126.114/500 dst outside:192.168.100.2/500 hoser Cisco 2 04-15-2005 05:22 PM
Error 500: ERROR: Cannot forward. Writer or Stream already obtained. Error JavaQueries Java 1 03-01-2005 06:30 PM
stack overflow just because of a double array[500][500]? James C++ 2 11-03-2004 09:05 AM
Re: custom error 500 not loads z. f. ASP .Net 2 10-11-2004 06:11 AM



Advertisments