Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Services > xsi nil=true

Reply
Thread Tools

xsi nil=true

 
 
arjun.chakraborty@gmail.com
Guest
Posts: n/a
 
      04-25-2005
Hi All,

I have a deeply nested class structure defined in a web service. An
object of this class type is received as an input parameter in the only
web method present in the web service. When, I try to execute the
service, I am not able to see the entire xml request schema. It
displays till the 5th level node only. After that, an attribute
xsi:nil=true comes up.

HTTP/1.1 200 OK
Content-Type: text/xml; charset=utf-8
Content-Length: length

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlnssi="http://www.w3.org/2001/XMLSchema-instance"
xmlnssd="http://www.w3.org/2001/XMLSchema"
xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
<soap:Body>
<HelloWorldResponse xmlns="http://tempuri.org/">
<HelloWorldResult>
<objClass2>
<objClass3>
<objClass4 xsi:nil="true" />
</objClass3>
</objClass2>
</HelloWorldResult>
</HelloWorldResponse>
</soap:Body>
</soap:Envelope>


Any help would be appreciated
Arjun

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
XSI type not supported withing web.config file =?Utf-8?B?WUM=?= ASP .Net 0 04-05-2006 07:00 AM
validate element with attribute xsi:type="xsd:string" johnsocs@gmail.com XML 8 06-09-2005 11:16 AM
Empty Elements: implicit xsi:nil="true" possible ? Stefan Prange XML 0 03-16-2005 10:29 AM
correct use of xsi:schemaLocation Sarah Tegtmeier XML 0 01-16-2004 10:04 AM
Validating XML document without using "xsi:schemaLocation" attribute Naresh Agarwal XML 1 01-13-2004 12:33 PM



Advertisments