Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Services > Web Service works in VS.NET 1.1, but not VS.NET 2.0

Reply
Thread Tools

Web Service works in VS.NET 1.1, but not VS.NET 2.0

 
 
Jim
Guest
Posts: n/a
 
      04-14-2005
Hi,

I'm not very versed in the use of web services, so please bear with me!

I'm trying to consume a web service using Visual Studio 2005 (the Feb.
Community Technology Preview). I'm trying to register a web service WSDL.
I am able to do so successfully using VS.NET 1.1, but when I try to Add Web
Reference to the same WSDL in VS.NET 2.0, I get the following error:

The document at the url <url.wsdl> was not recognized as a known document
type.
The error message from each known type may help you fix the problem:
- Report from 'DISCO Document' is 'Discovery document at the URL <url.wsdl>
could not be found.'.
- The document format is not recognized.
- Report from 'WSDL Document' is 'There is an error in the XML document.'.
- The element is not supported in this context: <xsd:documentation
xmlnssd="http://www.w3.org/2001/XMLSchema">IDs for sources, empty array
means describe all</xsd:documentation>.
- Report from 'XML Schema' is 'Expected Schema root. Make sure that the root
element is <schema> and the namespace is 'http://www.w3.org/2001/XMLSchema'
for an XSD schema or 'urn:schemas-microsoft-comml-data' for an XDR
schema.'.

According to the web service documentation, the web service uses the SOAP
1.1 protocol with the rpc/encoded encoding style.

Can anybody shed some light on this problem for me??

Thanks, Jim


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
When I turn on my PC, it works, works, works. Problem! Fogar Computer Information 1 01-17-2006 12:57 AM
InvocationTargetException when calling "new Service()" in Axis web service to call another web service Michael Averstegge Java 0 01-10-2006 11:05 PM
Web Service works in VS.NET 1.1, but not VS.NET 2.0 Jim ASP .Net 0 04-14-2005 09:39 PM
[py2exe.i18n] English works, German works, but not French. What do I miss? F. GEIGER Python 3 08-06-2004 10:01 AM
After rebooting my PC works, works, works! Antivirus problem? Adriano Computer Information 1 12-15-2003 05:30 AM



Advertisments