Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Services > Custom object parameter

Reply
Thread Tools

Custom object parameter

 
 
Chakra
Guest
Posts: n/a
 
      12-22-2004
I have a web method which works when i send a custom object as a parameter.
Today i added a DataSet after the Custom object and it wouldn't execute the
Web method at all. Then, when i interchanged the order of the parameters to
Dataset, Object, it worked . Why could this be so ?



 
Reply With Quote
 
 
 
 
Bruce Johnson [.NET MVP]
Guest
Posts: n/a
 
      12-22-2004
Does your custom object do anything unusual? Like implementing the
IXmlSerializable interface?

Bruce Johnson [.NET MVP]
http://www.objectsharp.com/blogs/bruce

"Chakra" wrote:

> I have a web method which works when i send a custom object as a parameter.
> Today i added a DataSet after the Custom object and it wouldn't execute the
> Web method at all. Then, when i interchanged the order of the parameters to
> Dataset, Object, it worked . Why could this be so ?
>
>
>
>

 
Reply With Quote
 
 
 
 
Dan Rogers
Guest
Posts: n/a
 
      12-22-2004
There is a known issue (this may not be the issue you are seeing) when
using a custom class that implements it's own serializer (always a bad bad
bad idea) that makes argument order critical.

If you have implemented your own serializer, try to undo that decision -
I've never seen a good reason for it (although I've seen many teams justify
it for what I consider to be examples of flawed reasoning).

I hope this helps

Dan Rogers
Microsoft Corporation
--------------------
>From: "Chakra" <(E-Mail Removed)>
>Subject: Custom object parameter
>Date: Wed, 22 Dec 2004 16:39:15 +0530
>Lines: 7
>X-Priority: 3
>X-MSMail-Priority: Normal
>X-Newsreader: Microsoft Outlook Express 6.00.2800.1437
>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1441
>Message-ID: <(E-Mail Removed)>
>Newsgroups: microsoft.public.dotnet.framework.aspnet.webservic es
>NNTP-Posting-Host: dsl-kk-035.206.95.61.touchtelindia.net 61.95.206.35
>Path:

cpmsftngxa10.phx.gbl!TK2MSFTFEED02.phx.gbl!TK2MSFT NGP08.phx.gbl!TK2MSFTNGP15
phx.gbl
>Xref: cpmsftngxa10.phx.gbl

microsoft.public.dotnet.framework.aspnet.webservic es:27348
>X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet.webservic es
>
>I have a web method which works when i send a custom object as a parameter.
>Today i added a DataSet after the Custom object and it wouldn't execute the
>Web method at all. Then, when i interchanged the order of the parameters to
>Dataset, Object, it worked . Why could this be so ?
>
>
>
>


 
Reply With Quote
 
Chakra
Guest
Posts: n/a
 
      12-28-2004
No it does not do anything unusual like that.


"Bruce Johnson [.NET MVP]" <(E-Mail Removed)> wrote in
message news:(E-Mail Removed)...
> Does your custom object do anything unusual? Like implementing the
> IXmlSerializable interface?
>
> Bruce Johnson [.NET MVP]
> http://www.objectsharp.com/blogs/bruce
>
> "Chakra" wrote:
>
> > I have a web method which works when i send a custom object as a

parameter.
> > Today i added a DataSet after the Custom object and it wouldn't execute

the
> > Web method at all. Then, when i interchanged the order of the parameters

to
> > Dataset, Object, it worked . Why could this be so ?
> >
> >
> >
> >



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Parameter List / Parameter Block / Anything patterns... mast2as@yahoo.com C++ 4 03-29-2007 09:37 PM
Custom control within repeater with custom object binding - .net 1 =?Utf-8?B?SmF5YnVmZmV0?= ASP .Net 9 02-21-2006 03:38 AM
Object creation - Do we really need to create a parent for a derieved object - can't the base object just point to an already created base object jon wayne C++ 9 09-22-2005 02:06 AM
How do I fix "Argument not specified for parameter 'value' of 'Public Overridable Sub Add(key As Object, value As Object)" Chuck Insight ASP .Net Web Controls 2 03-19-2005 12:03 AM
Custom object as input parameter Arcadius A. ASP .Net Web Services 1 12-16-2003 11:33 PM



Advertisments