Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Services > web config ERror

Reply
Thread Tools

web config ERror

 
 
Savas Ates
Guest
Posts: n/a
 
      12-02-2004
my web conhig code is like this and <customErrors mode="Off"/> was set off

<compilation defaultLanguage="vb" debug="true"/>

<!-- CUSTOM ERROR MESSAGES
Set customErrors mode="Off" or "RemoteOnly" to enable custom error
messages, "Off" to disable.
Add <error> tags for each of the errors you want to handle.
-->
<customErrors mode="Off"/>

<!-- AUTHENTICATION
This section sets the authentication policies of the application.
Possible modes are "Windows",
"Forms", "Passport" and "None"
-->
<authentication mode="Windows"/>


<!-- AUTHORIZATION
This section sets the authorization policies of the application.
You can allow or deny access
to application resources by user or role. Wildcards: "*" mean
everyone, "?" means anonymous
(unauthenticated) users.
-->
<authorization>
<allow users="*"/> <!-- Allow all users -->

Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>


Notes: The current error page you are seeing can be replaced by a custom
error page by modifying the "defaultRedirect" attribute of the application's
<customErrors> configuration tag to point to a custom error page URL.


<!-- Web.Config Configuration File -->

<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>




 
Reply With Quote
 
 
 
 
Dan Rogers
Guest
Posts: n/a
 
      12-02-2004
Hi Savas?

Is there an issue that I can help you with? This error message is
displayed when a web service has thrown an exception that is not caught,
and the calling browser is not on the same machine as the web service. It
usually indicates that there is a problem (bug?) in the program. By
default, a stack trace is surpressed so as to not reveal too much to a
remote caller.

I hope this helps,

Dan Rogers
Microsoft Corporation
--------------------
>From: "Savas Ates" <(E-Mail Removed)>
>Subject: web config ERror
>Date: Thu, 2 Dec 2004 10:04:29 +0200
>Lines: 70
>X-Priority: 3
>X-MSMail-Priority: Normal
>X-Newsreader: Microsoft Outlook Express 6.00.2900.2180
>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
>X-RFC2646: Format=Flowed; Original
>Message-ID: <(E-Mail Removed)>
>Newsgroups: microsoft.public.dotnet.framework.aspnet.webservic es
>NNTP-Posting-Host: dsl81-215-37958.adsl.ttnet.net.tr 81.215.148.70
>Path:

cpmsftngxa10.phx.gbl!TK2MSFTNGXA03.phx.gbl!TK2MSFT NGP08.phx.gbl!TK2MSFTNGP11
phx.gbl
>Xref: cpmsftngxa10.phx.gbl

microsoft.public.dotnet.framework.aspnet.webservic es:26985
>X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet.webservic es
>
> my web conhig code is like this and <customErrors mode="Off"/> was set

off
>
> <compilation defaultLanguage="vb" debug="true"/>
>
> <!-- CUSTOM ERROR MESSAGES
> Set customErrors mode="Off" or "RemoteOnly" to enable custom

error
>messages, "Off" to disable.
> Add <error> tags for each of the errors you want to handle.
> -->
> <customErrors mode="Off"/>
>
> <!-- AUTHENTICATION
> This section sets the authentication policies of the

application.
>Possible modes are "Windows",
> "Forms", "Passport" and "None"
> -->
> <authentication mode="Windows"/>
>
>
> <!-- AUTHORIZATION
> This section sets the authorization policies of the application.
>You can allow or deny access
> to application resources by user or role. Wildcards: "*" mean
>everyone, "?" means anonymous
> (unauthenticated) users.
> -->
> <authorization>
> <allow users="*"/> <!-- Allow all users -->
>
>Server Error in '/' Application.
>---------------------------------------------------------------------------

-----
>
>Runtime Error
>Description: An application error occurred on the server. The current

custom
>error settings for this application prevent the details of the application
>error from being viewed remotely (for security reasons). It could,

however,
>be viewed by browsers running on the local server machine.
>
>Details: To enable the details of this specific error message to be

viewable
>on remote machines, please create a <customErrors> tag within a

"web.config"
>configuration file located in the root directory of the current web
>application. This <customErrors> tag should then have its "mode" attribute
>set to "Off".
>
>
><!-- Web.Config Configuration File -->
>
><configuration>
> <system.web>
> <customErrors mode="Off"/>
> </system.web>
></configuration>
>
>
>Notes: The current error page you are seeing can be replaced by a custom
>error page by modifying the "defaultRedirect" attribute of the

application's
><customErrors> configuration tag to point to a custom error page URL.
>
>
><!-- Web.Config Configuration File -->
>
><configuration>
> <system.web>
> <customErrors mode="RemoteOnly"

defaultRedirect="mycustompage.htm"/>
> </system.web>
></configuration>
>
>
>
>
>


 
Reply With Quote
 
 
 
 
jwelch1978@hotmail.com
Guest
Posts: n/a
 
      12-23-2004
how do I get to my ''root directory" and change my ''web configuration'' and have the mode set to off I want to create a profile to be able to log onto the blockbuster.ca/getmore site ?

************************************************** ********************
Sent via Fuzzy Software @ http://www.fuzzysoftware.com/
Comprehensive, categorised, searchable collection of links to ASP & ASP.NET resources...
 
Reply With Quote
 
Dan Rogers
Guest
Posts: n/a
 
      01-04-2005
Hi Jonathan,

I'm not following you. If you need to change your web.config file, it is
typically found in the virtual root that is serving your web service. I'm
not sure what config changes you want to make, and I don't know what this
has to do with blockbuster's site. If you just want to go to their web
page and log in, you should do that.

I tried that URL and there is very little for you to do with your root
directory or web config file ... that is a simple cookie based portal login
page. You won't be able to call it via a web service proxy. Just use your
browser...

Dan
--------------------
>From: Jonathan Welch ((E-Mail Removed))
>Subject: Re: web config ERror
>References: <(E-Mail Removed)>
>Message-ID: <(E-Mail Removed)>
>Newsgroups: microsoft.public.dotnet.framework.aspnet.webservic es
>Date: Thu, 23 Dec 2004 12:21:23 -0800
>NNTP-Posting-Host: shared2.orcsweb.com 66.129.69.1
>Lines: 1
>Path:

cpmsftngxa10.phx.gbl!TK2MSFTFEED02.phx.gbl!TK2MSFT NGP08.phx.gbl!TK2MSFTNGP11
.phx.gbl
>Xref: cpmsftngxa10.phx.gbl

microsoft.public.dotnet.framework.aspnet.webservic es:27376
>X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet.webservic es
>
>how do I get to my ''root directory" and change my ''web configuration''

and have the mode set to off I want to create a profile to be able to log
onto the blockbuster.ca/getmore site ?
>
>************************************************* *********************
>Sent via Fuzzy Software @ http://www.fuzzysoftware.com/
>Comprehensive, categorised, searchable collection of links to ASP &

ASP.NET resources...
>


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dll config and web.config and Label Expressions (binding label text to dll config settings) CSharpner ASP .Net 0 04-09-2007 09:00 PM
how to let the web.config in the sub-directory to NOT to inherited from Root's web.config. Benny Ng ASP .Net 9 10-13-2005 03:27 PM
Configuration Error - c:\winnt\microsoft.net\framework\v1.1.4322\Config\machine.config Ivan ASP .Net 1 05-21-2004 04:18 AM
Error loading XML file c:\windows\microsoft.net\framework\v1.0.3705\Config\machine.config CSharpner ASP .Net Security 0 04-19-2004 02:04 AM
Machine.config & web.config =?Utf-8?B?RGFuaWVs?= ASP .Net 2 01-18-2004 08:06 PM



Advertisments