Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Services > application_start in webservices

Reply
Thread Tools

application_start in webservices

 
 
mekim
Guest
Posts: n/a
 
      10-27-2004
Hello...since application_start is not being called when u invoke a
webservice for the first time...where r u suppose to or how r u suppose to
persist "application_start" global variables?

My "work" around is to launch a webform1 that starts application_start...but
that seems silly

Regards,
mekim
 
Reply With Quote
 
 
 
 
Dan Rogers
Guest
Posts: n/a
 
      11-24-2004
Hi,

In general, the advice is to make your web services stateless - that is not
use any server side state to store session information. The easiest way to
manage state across the web service bounday is to activate cookies (proxy
must accept cookies) and use cookies to persist state across the call.

I hope this helps

Dan Rogers
Microsoft Corporation
--------------------
>Thread-Topic: application_start in webservices
>thread-index: AcS8PIA/+zI5+mhDRIKfmmpTSOMX1w==
>X-WBNR-Posting-Host: 68.157.85.195
>From: "=?Utf-8?B?bWVraW0=?=" <(E-Mail Removed)>
>Subject: application_start in webservices
>Date: Wed, 27 Oct 2004 08:49:10 -0700
>Lines: 9
>Message-ID: <(E-Mail Removed)>
>MIME-Version: 1.0
>Content-Type: text/plain;
> charset="Utf-8"
>Content-Transfer-Encoding: 7bit
>X-Newsreader: Microsoft CDO for Windows 2000
>Content-Class: urn:content-classes:message
>Importance: normal
>Priority: normal
>X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
>Newsgroups: microsoft.public.dotnet.framework.aspnet.webservic es
>NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.1.29
>Path: cpmsftngxa10.phx.gbl!TK2MSFTNGXA03.phx.gbl
>Xref: cpmsftngxa10.phx.gbl

microsoft.public.dotnet.framework.aspnet.webservic es:26278
>X-Tomcat-NG: microsoft.public.dotnet.framework.aspnet.webservic es
>
>Hello...since application_start is not being called when u invoke a
>webservice for the first time...where r u suppose to or how r u suppose to
>persist "application_start" global variables?
>
>My "work" around is to launch a webform1 that starts

application_start...but
>that seems silly
>
>Regards,
>mekim
>


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Application_Start not firing in global.asax Max ASP .Net 5 12-07-2011 07:48 PM
Question About Application_Start in Global.asax and async functions Bob Johnson ASP .Net 4 11-13-2003 05:02 PM
Creating diretories on Application_Start Leonardo Gangemi ASP .Net 3 08-14-2003 08:52 PM
HttpApplication Init, Application_Start and Application_End don't fire Halcyon Woodward ASP .Net 3 07-16-2003 04:34 PM
Application_Start not firing at all Adrian ASP .Net 0 07-02-2003 03:07 PM



Advertisments