Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Services > Problem deploying web service

Reply
Thread Tools

Problem deploying web service

 
 
Sky Fly
Guest
Posts: n/a
 
      07-29-2003
Hello,

I am trying to deploy a web service on a remote server.
I have been able to develop the web service on my
development machine using VB.NET 2003, and when I open
a browser and type in
http://localhost/MyApplication/MyWebService.asmx in
the browser, I am able to see a page that lists a description
of the web service and the methods it exposes.

However, when I copy the assemblies in the bin folder
to the remote server and attempt to view the web service
description by typing
http://www.<remoteserver>.com/MyApplication/MyWebService.asmx,
I get the following error:

Parser Error Message: Could not create type 'MyApplication.MyWebService'.

Source Error:

Line 1: <%@ WebService Language="vb" Codebehind="WebService.asmx.vb"
Class="MyApplication.MyWebService" %>

I've checked that the directory that the bin file is under
on the server has been made a virtual directory in IIS as
well as an application. I've restarted IIS after each
change, but this seems to make no difference. The only
other thing I can think of is that an older version of the
web service that was built using a previous version of VB.NET
seems to work fine on the server.

I hope that I can get some help - when I checked on Google,
it seemed as though there wasn't much help for people with
this kind of problem.

Thanks in advance,

--
Akin

aknak at aksoto dot idps dot co dot uk




 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Deploying a web service (VS 2005) timsohn@gmail.com ASP .Net 3 02-04-2009 07:34 AM
Problem deploying web-application and web-service on same IIS server. Jan Obrestad ASP .Net 0 12-05-2007 02:54 PM
Error deploying web service Lucas Ponzo ASP .Net Security 0 08-17-2006 05:57 AM
InvocationTargetException when calling "new Service()" in Axis web service to call another web service Michael Averstegge Java 0 01-10-2006 11:05 PM
deploying and re-deploying ASP.Net applications =?Utf-8?B?VG9tIE4=?= ASP .Net 2 02-04-2004 09:31 PM



Advertisments