Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Controls > Reportviewer not showing any data

Reply
Thread Tools

Reportviewer not showing any data

 
 
gandhi.vishal@gmail.com
Guest
Posts: n/a
 
      11-03-2008
Hello,
I have an issue. I'm not seeing the reportviewer data at all. The
column names come up fine but there is no data in the report table.
Here is what I'm doing

I created a dataset with the following query
select * from av_project_mst where apm_project_id=@projectid

Now I created a report (.rdlc) and dragged a table onto it and the
report looks like the following

<?xml version="1.0" encoding="utf-8"?>
<Report xmlns="http://schemas.microsoft.com/sqlserver/reporting/
2005/01/reportdefinition" xmlns:rd="http://schemas.microsoft.com/
SQLServer/reporting/reportdesigner">
<DataSources>
<DataSource Name="test1">
<rdataSourceID>0ac0f7f1-9a46-4289-a79d-97cab9205b09</
rdataSourceID>
<ConnectionProperties>
<DataProvider>SQL</DataProvider>
<ConnectString />
</ConnectionProperties>
</DataSource>
</DataSources>
<InteractiveHeight>11in</InteractiveHeight>
<ReportParameters>
<ReportParameter Name="projectid">
<DataType>String</DataType>
<DefaultValue>
<Values>
<Value />
</Values>
</DefaultValue>
<AllowBlank>true</AllowBlank>
<Prompt>Report_Parameter_0</Prompt>
</ReportParameter>
</ReportParameters>
<rdrawGrid>true</rdrawGrid>
<InteractiveWidth>8.5in</InteractiveWidth>
<rd:SnapToGrid>true</rd:SnapToGrid>
<RightMargin>1in</RightMargin>
<LeftMargin>1in</LeftMargin>
<BottomMargin>1in</BottomMargin>
<rd:ReportID>4b5ab029-97b6-4439-966e-4a51232b81d2</rd:ReportID>
<DataSets>
<DataSet Name="DataSet1_AV_PROJECT_MST1">
<Fields>
<Field Name="APM_Project_Name">
<DataField>APM_Project_Name</DataField>
<rd:TypeName>System.String</rd:TypeName>
</Field>
<Field Name="APM_Project_Start_Date">
<DataField>APM_Project_Start_Date</DataField>
<rd:TypeName>System.DateTime</rd:TypeName>
</Field>
<Field Name="APM_Project_End_Date">
<DataField>APM_Project_End_Date</DataField>
<rd:TypeName>System.DateTime</rd:TypeName>
</Field>
<Field Name="APM_Project_InCharge">
<DataField>APM_Project_InCharge</DataField>
<rd:TypeName>System.String</rd:TypeName>
</Field>
<Field Name="APM_Project_Desc">
<DataField>APM_Project_Desc</DataField>
<rd:TypeName>System.String</rd:TypeName>
</Field>
<Field Name="APM_Project_ID">
<DataField>APM_Project_ID</DataField>
<rd:TypeName>System.Int32</rd:TypeName>
</Field>
<Field Name="APM_RECADDID">
<DataField>APM_RECADDID</DataField>
<rd:TypeName>System.String</rd:TypeName>
</Field>
<Field Name="APM_RECADDDATE">
<DataField>APM_RECADDDATE</DataField>
<rd:TypeName>System.DateTime</rd:TypeName>
</Field>
<Field Name="APM_RECUPDATEID">
<DataField>APM_RECUPDATEID</DataField>
<rd:TypeName>System.String</rd:TypeName>
</Field>
<Field Name="APM_RECUPDATEDATE">
<DataField>APM_RECUPDATEDATE</DataField>
<rd:TypeName>System.DateTime</rd:TypeName>
</Field>
</Fields>
<Query>
<DataSourceName>test1</DataSourceName>
<CommandText>select * from av_project_mst where
apm_project_id=@projectid</CommandText>
<rd:UseGenericDesigner>true</rd:UseGenericDesigner>
</Query>
<rdataSetInfo>
<rdataSetName>DataSet1</rdataSetName>
<rd:TableName>AV_PROJECT_MST</rd:TableName>
<rd:TableAdapterName>AV_PROJECT_MSTTableAdapter</
rd:TableAdapterName>
<rd:TableAdapterFillMethod>Fill</rd:TableAdapterFillMethod>
<rd:TableAdapterGetDataMethod>GetData</
rd:TableAdapterGetDataMethod>
</rdataSetInfo>
</DataSet>
</DataSets>
<Width>10.83333in</Width>
<Body>
<ReportItems>
<Table Name="table1">
<DataSetName>DataSet1_AV_PROJECT_MST1</DataSetName>
<Top>0.75in</Top>
<Details>
<TableRows>
<TableRow>
<TableCells>
<TableCell>
<ReportItems>
<Textbox Name="APM_Project_Name">
<rdefaultName>APM_Project_Name</
rdefaultName>
<Style>
<PaddingLeft>2pt</PaddingLeft>
<PaddingRight>2pt</PaddingRight>
<PaddingTop>2pt</PaddingTop>
<PaddingBottom>2pt</PaddingBottom>
</Style>
<ZIndex>2</ZIndex>
<CanGrow>true</CanGrow>
<Value>=First(Fields!APM_Project_Name.Value)</
Value>
</Textbox>
</ReportItems>
</TableCell>
<TableCell>
<ReportItems>
<Textbox Name="APM_Project_Start_Date">
<rdefaultName>APM_Project_Start_Date</
rdefaultName>
<Style>
<PaddingLeft>2pt</PaddingLeft>
<PaddingRight>2pt</PaddingRight>
<PaddingTop>2pt</PaddingTop>
<PaddingBottom>2pt</PaddingBottom>
</Style>
<ZIndex>1</ZIndex>
<CanGrow>true</CanGrow>
<Value>=First(Fields!
APM_Project_Start_Date.Value)</Value>
</Textbox>
</ReportItems>
</TableCell>
<TableCell>
<ReportItems>
<Textbox Name="textbox6">
<rdefaultName>textbox6</rdefaultName>
<Style>
<PaddingLeft>2pt</PaddingLeft>
<PaddingRight>2pt</PaddingRight>
<PaddingTop>2pt</PaddingTop>
<PaddingBottom>2pt</PaddingBottom>
</Style>
<CanGrow>true</CanGrow>
<Value />
</Textbox>
</ReportItems>
</TableCell>
</TableCells>
<Height>0.25in</Height>
</TableRow>
</TableRows>
</Details>
<Header>
<TableRows>
<TableRow>
<TableCells>
<TableCell>
<ReportItems>
<Textbox Name="textbox1">
<rdefaultName>textbox1</rdefaultName>
<Style>
<PaddingLeft>2pt</PaddingLeft>
<PaddingRight>2pt</PaddingRight>
<PaddingTop>2pt</PaddingTop>
<PaddingBottom>2pt</PaddingBottom>
</Style>
<ZIndex>8</ZIndex>
<CanGrow>true</CanGrow>
<Value>APM Project Name</Value>
</Textbox>
</ReportItems>
</TableCell>
<TableCell>
<ReportItems>
<Textbox Name="textbox2">
<rdefaultName>textbox2</rdefaultName>
<Style>
<PaddingLeft>2pt</PaddingLeft>
<PaddingRight>2pt</PaddingRight>
<PaddingTop>2pt</PaddingTop>
<PaddingBottom>2pt</PaddingBottom>
</Style>
<ZIndex>7</ZIndex>
<CanGrow>true</CanGrow>
<Value>APM Project Start Date</Value>
</Textbox>
</ReportItems>
</TableCell>
<TableCell>
<ReportItems>
<Textbox Name="textbox3">
<rdefaultName>textbox3</rdefaultName>
<Style>
<PaddingLeft>2pt</PaddingLeft>
<PaddingRight>2pt</PaddingRight>
<PaddingTop>2pt</PaddingTop>
<PaddingBottom>2pt</PaddingBottom>
</Style>
<ZIndex>6</ZIndex>
<CanGrow>true</CanGrow>
<Value />
</Textbox>
</ReportItems>
</TableCell>
</TableCells>
<Height>0.25in</Height>
</TableRow>
</TableRows>
</Header>
<TableColumns>
<TableColumn>
<Width>3.61111in</Width>
</TableColumn>
<TableColumn>
<Width>3.61111in</Width>
</TableColumn>
<TableColumn>
<Width>3.61111in</Width>
</TableColumn>
</TableColumns>
<Height>0.75in</Height>
<Footer>
<TableRows>
<TableRow>
<TableCells>
<TableCell>
<ReportItems>
<Textbox Name="textbox7">
<rdefaultName>textbox7</rdefaultName>
<Style>
<PaddingLeft>2pt</PaddingLeft>
<PaddingRight>2pt</PaddingRight>
<PaddingTop>2pt</PaddingTop>
<PaddingBottom>2pt</PaddingBottom>
</Style>
<ZIndex>5</ZIndex>
<CanGrow>true</CanGrow>
<Value />
</Textbox>
</ReportItems>
</TableCell>
<TableCell>
<ReportItems>
<Textbox Name="textbox8">
<rdefaultName>textbox8</rdefaultName>
<Style>
<PaddingLeft>2pt</PaddingLeft>
<PaddingRight>2pt</PaddingRight>
<PaddingTop>2pt</PaddingTop>
<PaddingBottom>2pt</PaddingBottom>
</Style>
<ZIndex>4</ZIndex>
<CanGrow>true</CanGrow>
<Value />
</Textbox>
</ReportItems>
</TableCell>
<TableCell>
<ReportItems>
<Textbox Name="textbox9">
<rdefaultName>textbox9</rdefaultName>
<Style>
<PaddingLeft>2pt</PaddingLeft>
<PaddingRight>2pt</PaddingRight>
<PaddingTop>2pt</PaddingTop>
<PaddingBottom>2pt</PaddingBottom>
</Style>
<ZIndex>3</ZIndex>
<CanGrow>true</CanGrow>
<Value />
</Textbox>
</ReportItems>
</TableCell>
</TableCells>
<Height>0.25in</Height>
</TableRow>
</TableRows>
</Footer>
</Table>
</ReportItems>
<Height>2in</Height>
</Body>
<Language>en-US</Language>
<TopMargin>1in</TopMargin>
</Report>

After this I created a aspx file and dragged the reportviewer control
onto it which looks like following

<rsweb:ReportViewer ID="ReportViewer1"
runat="server" Font-Names="Verdana" Font-Size="8pt"
Height="400px" Width="560px">
<LocalReport ReportPath="c:\inetpub
\wwwroot\sarvarpitgroup\av_system\Report\PurchaseR eport.rdlc">
<DataSources>
<rsweb:ReportDataSource
DataSourceId="ObjectDataSource1" Name="DataSet1_AV_PROJECT_MST1" />
</DataSources>
</LocalReport>
</rsweb:ReportViewer>
<asp:ObjectDataSource
ID="ObjectDataSource1" runat="server" SelectMethod="GetData"

TypeName="DataSet1TableAdapters.AV_PROJECT_MSTTabl eAdapter"
DeleteMethod="Delete" InsertMethod="Insert"
OldValuesParameterFormatString="original_{0}" UpdateMethod="Update">
<DeleteParameters>
<asparameter
Name="Original_APM_Project_ID" Type="Int32" />
</DeleteParameters>
<UpdateParameters>
<asparameter
Name="APM_Project_Name" Type="String" />
<asparameter
Name="APM_Project_Start_Date" Type="DateTime" />
<asparameter
Name="APM_Project_End_Date" Type="DateTime" />
<asparameter
Name="APM_Project_InCharge" Type="String" />
<asparameter
Name="APM_Project_Desc" Type="String" />
<asparameter Name="APM_RECADDID"
Type="String" />
<asparameter
Name="APM_RECADDDATE" Type="DateTime" />
<asparameter
Name="APM_RECUPDATEID" Type="String" />
<asparameter
Name="APM_RECUPDATEDATE" Type="DateTime" />
<asparameter
Name="Original_APM_Project_ID" Type="Int32" />
</UpdateParameters>
<SelectParameters>
<asparameter Name="projectid"
Type="Int32" />
</SelectParameters>
<InsertParameters>
<asparameter
Name="APM_Project_Name" Type="String" />
<asparameter
Name="APM_Project_Start_Date" Type="DateTime" />
<asparameter
Name="APM_Project_End_Date" Type="DateTime" />
<asparameter
Name="APM_Project_InCharge" Type="String" />
<asparameter
Name="APM_Project_Desc" Type="String" />
<asparameter Name="APM_RECADDID"
Type="String" />
<asparameter
Name="APM_RECADDDATE" Type="DateTime" />
<asparameter
Name="APM_RECUPDATEID" Type="String" />
<asparameter
Name="APM_RECUPDATEDATE" Type="DateTime" />
</InsertParameters>
</asp:ObjectDataSource>
<br />
</div>
</form></td>

In my vb file I'm doing the following
Dim userid As New ReportParameter("projectid", "2")
Dim p() As ReportParameter = {userid}
ReportViewer1.LocalReport.SetParameters(p)
ReportViewer1.LocalReport.Refresh()


Please help.
Thanks,
Vishal
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ReportViewer Webcontrol not working properly when Deployed on any Ash ASP .Net Web Controls 0 01-19-2009 11:21 PM
reportviewer in web forms not showing content or print button ns ASP .Net Web Controls 1 04-18-2007 08:47 PM
501 PIX "deny any any" "allow any any" Any Anybody? Networking Student Cisco 4 11-16-2006 10:40 PM
reportviewer toolbar images not showing Altman ASP .Net 1 07-05-2006 03:54 PM
ReportViewer "A data source instance has not been supplied for the data " problem Burak Gunay ASP .Net Web Controls 0 06-14-2006 03:08 PM



Advertisments