Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Controls > Editing .aspx/.ascx of precompiled web site (Project Portfolio Server Web Access)

Reply
Thread Tools

Editing .aspx/.ascx of precompiled web site (Project Portfolio Server Web Access)

 
 
Handle
Guest
Posts: n/a
 
      12-04-2007
I want to customize some aspx / ascx files of a precompiled site (the
project portofolio web access site). I have no access to source code.

Using Visual Studio, when I try to edit one these files in "design view", I
get the following two categories of errors:

1) Some "Cannot switch views" errors, like the following:

"Cannot switch views: This end tag has no matching start tag."
"Cannot switch views: Validation (XHTML 1.0 Transitional): Element '
myElement ' cannot be nested within element 'body'."
"Cannot switch views: Validation (XHTML 1.0 Transitional): Attribute 'align'
can be specified only once in a tag."

2) MANY "Element 'myElement' is not a known element.." errors, as:

"Element 'Benefits' is not a known element. This can occur if there is a
compilation error in the Web site"

In relation to registered user controls, like:
..
<%@ Register TagPrefix="WP" TagName="Schedule"
Src="../Parts/Projects/Schedule.ascx" %>
..


The web site Im trying to customize is the Project Portfolio 2007 Web
Access (fresh install and working properly).

Using VS 2005 SP1, opening the site by using the "Open site" from "file"
menu.


 
Reply With Quote
 
 
 
 
coolCoder
Guest
Posts: n/a
 
      12-04-2007
On Dec 4, 9:10 pm, "Handle" <(E-Mail Removed)> wrote:
> I want to customize some aspx / ascx files of a precompiled site (the
> project portofolio web access site). I have no access to source code.
>
> Using Visual Studio, when I try to edit one these files in "design view", I
> get the following two categories of errors:
>
> 1) Some "Cannot switch views" errors, like the following:
>
> "Cannot switch views: This end tag has no matching start tag."
> "Cannot switch views: Validation (XHTML 1.0 Transitional): Element '
> myElement ' cannot be nested within element 'body'."
> "Cannot switch views: Validation (XHTML 1.0 Transitional): Attribute 'align'
> can be specified only once in a tag."
>
> 2) MANY "Element 'myElement' is not a known element.." errors, as:
>
> "Element 'Benefits' is not a known element. This can occur if there is a
> compilation error in the Web site"
>
> In relation to registered user controls, like:
> .
> <%@ Register TagPrefix="WP" TagName="Schedule"
> Src="../Parts/Projects/Schedule.ascx" %>
> .
>
> The web site Im trying to customize is the Project Portfolio 2007 Web
> Access (fresh install and working properly).
>
> Using VS 2005 SP1, opening the site by using the "Open site" from "file"
> menu.


These errors are related to the XML validation. Try changing the XML
validation from the context menu on the html code itself. Try changing
it to some older browser config. Hope this helps.
 
Reply With Quote
 
 
 
 
Handle
Guest
Posts: n/a
 
      12-04-2007
>These errors are related to the XML validation. Try changing the XML
>validation from the context menu on the html code itself. Try changing
>it to some older browser config. Hope this helps.


I disabled validation from "tools" --> "options" -- it did not work.


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Precompiled site and web crawlers RML ASP .Net 1 06-15-2010 07:37 PM
Editing .aspx/.ascx of precompiled web site (Project Portfolio Server Web Access) Handle ASP .Net 2 12-04-2007 04:42 PM
Can precompiled app be moved over to another web server? pedestrian ASP .Net 2 02-06-2007 12:10 PM
error when moving a vs 2005 precompiled site to test server =?Utf-8?B?ZXN3YW5zb24=?= ASP .Net 3 02-24-2006 06:26 AM
error when moving a vs 2005 precompiled site to test server =?Utf-8?B?ZXN3YW5zb24=?= ASP .Net 0 02-20-2006 01:23 AM



Advertisments