Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Controls > Problem with ReportViewer at deploy

Reply
Thread Tools

Problem with ReportViewer at deploy

 
 
sir_mircea
Guest
Posts: n/a
 
      03-01-2007
Hi,

I have a page that is using a ReportViewer control. When the page is
accessed from the uncompiled version it works witout problems but when the
page is accessed from the precompiled version from deploy (publish web site
or setup) I recieve the folowing exception:

Compiler Error Message: CS0030: Cannot convert type 'ASP.report_aspx' to
'Microsoft.Reporting.WebForms.Report'

Source Error:


Line 118: public report_aspx() {
Line 119: string[] dependencies;
Line 120: ((Report)(this)).AppRelativeVirtualPath =
"~/Report.aspx";
Line 121: if ((global::ASP.report_aspx.@__initialized == false))
{
Line 122: dependencies = new string[1];

Source File: c:\WINNT\Microsoft.NET\Framework\v2.0.50727\Tempor ary ASP.NET
Files\wfmaintenanceconfiguration2006precompiled\57 00de50\111dba67\App_Web_re
port.aspx.cdcab7d2.eijhuujb.0.cs Line: 120

Maybe someone have an ideea what is going on and how can I solve this
problem.

Thank you.


 
Reply With Quote
 
 
 
 
General Afify
Guest
Posts: n/a
 
      01-07-2008
On Nov 22 2007, 5:21*pm, "vinod kumar"<(E-Mail Removed)> wrote:
> Hi,Try placing the reportViewercontrol in the user control (ascx page) and
> load that on to your aspx page.This solved this issue.
>
> url:http://www.ureader.com/msg/14253464.aspx


Hi,

I faced the same problem and tried using the user control as you said
And it is working fine in the uncompiled version ...

But, gives the same error in the compiled version !!

Any suggestions ?

Thanks in advance
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Deploy won't deploy Masterpage.master GaryDean ASP .Net 1 04-14-2009 01:50 AM
ReportViewer Deploy =?Utf-8?B?SGVyYg==?= ASP .Net 1 08-31-2007 06:26 PM
Reportviewer problem =?Utf-8?B?QnJhZA==?= ASP .Net 2 02-14-2006 12:15 PM
ReportViewer/ObjectDatasource Problem =?Utf-8?B?SG91c3RvbiBMdWNpZmVy?= ASP .Net 0 12-24-2005 12:12 AM
ReportViewer problem after deploy Chris Botha ASP .Net 1 11-16-2005 07:34 PM



Advertisments