Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Controls > <customErrors mode="Off"/> ERROR

Reply
Thread Tools

<customErrors mode="Off"/> ERROR

 
 
Savas Ates
Guest
Posts: n/a
 
      12-19-2005
I have a web application It works well in my local folder.. When i upload
it
to my web server i got

To enable the details of this specific error message to be viewable on
remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".




Server Error in '/' Application.
--------------------------------------------------------------------------------

Runtime Error
Description: An application error occurred on the server. The current custom
error settings for this application prevent the details of the application
error from being viewed remotely (for security reasons). It could, however,
be viewed by browsers running on the local server machine.

Details: To enable the details of this specific error message to be viewable
on remote machines, please create a <customErrors> tag within a "web.config"
configuration file located in the root directory of the current web
application. This <customErrors> tag should then have its "mode" attribute
set to "Off".


 
Reply With Quote
 
 
 
 
sjurmr@online.no
Guest
Posts: n/a
 
      12-19-2005
It means you application crashes on the server. Put the
customerrors-tag as listed in the web.config-file to see the
error-output.

Regards,
Sjur Rondestveit

 
Reply With Quote
 
 
 
 
Ken Tucker [MVP]
Guest
Posts: n/a
 
      12-19-2005
Hi,

Usually when a web project works on a local machine but not on your
web host you are missing a dll referenced. I would check and make sure all
the dll files in your projects bin folder are on the bin folder on your web
host. Also adding that line to your web.config on your web host will give
you a lot more information about the error.

Ken
-------------
"Savas Ates" <(E-Mail Removed)> wrote in message
news:eZ$(E-Mail Removed)...
> I have a web application It works well in my local folder.. When i upload
> it
> to my web server i got
>
> To enable the details of this specific error message to be viewable on
> remote machines, please create a <customErrors> tag within a "web.config"
> configuration file located in the root directory of the current web
> application. This <customErrors> tag should then have its "mode" attribute
> set to "Off".
>
>
>
>
> Server Error in '/' Application.
> --------------------------------------------------------------------------------
>
> Runtime Error
> Description: An application error occurred on the server. The current
> custom error settings for this application prevent the details of the
> application error from being viewed remotely (for security reasons). It
> could, however, be viewed by browsers running on the local server machine.
>
> Details: To enable the details of this specific error message to be
> viewable on remote machines, please create a <customErrors> tag within a
> "web.config" configuration file located in the root directory of the
> current web application. This <customErrors> tag should then have its
> "mode" attribute set to "Off".
>
>



 
Reply With Quote
 
Savas Ates
Guest
Posts: n/a
 
      12-19-2005
I copied all bin directory with dll's.. There is no problem about missing
files.. It is my web server. I have full access to change whatever i want ..
By the way what you mean

<< Put the
customerrors-tag as listed in the web.config-file to see the
error-output.

my web.config file
<customErrors mode="Off" />



any solution ?



"Savas Ates" <(E-Mail Removed)>, haber iletisinde şunları
yazdı:eZ$(E-Mail Removed)...
> I have a web application It works well in my local folder.. When i upload
> it
> to my web server i got
>
> To enable the details of this specific error message to be viewable on
> remote machines, please create a <customErrors> tag within a "web.config"
> configuration file located in the root directory of the current web
> application. This <customErrors> tag should then have its "mode" attribute
> set to "Off".
>
>
>
>
> Server Error in '/' Application.
> --------------------------------------------------------------------------------
>
> Runtime Error
> Description: An application error occurred on the server. The current
> custom error settings for this application prevent the details of the
> application error from being viewed remotely (for security reasons). It
> could, however, be viewed by browsers running on the local server machine.
>
> Details: To enable the details of this specific error message to be
> viewable on remote machines, please create a <customErrors> tag within a
> "web.config" configuration file located in the root directory of the
> current web application. This <customErrors> tag should then have its
> "mode" attribute set to "Off".
>
>



 
Reply With Quote
 
Greg Burns
Guest
Posts: n/a
 
      12-19-2005
Isn't "Server Error in '/' Application" idicative of the virtual directory
not being marked as an application in IIS?

PS: I've also seen the <customErrors> message even when it is set to Off,
whenever there is a syntax error in the web.config.

Greg


"Savas Ates" <(E-Mail Removed)> wrote in message
news:eZ$(E-Mail Removed)...
> I have a web application It works well in my local folder.. When i upload
> it
> to my web server i got
>
> To enable the details of this specific error message to be viewable on
> remote machines, please create a <customErrors> tag within a "web.config"
> configuration file located in the root directory of the current web
> application. This <customErrors> tag should then have its "mode" attribute
> set to "Off".
>
>
>
>
> Server Error in '/' Application.
> --------------------------------------------------------------------------------
>
> Runtime Error
> Description: An application error occurred on the server. The current
> custom error settings for this application prevent the details of the
> application error from being viewed remotely (for security reasons). It
> could, however, be viewed by browsers running on the local server machine.
>
> Details: To enable the details of this specific error message to be
> viewable on remote machines, please create a <customErrors> tag within a
> "web.config" configuration file located in the root directory of the
> current web application. This <customErrors> tag should then have its
> "mode" attribute set to "Off".
>
>



 
Reply With Quote
 
vortep@gmail.com
Guest
Posts: n/a
 
      12-19-2005
do exactly what the error tells you. open the web.config
and change
<customErrors
mode="RemoteOnly"
/>

to <customErrors
mode="Off"
/>


thou shalt google before asking...

Savas Ates wrote:
> I copied all bin directory with dll's.. There is no problem about missing
> files.. It is my web server. I have full access to change whatever i want..
> By the way what you mean
>
> << Put the
> customerrors-tag as listed in the web.config-file to see the
> error-output.
>
> my web.config file
> <customErrors mode="Off" />
>
>
>
> any solution ?
>
>
>
> "Savas Ates" <(E-Mail Removed)>, haber iletisinde şunları
> yazdı:eZ$(E-Mail Removed)...
> > I have a web application It works well in my local folder.. When i upload
> > it
> > to my web server i got
> >
> > To enable the details of this specific error message to be viewable on
> > remote machines, please create a <customErrors> tag within a "web.config"
> > configuration file located in the root directory of the current web
> > application. This <customErrors> tag should then have its "mode" attribute
> > set to "Off".
> >
> >
> >
> >
> > Server Error in '/' Application.
> > --------------------------------------------------------------------------------
> >
> > Runtime Error
> > Description: An application error occurred on the server. The current
> > custom error settings for this application prevent the details of the
> > application error from being viewed remotely (for security reasons). It
> > could, however, be viewed by browsers running on the local server machine.
> >
> > Details: To enable the details of this specific error message to be
> > viewable on remote machines, please create a <customErrors> tag within a
> > "web.config" configuration file located in the root directory of the
> > current web application. This <customErrors> tag should then have its
> > "mode" attribute set to "Off".
> >
> >


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ERROR [HY000] [Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0xffc Thread 0x228 DBC 0x437b94 Jet'. ERROR [IM006] [Microsoft][ODBC Driver Manager] Driver's SQLSetConnectAttr bazzer ASP .Net 0 03-30-2006 03:16 PM
Error connecting to SQLExpress 2005 locally (error: 26 - Error Locating Server/Instance Specified) hfk0 ASP .Net 2 03-27-2006 08:43 PM
ERROR [HY000] [Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x8fc Thread 0x934 DBC 0x437b94 Jet'. ERROR [IM006] [Microsoft][ODBC Driver Manager] Driver's SQLSetConnectAttr bazzer ASP .Net 1 03-24-2006 04:20 PM
ERROR [HY000] [Microsoft][ODBC Microsoft Access Driver]General error Unable to open registry key 'Temporary (volatile) Jet DSN for process 0x8fc Thread 0x934 DBC 0x437b94 Jet'. ERROR [IM006] [Microsoft][ODBC Driver Manager] Driver's SQLSetConnectAttr bazzer ASP .Net 0 03-24-2006 02:22 PM
Error 500: ERROR: Cannot forward. Writer or Stream already obtained. Error JavaQueries Java 1 03-01-2005 06:30 PM



Advertisments