Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Controls > issues using webbrowser in a service

Reply
Thread Tools

issues using webbrowser in a service

 
 
ScottLR
Guest
Posts: n/a
 
      11-30-2005
Hello,

I am using the Webrowser control in an mfc application. It succeeds when run
as an application but not when run from a service that allows the user to
interact with the desktop:

I invoke Navigate.

I catch the DownloadComplete event.

I successfully call get_LocationURL and retreive the url. When run as an
application, the url is valid. When run as a service, the call
get_LocationURL returns an empty url.

--

Thank you,

Scott


 
Reply With Quote
 
 
 
 
TerryFei
Guest
Posts: n/a
 
      12-01-2005
Hi Scott,
Welcome to MSDN Newsgroup!

Based on your description, please help me to confirm the following
information. What does the "Service" mean? Is it a web service or a windows
service program controlled by SCM (Service Control Manager)? I would
appreciate you if you could provide me a simplified sample to reproduce
your problem on our side. I think it will help me to get closer to
resolving your issue.
I am looking forward to you. Have a nice day!

Best Regards,

Terry Fei[MSFT]
Microsoft Community Support
Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

 
Reply With Quote
 
 
 
 
ScottLR
Guest
Posts: n/a
 
      12-01-2005
Terry,

It is invoked by the service control manager. Do you have the ability to
invoke an exe from a service? Is so, I could provide simplified source for
an exe.

--

Thank you,

Scott


""TerryFei"" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hi Scott,
> Welcome to MSDN Newsgroup!
>
> Based on your description, please help me to confirm the following
> information. What does the "Service" mean? Is it a web service or a
> windows
> service program controlled by SCM (Service Control Manager)? I would
> appreciate you if you could provide me a simplified sample to reproduce
> your problem on our side. I think it will help me to get closer to
> resolving your issue.
> I am looking forward to you. Have a nice day!
>
> Best Regards,
>
> Terry Fei[MSFT]
> Microsoft Community Support
> Get Secure! www.microsoft.com/security
> (This posting is provided "AS IS", with no warranties, and confers no
> rights.)
>



 
Reply With Quote
 
TerryFei
Guest
Posts: n/a
 
      12-02-2005
Hi Scott,
Thanks for your quick response!

You could send a simplified source code for me so that I could debug this
issue on my side. I will be happy to be of further assistance. Thanks for
you understanding!

Best Regards,

Terry Fei[MSFT]
Microsoft Community Support
Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

 
Reply With Quote
 
ScottLR
Guest
Posts: n/a
 
      12-02-2005
Terry,

If the source were for an exe and not an nt service, would that be
sufficient?

--

Thank you,

Scott
Software995 Support

""TerryFei"" <(E-Mail Removed)> wrote in message
news:F8%(E-Mail Removed)...
> Hi Scott,
> Thanks for your quick response!
>
> You could send a simplified source code for me so that I could debug this
> issue on my side. I will be happy to be of further assistance. Thanks for
> you understanding!
>
> Best Regards,
>
> Terry Fei[MSFT]
> Microsoft Community Support
> Get Secure! www.microsoft.com/security
> (This posting is provided "AS IS", with no warranties, and confers no
> rights.)
>



 
Reply With Quote
 
TerryFei
Guest
Posts: n/a
 
      12-02-2005
Hi Scott,

Since the source as an application runs well, I hope you could provide me
source code as NT Service, which will reflect this issue directly and help
me get closer to resolving it. Thanks for your understanding!

Best Regards,

Terry Fei[MSFT]
Microsoft Community Support
Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Saving a page loaded using the webbrowser library? Dr. Benjamin David Clarke Python 1 03-25-2010 08:13 AM
Screen capture control using WebBrowser control and GDI+ in a web app JP2006 ASP .Net 1 01-07-2007 07:51 PM
How to disable Open/Save/Cancel dialog using WebBrowser amolk ASP .Net Web Controls 0 09-04-2006 02:13 PM
Type mismatch using Mozilla ActiveX in place of Microsoft WebBrowser? Noozer Firefox 0 05-19-2004 08:08 AM
ASPNET and Webbrowser control Daniel Frede ASP .Net 1 05-18-2004 01:50 AM



Advertisments