Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Controls > Button click event not firing on production IIS server?

Reply
Thread Tools

Button click event not firing on production IIS server?

 
 
JohnH.
Guest
Posts: n/a
 
      03-29-2005
I'm obviously not looking in the right place to find the source of
this problem. Anybody got any ideas where to look?

I have an ASP.NET c# application w/ several pages that have buttons.
On my development IIS server everything works fine. When I publish my
code to a pre-productions staging area everything works fine. When I
move the code to our productions environment the buttons click events
for the buttons on one page stop firing.

Facts:
(1) The buttons on all of the other pages work fine in production.
(2) I have cycled this code from development to staging to production
several times and the buttons on this problem page have always worked
fine in the past.
(3) All of the buttons on this page have stopped firing.
(4) My Page directive has these settings:
AutoEventWireup="False"
smartNavigation="False"
enableViewState="True"
(5) I am attaching the event handlers as delegates. I've traced
through the code on the production server and the event handler
delegate functions are getting attached to the buttons they are just
not firing.
(6) The development and production servers are both Windows 2003
Servers w/ all of the latest patches, and .Net Framework v1.1 w/ SP1.
(7) I did make changes to the problem page, but nothing (famous last
words) that should effect the buttons.

I've searched MSDN, Technet, Google, and news groups. I'm pulling
my hair out. Anybody got any ideas?

Thanks,
John

 
Reply With Quote
 
 
 
 
Ken Cox [Microsoft MVP]
Guest
Posts: n/a
 
      03-30-2005
Hi John,

I guess you've tried this since you have SP1, but I thought I'd mention it:

BUG: The Submit button on ASP.NET pages does not work after you install the
..NET Framework 1.1 Service Pack 1

http://support.microsoft.com/default...b;en-us;889877


"JohnH." <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) oups.com...
> I'm obviously not looking in the right place to find the source of
> this problem. Anybody got any ideas where to look?
>
> I have an ASP.NET c# application w/ several pages that have buttons.
> On my development IIS server everything works fine. When I publish my
> code to a pre-productions staging area everything works fine. When I
> move the code to our productions environment the buttons click events
> for the buttons on one page stop firing.
>
> Facts:
> (1) The buttons on all of the other pages work fine in production.
> (2) I have cycled this code from development to staging to production
> several times and the buttons on this problem page have always worked
> fine in the past.
> (3) All of the buttons on this page have stopped firing.
> (4) My Page directive has these settings:
> AutoEventWireup="False"
> smartNavigation="False"
> enableViewState="True"
> (5) I am attaching the event handlers as delegates. I've traced
> through the code on the production server and the event handler
> delegate functions are getting attached to the buttons they are just
> not firing.
> (6) The development and production servers are both Windows 2003
> Servers w/ all of the latest patches, and .Net Framework v1.1 w/ SP1.
> (7) I did make changes to the problem page, but nothing (famous last
> words) that should effect the buttons.
>
> I've searched MSDN, Technet, Google, and news groups. I'm pulling
> my hair out. Anybody got any ideas?
>
> Thanks,
> John
>


 
Reply With Quote
 
 
 
 
JohnH.
Guest
Posts: n/a
 
      03-30-2005
Ken,

You are the man!!! That fixed it. I'm little puzzled because the
symptoms did not exactly match the knowledge base article. But, I went
ahead and ran aspnet_regiis.exe and the buttons started firing. Thanks
for responding to my post.

John

 
Reply With Quote
 
Ken Cox [Microsoft MVP]
Guest
Posts: n/a
 
      03-30-2005
Hey John,

Glad you got going again!

"JohnH." <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) ups.com...
> Ken,
>
> You are the man!!! That fixed it. I'm little puzzled because the
> symptoms did not exactly match the knowledge base article. But, I went
> ahead and ran aspnet_regiis.exe and the buttons started firing. Thanks
> for responding to my post.
>
> John
>


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
image button click event fires before click event of button Purvi T ASP .Net 0 10-19-2004 06:19 AM
Button.Init? how Do I know if click event has been fired? TextBox.TextChanged event before Button.Click in a CompositeCustomControl. jorge ASP .Net Building Controls 1 05-28-2004 06:23 AM
Button.Init? how Do I know if click event has been fired? TextBox.TextChanged event before Button.Click in a CompositeCustomControl. jorge ASP .Net 2 05-25-2004 11:45 PM
Button.Init? how Do I know if click event has been fired? TextBox.TextChanged event before Button.Click in a CompositeCustomControl. jorge ASP .Net Datagrid Control 0 05-25-2004 01:45 AM
Button.Init? how Do I know if click event has been fired? TextBox.TextChanged event before Button.Click in a CompositeCustomControl. jorge ASP .Net Web Controls 0 05-25-2004 01:45 AM



Advertisments