Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Controls > Validation Controls Have Stopped working

Reply
Thread Tools

Validation Controls Have Stopped working

 
 
Jay
Guest
Posts: n/a
 
      02-19-2005
Something happened on the server that has caused my validation controls to
stop working. In fact, a page that contained the validation controls
doesn't even do a postback.

My asp.net works fine on my laptop, but stopped working on the server.
After several hours I finally figured that the problem is with the
validation controls.

What needs to be installed on the server for the validation controls to
work. I suspect that has been clobbered somehow.

Thanks for your help.
Jay


 
Reply With Quote
 
 
 
 
Alvin Bruney [MVP]
Guest
Posts: n/a
 
      02-19-2005
couple things you can check is the validation folder validation.js should be
available. the file path for this folder should be correctly mapped in the
config file. Make sure these are correct

--
Regards,
Alvin Bruney [Microsoft MVP ASP.NET]

[Shameless Author plug]
The Microsoft Office Web Components Black Book with .NET
Now Available @ http://www.lulu.com/owc
----------------------------------------------------------


"Jay" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Something happened on the server that has caused my validation controls to
> stop working. In fact, a page that contained the validation controls
> doesn't even do a postback.
>
> My asp.net works fine on my laptop, but stopped working on the server.
> After several hours I finally figured that the problem is with the
> validation controls.
>
> What needs to be installed on the server for the validation controls to
> work. I suspect that has been clobbered somehow.
>
> Thanks for your help.
> Jay
>



 
Reply With Quote
 
 
 
 
Steven Cheng[MSFT]
Guest
Posts: n/a
 
      02-21-2005
Thanks for Alvin's suggestion.

Hi Jay,

I think you can have a check in the "aspnet_client" folder under your
server's IIS site's root directory. The asp.net's validation controls's
clientside validation reply on those global script files installed in that
folder, if you have enabled clientside validation, and those files are not
correctly installed, there may cause some problems at clientside. Also, we
can use the

aspnet_regiis -c

command to install those ASP.NET globa. client script files:

#ASP.NET IIS Registration Tool (Aspnet_regiis.exe)
http://msdn.microsoft.com/library/de...us/cptools/htm
l/cpgrfaspnetiisregistrationtoolaspnet_regiisexe.asp

Thanks & Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

 
Reply With Quote
 
Jay
Guest
Posts: n/a
 
      02-21-2005
Thanks for your responses.

Is there some reason why this problem is intermittent. There is something
going on on my server that causes aspnet_client to not be accessed only some
of the time. I have developed many asp.net apps with no problems and I have
used validation. This is the first time I have used the summary validation
control.

Thanks for you help.
Jay


"Jay" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Something happened on the server that has caused my validation controls to
> stop working. In fact, a page that contained the validation controls
> doesn't even do a postback.
>
> My asp.net works fine on my laptop, but stopped working on the server.
> After several hours I finally figured that the problem is with the
> validation controls.
>
> What needs to be installed on the server for the validation controls to
> work. I suspect that has been clobbered somehow.
>
> Thanks for your help.
> Jay
>



 
Reply With Quote
 
Jay
Guest
Posts: n/a
 
      02-21-2005
One more piece of information. I have determined that the website in
question works on my development laptop and on the server when I access the
server from home using VPN. However, the website does not work when I am at
work. But it did work at work until recently. At work, I connect to the
internet using a proxy server.

Any thoughts?
Jay


"Jay" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Something happened on the server that has caused my validation controls to
> stop working. In fact, a page that contained the validation controls
> doesn't even do a postback.
>
> My asp.net works fine on my laptop, but stopped working on the server.
> After several hours I finally figured that the problem is with the
> validation controls.
>
> What needs to be installed on the server for the validation controls to
> work. I suspect that has been clobbered somehow.
>
> Thanks for your help.
> Jay
>



 
Reply With Quote
 
Steven Cheng[MSFT]
Guest
Posts: n/a
 
      02-22-2005
Thanks for your followup Jay,

Not sure whether your server has ever installed any framework update(sp) or
done any setting changes in IIS. based on my experience, since the when
..net framework has been updated after installed some patch, the version of
the global clientscripts will also change. For example, you can find multi
sub folders under
{IIS site root}\aspnet_client\system_web , each of them is specific to a
certain sub version of the asp.net. So if the version is mismatch( your
page's and the files in the aspnet_client), there may occur such
unexpected errors.

Thanks & Regards,

Steven Cheng
Microsoft Online Support

Get Secure! www.microsoft.com/security
(This posting is provided "AS IS", with no warranties, and confers no
rights.)

 
Reply With Quote
 
Teemu Keiski
Guest
Posts: n/a
 
      02-22-2005
Hi,

check this out:

BUG: The Submit button on ASP.NET pages does not work after you install the
..NET Framework 1.1 Service Pack 1
http://support.microsoft.com/default...b;en-us;889877

The problem relies on how onsubmit is rendered out on HtmlForm after the
update.It outputs something like onsubmit="if(!ValidatorOnSubmit) return
false;" after the update and the problem being that ValidatorOnSubmit method
calls ValidatorCommonOnSubmit which might have got out of synch and doesn't
return a value (you can check this method from ASp.NET's WebUIValidation.js
file). Therefore the condition in onsubmit always evaluates such that
onsubmit will cancel the postback.

It is explained here in more detail
http://scottonwriting.net/sowBlog/posts/2943.aspx

--
Teemu Keiski
ASP.NET MVP, Finland



"Jay" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Something happened on the server that has caused my validation controls to
> stop working. In fact, a page that contained the validation controls
> doesn't even do a postback.
>
> My asp.net works fine on my laptop, but stopped working on the server.
> After several hours I finally figured that the problem is with the
> validation controls.
>
> What needs to be installed on the server for the validation controls to
> work. I suspect that has been clobbered somehow.
>
> Thanks for your help.
> Jay
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
All USB Ports have Selectively Stopped Working Pirate727 Computer Support 3 11-20-2006 03:21 PM
Client side validation stopped working! mohaaron@gmail.com ASP .Net 0 05-31-2006 11:15 PM
Validation Controls Stopped Working on the server, but work on the local machine Just D. ASP .Net 3 03-04-2006 06:09 AM
Why has my validation stopped working? [1/1] Alan Silver ASP .Net 4 01-31-2005 03:52 PM
Client side validation stopped working =?Utf-8?B?dnphZmZpcm8=?= ASP .Net 4 11-24-2004 10:24 PM



Advertisments