Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Controls > User controls problem.

Reply
Thread Tools

User controls problem.

 
 
Josema
Guest
Posts: n/a
 
      01-18-2005
Hi,

Im starting to do the navigation of a portal, and for it, im using
usercontrols....

Actually i have a user control in the top of the page that has some menus
(contact, register, etc...)

Depending of the menu that the user will clik i make a LoadControl to the
specific user control. i start to see some problems following this way...

If the control to load doesnt have any controls that makes post-back (a
button, or any control with autopostback=true) it works, cause when i make
click in a menu, i show the user control, and that's all.

But if the user control for instance its a form to register a user here
comes the problem, cause when i click the button the control is loaded, but
if i fill the form to register, and click in the button of this form, this
user control dissapear...

I know the reason cause i make the LoadControl in the Onlclick Method of the
menu, and if i click in in the button that is in the user control of the
register this control its not loaded cause the program dont go throught the
Onclick Method of the menu...

How could i solve it?

I Hope explain my self correctly...
--
Thanks
Regards.
Josema

 
Reply With Quote
 
 
 
 
Michael Tkachev
Guest
Posts: n/a
 
      01-18-2005
Send me plz your usercontrol. I'll look at...
http://www.velocityreviews.com/forums/(E-Mail Removed).

"Josema" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Hi,
>
> Im starting to do the navigation of a portal, and for it, im using
> usercontrols....
>
> Actually i have a user control in the top of the page that has some menus
> (contact, register, etc...)
>
> Depending of the menu that the user will clik i make a LoadControl to the
> specific user control. i start to see some problems following this way...
>
> If the control to load doesnt have any controls that makes post-back (a
> button, or any control with autopostback=true) it works, cause when i make
> click in a menu, i show the user control, and that's all.
>
> But if the user control for instance its a form to register a user here
> comes the problem, cause when i click the button the control is loaded,

but
> if i fill the form to register, and click in the button of this form, this
> user control dissapear...
>
> I know the reason cause i make the LoadControl in the Onlclick Method of

the
> menu, and if i click in in the button that is in the user control of the
> register this control its not loaded cause the program dont go throught

the
> Onclick Method of the menu...
>
> How could i solve it?
>
> I Hope explain my self correctly...
> --
> Thanks
> Regards.
> Josema
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Controls.Count, Controls.IsSynchronized, and Controls.SyncRoot Nathan Sokalski ASP .Net 4 09-05-2007 03:27 AM
using javascript in User controls to access server controls of the user control Faizan Ahmed ASP .Net Building Controls 1 01-04-2005 04:09 PM
using javascript in User controls to access server controls of the user control Faizan Ahmed ASP .Net Web Controls 1 01-04-2005 04:09 PM
IntelliSense on Web User Controls and Web Custom Controls Axel Dahmen ASP .Net 1 11-12-2003 06:12 AM
HTML Controls and User controls trinitypete ASP .Net 6 06-26-2003 09:47 AM



Advertisments