Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Controls > SendUsing

Reply
Thread Tools

SendUsing

 
 
Thom Little
Guest
Posts: n/a
 
      10-09-2004
I am using SmtpMail.Send( ) to send a message.

When this application is run from localhost it executes and the message is
delivered correctly.

When the same code is executed from a remote host it throws an exception ...

[COMException (0x80040220): The "SendUsing" configuration value is invalid.]



What is the correction for this problem?

--
-- Thom Little -- www.tlaNET.net -- Thom Little Associates, Ltd.
--



 
Reply With Quote
 
 
 
 
Ken Cox [Microsoft MVP]
Guest
Posts: n/a
 
      10-13-2004
Although the error message doesn't reflect the problem, the symptoms sound
like permissions. When run from the localhost, the security permissions are
being passed through but when run remotely, they aren't. If that's the case,
finding out who the ASP.NET user is at the time and who it needs to be would
be the next step.

"Thom Little" <(E-Mail Removed)> wrote in message
news:%(E-Mail Removed)...
>I am using SmtpMail.Send( ) to send a message.
>
> When this application is run from localhost it executes and the message is
> delivered correctly.
>
> When the same code is executed from a remote host it throws an exception
> ...
>
> [COMException (0x80040220): The "SendUsing" configuration value is
> invalid.]
>
>
>
> What is the correction for this problem?
>
> --
> -- Thom Little -- www.tlaNET.net -- Thom Little Associates, Ltd.
> --
>
>
>


 
Reply With Quote
 
 
 
 
Thom Little
Guest
Posts: n/a
 
      10-13-2004
Thanks.

The problem was that the administrator for the server changed the property
that set the IP address of the SMTP server. Unfortunately he does not know
where it is set or how to reset it.

When I specify
SmtpMail.SmtpServer = "111.222.333.444" ;

Where 111.222.333.444 is the IP that worked before the change then it works
properly.

If you have any idea how to set the property back to its original value I
will pass the information on to him so I can start using the default setting
again.

--
-- Thom Little -- www.tlaNET.net -- Thom Little Associates, Ltd.
--

"Ken Cox [Microsoft MVP]" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
> Although the error message doesn't reflect the problem, the symptoms sound
> like permissions. When run from the localhost, the security permissions
> are being passed through but when run remotely, they aren't. If that's the
> case, finding out who the ASP.NET user is at the time and who it needs to
> be would be the next step.
>
> "Thom Little" <(E-Mail Removed)> wrote in message
> news:%(E-Mail Removed)...
>>I am using SmtpMail.Send( ) to send a message.
>>
>> When this application is run from localhost it executes and the message
>> is delivered correctly.
>>
>> When the same code is executed from a remote host it throws an exception
>> ...
>>
>> [COMException (0x80040220): The "SendUsing" configuration value is
>> invalid.]
>>
>>
>>
>> What is the correction for this problem?
>>
>> --
>> -- Thom Little -- www.tlaNET.net -- Thom Little Associates, Ltd.
>> --
>>
>>
>>

>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"SendUsing" configuration value is invalid. samarthkumar84@gmail.com ASP .Net 1 04-18-2007 02:24 PM
The "SendUsing" configuration value is invalid / HttpException (0x80004005): Could not access 'CDO.Message' object lds ASP .Net 5 11-04-2005 08:38 PM
SendUsing configuration value is invalid =?Utf-8?B?Zm1AbmV3c2dyb3Vwcy5ub3NwYW0=?= ASP .Net 5 10-21-2004 12:52 AM
Error -The "SendUsing" configuration value is invalid. Only on ASP Not VB on Server Elie ASP .Net 1 10-19-2004 09:46 AM
Problem sending mail on Server 2003 "SendUsing" configuration is invalid Brent ASP .Net 2 08-12-2003 05:02 PM



Advertisments