Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Controls > Validation Summary Control not displaying MessageBox

Reply
Thread Tools

Validation Summary Control not displaying MessageBox

 
 
Chris Lane
Guest
Posts: n/a
 
      11-23-2003
Hi,

I have the following in my .aspx page:
<asp:validationsummary id=VSAddStores style="Z-INDEX: 141;
LEFT: 721px; POSITION: absolute; TOP: 314px"
runat="server" Width="370px" Height="126px"
BackColor="Gainsboro" ShowMessageBox="True"
ShowSummary="False" HeaderText="The Following errors
occurred:"></asp:validationsummary>

I also have a RequiredFieldValidator connnected to a Text
Box.

When I submit the form with no value in the TextBox I
expected to see a messagebox client side using the VS
control, however I do not.

I also noticed that the EnableClientScript Property does
not seem to stay when I set it.

Is this some kind of bug?

I am using VS.NET 2002.

Thanks
 
Reply With Quote
 
 
 
 
Alvin Bruney
Guest
Posts: n/a
 
      11-23-2003
validation controls rely on a clientvalidation script which must be located
in the root web folder. The script is located in the aspnet_client folder.
Make sure that this is there. Or where ever it is located, the path in the
clientvalidation node in the machine config file must point to it.
Due to certain browser settings, the error message may not appear when the
file is not found. In that case, validation simply fails silently.

Regards

--


-----------
Got TidBits?
Get it here: www.networkip.net/tidbits
"Chris Lane" <(E-Mail Removed)> wrote in message
news:01a001c3b209$84a0b400$(E-Mail Removed)...
> Hi,
>
> I have the following in my .aspx page:
> <asp:validationsummary id=VSAddStores style="Z-INDEX: 141;
> LEFT: 721px; POSITION: absolute; TOP: 314px"
> runat="server" Width="370px" Height="126px"
> BackColor="Gainsboro" ShowMessageBox="True"
> ShowSummary="False" HeaderText="The Following errors
> occurred:"></asp:validationsummary>
>
> I also have a RequiredFieldValidator connnected to a Text
> Box.
>
> When I submit the form with no value in the TextBox I
> expected to see a messagebox client side using the VS
> control, however I do not.
>
> I also noticed that the EnableClientScript Property does
> not seem to stay when I set it.
>
> Is this some kind of bug?
>
> I am using VS.NET 2002.
>
> Thanks



 
Reply With Quote
 
 
 
 
Chris Lane
Guest
Posts: n/a
 
      11-23-2003
>-----Original Message-----
>validation controls rely on a clientvalidation script

which must be located
>in the root web folder. The script is located in the

aspnet_client folder.
OK I checked and it's there.
>Make sure that this is there. Or where ever it is

located, the path in the
>clientvalidation node in the machine config file must

point to it.

So Just the machine config file not the web config?

>Due to certain browser settings, the error message may

not appear when the
>file is not found. In that case, validation simply fails

silently.
>
>Regards
>
>--
>
>
>-----------
>Got TidBits?
>Get it here: www.networkip.net/tidbits
>"Chris Lane" <(E-Mail Removed)> wrote in message
>news:01a001c3b209$84a0b400$(E-Mail Removed)...
>> Hi,
>>
>> I have the following in my .aspx page:
>> <asp:validationsummary id=VSAddStores style="Z-INDEX:

141;
>> LEFT: 721px; POSITION: absolute; TOP: 314px"
>> runat="server" Width="370px" Height="126px"
>> BackColor="Gainsboro" ShowMessageBox="True"
>> ShowSummary="False" HeaderText="The Following errors
>> occurred:"></asp:validationsummary>
>>
>> I also have a RequiredFieldValidator connnected to a

Text
>> Box.
>>
>> When I submit the form with no value in the TextBox I
>> expected to see a messagebox client side using the VS
>> control, however I do not.
>>
>> I also noticed that the EnableClientScript Property does
>> not seem to stay when I set it.
>>
>> Is this some kind of bug?
>>
>> I am using VS.NET 2002.
>>
>> Thanks

>
>
>.
>

 
Reply With Quote
 
Chris Lane
Guest
Posts: n/a
 
      11-23-2003
Hmm,I don't see a clientvalidation node in the
machine.config file.
>-----Original Message-----
>validation controls rely on a clientvalidation script

which must be located
>in the root web folder. The script is located in the

aspnet_client folder.
>Make sure that this is there. Or where ever it is

located, the path in the
>clientvalidation node in the machine config file must

point to it.
>Due to certain browser settings, the error message may

not appear when the
>file is not found. In that case, validation simply fails

silently.
>
>Regards
>
>--
>
>
>-----------
>Got TidBits?
>Get it here: www.networkip.net/tidbits
>"Chris Lane" <(E-Mail Removed)> wrote in message
>news:01a001c3b209$84a0b400$(E-Mail Removed)...
>> Hi,
>>
>> I have the following in my .aspx page:
>> <asp:validationsummary id=VSAddStores style="Z-INDEX:

141;
>> LEFT: 721px; POSITION: absolute; TOP: 314px"
>> runat="server" Width="370px" Height="126px"
>> BackColor="Gainsboro" ShowMessageBox="True"
>> ShowSummary="False" HeaderText="The Following errors
>> occurred:"></asp:validationsummary>
>>
>> I also have a RequiredFieldValidator connnected to a

Text
>> Box.
>>
>> When I submit the form with no value in the TextBox I
>> expected to see a messagebox client side using the VS
>> control, however I do not.
>>
>> I also noticed that the EnableClientScript Property does
>> not seem to stay when I set it.
>>
>> Is this some kind of bug?
>>
>> I am using VS.NET 2002.
>>
>> Thanks

>
>
>.
>

 
Reply With Quote
 
Alvin Bruney
Guest
Posts: n/a
 
      11-24-2003
Sorry
the node you need to look for is <webControls> it is part of the
<processModel> tree in the machine config file. It will contain a path
similar to
<webControls clientScriptsLocation="/aspnet_client/{0}/{1}/" />

When validation is required, the path pointed to by the
clientscriptslocation attribute is used to find the webuivalidation.js file
which handles validation. Most often the path pointed to isn't where the
aspnet_client file resides and validation fails.

I should have verified all this before posting incorrect information.

Regards

--


-----------
Got TidBits?
Get it here: www.networkip.net/tidbits
"Chris Lane" <(E-Mail Removed)> wrote in message
news:480301c3b21b$c9b77350$(E-Mail Removed)...
> Hmm,I don't see a clientvalidation node in the
> machine.config file.
> >-----Original Message-----
> >validation controls rely on a clientvalidation script

> which must be located
> >in the root web folder. The script is located in the

> aspnet_client folder.
> >Make sure that this is there. Or where ever it is

> located, the path in the
> >clientvalidation node in the machine config file must

> point to it.
> >Due to certain browser settings, the error message may

> not appear when the
> >file is not found. In that case, validation simply fails

> silently.
> >
> >Regards
> >
> >--
> >
> >
> >-----------
> >Got TidBits?
> >Get it here: www.networkip.net/tidbits
> >"Chris Lane" <(E-Mail Removed)> wrote in message
> >news:01a001c3b209$84a0b400$(E-Mail Removed)...
> >> Hi,
> >>
> >> I have the following in my .aspx page:
> >> <asp:validationsummary id=VSAddStores style="Z-INDEX:

> 141;
> >> LEFT: 721px; POSITION: absolute; TOP: 314px"
> >> runat="server" Width="370px" Height="126px"
> >> BackColor="Gainsboro" ShowMessageBox="True"
> >> ShowSummary="False" HeaderText="The Following errors
> >> occurred:"></asp:validationsummary>
> >>
> >> I also have a RequiredFieldValidator connnected to a

> Text
> >> Box.
> >>
> >> When I submit the form with no value in the TextBox I
> >> expected to see a messagebox client side using the VS
> >> control, however I do not.
> >>
> >> I also noticed that the EnableClientScript Property does
> >> not seem to stay when I set it.
> >>
> >> Is this some kind of bug?
> >>
> >> I am using VS.NET 2002.
> >>
> >> Thanks

> >
> >
> >.
> >



 
Reply With Quote
 
Chris Lane
Guest
Posts: n/a
 
      11-24-2003
Ok I do see this in the machine.config file:
<webControls clientScriptsLocation="/aspnet_client/{0}/
{1}/"/>
BTW-Validation is occuring because I do see the summary
list,and if I make the RFV visible I see that too when an
error occurs, I just don't see the message box.

>-----Original Message-----
>Sorry
>the node you need to look for is <webControls> it is part

of the
><processModel> tree in the machine config file. It will

contain a path
>similar to
><webControls clientScriptsLocation="/aspnet_client/{0}/

{1}/" />
>
>When validation is required, the path pointed to by the
>clientscriptslocation attribute is used to find the

webuivalidation.js file
>which handles validation. Most often the path pointed to

isn't where the
>aspnet_client file resides and validation fails.
>
>I should have verified all this before posting incorrect

information.
>
>Regards
>
>--
>
>
>-----------
>Got TidBits?
>Get it here: www.networkip.net/tidbits
>"Chris Lane" <(E-Mail Removed)> wrote in message
>news:480301c3b21b$c9b77350$(E-Mail Removed)...
>> Hmm,I don't see a clientvalidation node in the
>> machine.config file.
>> >-----Original Message-----
>> >validation controls rely on a clientvalidation script

>> which must be located
>> >in the root web folder. The script is located in the

>> aspnet_client folder.
>> >Make sure that this is there. Or where ever it is

>> located, the path in the
>> >clientvalidation node in the machine config file must

>> point to it.
>> >Due to certain browser settings, the error message may

>> not appear when the
>> >file is not found. In that case, validation simply

fails
>> silently.
>> >
>> >Regards
>> >
>> >--
>> >
>> >
>> >-----------
>> >Got TidBits?
>> >Get it here: www.networkip.net/tidbits
>> >"Chris Lane" <(E-Mail Removed)> wrote in message
>> >news:01a001c3b209$84a0b400$(E-Mail Removed)...
>> >> Hi,
>> >>
>> >> I have the following in my .aspx page:
>> >> <asp:validationsummary id=VSAddStores style="Z-INDEX:

>> 141;
>> >> LEFT: 721px; POSITION: absolute; TOP: 314px"
>> >> runat="server" Width="370px" Height="126px"
>> >> BackColor="Gainsboro" ShowMessageBox="True"
>> >> ShowSummary="False" HeaderText="The Following errors
>> >> occurred:"></asp:validationsummary>
>> >>
>> >> I also have a RequiredFieldValidator connnected to a

>> Text
>> >> Box.
>> >>
>> >> When I submit the form with no value in the TextBox I
>> >> expected to see a messagebox client side using the VS
>> >> control, however I do not.
>> >>
>> >> I also noticed that the EnableClientScript Property

does
>> >> not seem to stay when I set it.
>> >>
>> >> Is this some kind of bug?
>> >>
>> >> I am using VS.NET 2002.
>> >>
>> >> Thanks
>> >
>> >
>> >.
>> >

>
>
>.
>

 
Reply With Quote
 
Alvin Bruney
Guest
Posts: n/a
 
      11-24-2003
ok, do you have ShowMessageBox set to true?

--


-----------
Got TidBits?
Get it here: www.networkip.net/tidbits
"Chris Lane" <(E-Mail Removed)> wrote in message
news:02f101c3b227$eadc4a40$(E-Mail Removed)...
> Ok I do see this in the machine.config file:
> <webControls clientScriptsLocation="/aspnet_client/{0}/
> {1}/"/>
> BTW-Validation is occuring because I do see the summary
> list,and if I make the RFV visible I see that too when an
> error occurs, I just don't see the message box.
>
> >-----Original Message-----
> >Sorry
> >the node you need to look for is <webControls> it is part

> of the
> ><processModel> tree in the machine config file. It will

> contain a path
> >similar to
> ><webControls clientScriptsLocation="/aspnet_client/{0}/

> {1}/" />
> >
> >When validation is required, the path pointed to by the
> >clientscriptslocation attribute is used to find the

> webuivalidation.js file
> >which handles validation. Most often the path pointed to

> isn't where the
> >aspnet_client file resides and validation fails.
> >
> >I should have verified all this before posting incorrect

> information.
> >
> >Regards
> >
> >--
> >
> >
> >-----------
> >Got TidBits?
> >Get it here: www.networkip.net/tidbits
> >"Chris Lane" <(E-Mail Removed)> wrote in message
> >news:480301c3b21b$c9b77350$(E-Mail Removed)...
> >> Hmm,I don't see a clientvalidation node in the
> >> machine.config file.
> >> >-----Original Message-----
> >> >validation controls rely on a clientvalidation script
> >> which must be located
> >> >in the root web folder. The script is located in the
> >> aspnet_client folder.
> >> >Make sure that this is there. Or where ever it is
> >> located, the path in the
> >> >clientvalidation node in the machine config file must
> >> point to it.
> >> >Due to certain browser settings, the error message may
> >> not appear when the
> >> >file is not found. In that case, validation simply

> fails
> >> silently.
> >> >
> >> >Regards
> >> >
> >> >--
> >> >
> >> >
> >> >-----------
> >> >Got TidBits?
> >> >Get it here: www.networkip.net/tidbits
> >> >"Chris Lane" <(E-Mail Removed)> wrote in message
> >> >news:01a001c3b209$84a0b400$(E-Mail Removed)...
> >> >> Hi,
> >> >>
> >> >> I have the following in my .aspx page:
> >> >> <asp:validationsummary id=VSAddStores style="Z-INDEX:
> >> 141;
> >> >> LEFT: 721px; POSITION: absolute; TOP: 314px"
> >> >> runat="server" Width="370px" Height="126px"
> >> >> BackColor="Gainsboro" ShowMessageBox="True"
> >> >> ShowSummary="False" HeaderText="The Following errors
> >> >> occurred:"></asp:validationsummary>
> >> >>
> >> >> I also have a RequiredFieldValidator connnected to a
> >> Text
> >> >> Box.
> >> >>
> >> >> When I submit the form with no value in the TextBox I
> >> >> expected to see a messagebox client side using the VS
> >> >> control, however I do not.
> >> >>
> >> >> I also noticed that the EnableClientScript Property

> does
> >> >> not seem to stay when I set it.
> >> >>
> >> >> Is this some kind of bug?
> >> >>
> >> >> I am using VS.NET 2002.
> >> >>
> >> >> Thanks
> >> >
> >> >
> >> >.
> >> >

> >
> >
> >.
> >



 
Reply With Quote
 
Chris Lane
Guest
Posts: n/a
 
      11-24-2003
Yep ShowMessageBox is set to true and I am using IE 6.0 to
test.

>-----Original Message-----
>ok, do you have ShowMessageBox set to true?
>
>--
>
>
>-----------
>Got TidBits?
>Get it here: www.networkip.net/tidbits
>"Chris Lane" <(E-Mail Removed)> wrote in message
>news:02f101c3b227$eadc4a40$(E-Mail Removed)...
>> Ok I do see this in the machine.config file:
>> <webControls clientScriptsLocation="/aspnet_client/{0}/
>> {1}/"/>
>> BTW-Validation is occuring because I do see the summary
>> list,and if I make the RFV visible I see that too when

an
>> error occurs, I just don't see the message box.
>>
>> >-----Original Message-----
>> >Sorry
>> >the node you need to look for is <webControls> it is

part
>> of the
>> ><processModel> tree in the machine config file. It will

>> contain a path
>> >similar to
>> ><webControls clientScriptsLocation="/aspnet_client/

{0}/
>> {1}/" />
>> >
>> >When validation is required, the path pointed to by the
>> >clientscriptslocation attribute is used to find the

>> webuivalidation.js file
>> >which handles validation. Most often the path pointed

to
>> isn't where the
>> >aspnet_client file resides and validation fails.
>> >
>> >I should have verified all this before posting

incorrect
>> information.
>> >
>> >Regards
>> >
>> >--
>> >
>> >
>> >-----------
>> >Got TidBits?
>> >Get it here: www.networkip.net/tidbits
>> >"Chris Lane" <(E-Mail Removed)> wrote in message
>> >news:480301c3b21b$c9b77350$(E-Mail Removed)...
>> >> Hmm,I don't see a clientvalidation node in the
>> >> machine.config file.
>> >> >-----Original Message-----
>> >> >validation controls rely on a clientvalidation

script
>> >> which must be located
>> >> >in the root web folder. The script is located in the
>> >> aspnet_client folder.
>> >> >Make sure that this is there. Or where ever it is
>> >> located, the path in the
>> >> >clientvalidation node in the machine config file

must
>> >> point to it.
>> >> >Due to certain browser settings, the error message

may
>> >> not appear when the
>> >> >file is not found. In that case, validation simply

>> fails
>> >> silently.
>> >> >
>> >> >Regards
>> >> >
>> >> >--
>> >> >
>> >> >
>> >> >-----------
>> >> >Got TidBits?
>> >> >Get it here: www.networkip.net/tidbits
>> >> >"Chris Lane" <(E-Mail Removed)> wrote in

message
>> >> >news:01a001c3b209$84a0b400$(E-Mail Removed)...
>> >> >> Hi,
>> >> >>
>> >> >> I have the following in my .aspx page:
>> >> >> <asp:validationsummary id=VSAddStores style="Z-

INDEX:
>> >> 141;
>> >> >> LEFT: 721px; POSITION: absolute; TOP: 314px"
>> >> >> runat="server" Width="370px" Height="126px"
>> >> >> BackColor="Gainsboro" ShowMessageBox="True"
>> >> >> ShowSummary="False" HeaderText="The Following

errors
>> >> >> occurred:"></asp:validationsummary>
>> >> >>
>> >> >> I also have a RequiredFieldValidator connnected

to a
>> >> Text
>> >> >> Box.
>> >> >>
>> >> >> When I submit the form with no value in the

TextBox I
>> >> >> expected to see a messagebox client side using

the VS
>> >> >> control, however I do not.
>> >> >>
>> >> >> I also noticed that the EnableClientScript

Property
>> does
>> >> >> not seem to stay when I set it.
>> >> >>
>> >> >> Is this some kind of bug?
>> >> >>
>> >> >> I am using VS.NET 2002.
>> >> >>
>> >> >> Thanks
>> >> >
>> >> >
>> >> >.
>> >> >
>> >
>> >
>> >.
>> >

>
>
>.
>

 
Reply With Quote
 
Alvin Bruney
Guest
Posts: n/a
 
      11-24-2003
where is your aspnet_client folder located on your hard drive?

and

what is the home directory path mapped to? Find this out from properties of
the default web sites folder under IIS manager.

--


-----------
Got TidBits?
Get it here: www.networkip.net/tidbits
"Chris Lane" <(E-Mail Removed)> wrote in message
news:03b901c3b237$d4ecf3f0$(E-Mail Removed)...
> Yep ShowMessageBox is set to true and I am using IE 6.0 to
> test.
>
> >-----Original Message-----
> >ok, do you have ShowMessageBox set to true?
> >
> >--
> >
> >
> >-----------
> >Got TidBits?
> >Get it here: www.networkip.net/tidbits
> >"Chris Lane" <(E-Mail Removed)> wrote in message
> >news:02f101c3b227$eadc4a40$(E-Mail Removed)...
> >> Ok I do see this in the machine.config file:
> >> <webControls clientScriptsLocation="/aspnet_client/{0}/
> >> {1}/"/>
> >> BTW-Validation is occuring because I do see the summary
> >> list,and if I make the RFV visible I see that too when

> an
> >> error occurs, I just don't see the message box.
> >>
> >> >-----Original Message-----
> >> >Sorry
> >> >the node you need to look for is <webControls> it is

> part
> >> of the
> >> ><processModel> tree in the machine config file. It will
> >> contain a path
> >> >similar to
> >> ><webControls clientScriptsLocation="/aspnet_client/

> {0}/
> >> {1}/" />
> >> >
> >> >When validation is required, the path pointed to by the
> >> >clientscriptslocation attribute is used to find the
> >> webuivalidation.js file
> >> >which handles validation. Most often the path pointed

> to
> >> isn't where the
> >> >aspnet_client file resides and validation fails.
> >> >
> >> >I should have verified all this before posting

> incorrect
> >> information.
> >> >
> >> >Regards
> >> >
> >> >--
> >> >
> >> >
> >> >-----------
> >> >Got TidBits?
> >> >Get it here: www.networkip.net/tidbits
> >> >"Chris Lane" <(E-Mail Removed)> wrote in message
> >> >news:480301c3b21b$c9b77350$(E-Mail Removed)...
> >> >> Hmm,I don't see a clientvalidation node in the
> >> >> machine.config file.
> >> >> >-----Original Message-----
> >> >> >validation controls rely on a clientvalidation

> script
> >> >> which must be located
> >> >> >in the root web folder. The script is located in the
> >> >> aspnet_client folder.
> >> >> >Make sure that this is there. Or where ever it is
> >> >> located, the path in the
> >> >> >clientvalidation node in the machine config file

> must
> >> >> point to it.
> >> >> >Due to certain browser settings, the error message

> may
> >> >> not appear when the
> >> >> >file is not found. In that case, validation simply
> >> fails
> >> >> silently.
> >> >> >
> >> >> >Regards
> >> >> >
> >> >> >--
> >> >> >
> >> >> >
> >> >> >-----------
> >> >> >Got TidBits?
> >> >> >Get it here: www.networkip.net/tidbits
> >> >> >"Chris Lane" <(E-Mail Removed)> wrote in

> message
> >> >> >news:01a001c3b209$84a0b400$(E-Mail Removed)...
> >> >> >> Hi,
> >> >> >>
> >> >> >> I have the following in my .aspx page:
> >> >> >> <asp:validationsummary id=VSAddStores style="Z-

> INDEX:
> >> >> 141;
> >> >> >> LEFT: 721px; POSITION: absolute; TOP: 314px"
> >> >> >> runat="server" Width="370px" Height="126px"
> >> >> >> BackColor="Gainsboro" ShowMessageBox="True"
> >> >> >> ShowSummary="False" HeaderText="The Following

> errors
> >> >> >> occurred:"></asp:validationsummary>
> >> >> >>
> >> >> >> I also have a RequiredFieldValidator connnected

> to a
> >> >> Text
> >> >> >> Box.
> >> >> >>
> >> >> >> When I submit the form with no value in the

> TextBox I
> >> >> >> expected to see a messagebox client side using

> the VS
> >> >> >> control, however I do not.
> >> >> >>
> >> >> >> I also noticed that the EnableClientScript

> Property
> >> does
> >> >> >> not seem to stay when I set it.
> >> >> >>
> >> >> >> Is this some kind of bug?
> >> >> >>
> >> >> >> I am using VS.NET 2002.
> >> >> >>
> >> >> >> Thanks
> >> >> >
> >> >> >
> >> >> >.
> >> >> >
> >> >
> >> >
> >> >.
> >> >

> >
> >
> >.
> >



 
Reply With Quote
 
Chris Lane
Guest
Posts: n/a
 
      11-24-2003
It's on under INETPUB and it is in each web on my IIS
server. Each one is mapped correctly. This particular web
is C:\Inetpub\wwwroot
>-----Original Message-----
>where is your aspnet_client folder located on your hard

drive?
>
>and
>
>what is the home directory path mapped to? Find this out

from properties of
>the default web sites folder under IIS manager.
>
>--
>
>
>-----------
>Got TidBits?
>Get it here: www.networkip.net/tidbits
>"Chris Lane" <(E-Mail Removed)> wrote in message
>news:03b901c3b237$d4ecf3f0$(E-Mail Removed)...
>> Yep ShowMessageBox is set to true and I am using IE 6.0

to
>> test.
>>
>> >-----Original Message-----
>> >ok, do you have ShowMessageBox set to true?
>> >
>> >--
>> >
>> >
>> >-----------
>> >Got TidBits?
>> >Get it here: www.networkip.net/tidbits
>> >"Chris Lane" <(E-Mail Removed)> wrote in message
>> >news:02f101c3b227$eadc4a40$(E-Mail Removed)...
>> >> Ok I do see this in the machine.config file:
>> >> <webControls clientScriptsLocation="/aspnet_client/

{0}/
>> >> {1}/"/>
>> >> BTW-Validation is occuring because I do see the

summary
>> >> list,and if I make the RFV visible I see that too

when
>> an
>> >> error occurs, I just don't see the message box.
>> >>
>> >> >-----Original Message-----
>> >> >Sorry
>> >> >the node you need to look for is <webControls> it is

>> part
>> >> of the
>> >> ><processModel> tree in the machine config file. It

will
>> >> contain a path
>> >> >similar to
>> >> ><webControls clientScriptsLocation="/aspnet_client/

>> {0}/
>> >> {1}/" />
>> >> >
>> >> >When validation is required, the path pointed to by

the
>> >> >clientscriptslocation attribute is used to find the
>> >> webuivalidation.js file
>> >> >which handles validation. Most often the path

pointed
>> to
>> >> isn't where the
>> >> >aspnet_client file resides and validation fails.
>> >> >
>> >> >I should have verified all this before posting

>> incorrect
>> >> information.
>> >> >
>> >> >Regards
>> >> >
>> >> >--
>> >> >
>> >> >
>> >> >-----------
>> >> >Got TidBits?
>> >> >Get it here: www.networkip.net/tidbits
>> >> >"Chris Lane" <(E-Mail Removed)> wrote in

message
>> >> >news:480301c3b21b$c9b77350$(E-Mail Removed)...
>> >> >> Hmm,I don't see a clientvalidation node in the
>> >> >> machine.config file.
>> >> >> >-----Original Message-----
>> >> >> >validation controls rely on a clientvalidation

>> script
>> >> >> which must be located
>> >> >> >in the root web folder. The script is located in

the
>> >> >> aspnet_client folder.
>> >> >> >Make sure that this is there. Or where ever it is
>> >> >> located, the path in the
>> >> >> >clientvalidation node in the machine config file

>> must
>> >> >> point to it.
>> >> >> >Due to certain browser settings, the error

message
>> may
>> >> >> not appear when the
>> >> >> >file is not found. In that case, validation

simply
>> >> fails
>> >> >> silently.
>> >> >> >
>> >> >> >Regards
>> >> >> >
>> >> >> >--
>> >> >> >
>> >> >> >
>> >> >> >-----------
>> >> >> >Got TidBits?
>> >> >> >Get it here: www.networkip.net/tidbits
>> >> >> >"Chris Lane" <(E-Mail Removed)> wrote in

>> message
>> >> >> >news:01a001c3b209$84a0b400$(E-Mail Removed)...
>> >> >> >> Hi,
>> >> >> >>
>> >> >> >> I have the following in my .aspx page:
>> >> >> >> <asp:validationsummary id=VSAddStores style="Z-

>> INDEX:
>> >> >> 141;
>> >> >> >> LEFT: 721px; POSITION: absolute; TOP: 314px"
>> >> >> >> runat="server" Width="370px" Height="126px"
>> >> >> >> BackColor="Gainsboro" ShowMessageBox="True"
>> >> >> >> ShowSummary="False" HeaderText="The Following

>> errors
>> >> >> >> occurred:"></asp:validationsummary>
>> >> >> >>
>> >> >> >> I also have a RequiredFieldValidator connnected

>> to a
>> >> >> Text
>> >> >> >> Box.
>> >> >> >>
>> >> >> >> When I submit the form with no value in the

>> TextBox I
>> >> >> >> expected to see a messagebox client side using

>> the VS
>> >> >> >> control, however I do not.
>> >> >> >>
>> >> >> >> I also noticed that the EnableClientScript

>> Property
>> >> does
>> >> >> >> not seem to stay when I set it.
>> >> >> >>
>> >> >> >> Is this some kind of bug?
>> >> >> >>
>> >> >> >> I am using VS.NET 2002.
>> >> >> >>
>> >> >> >> Thanks
>> >> >> >
>> >> >> >
>> >> >> >.
>> >> >> >
>> >> >
>> >> >
>> >> >.
>> >> >
>> >
>> >
>> >.
>> >

>
>
>.
>

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Validation Summary not showing for client side validation cwhankey@gmail.com ASP .Net 1 12-12-2008 02:32 AM
Validation Summary Message Box Not Displaying =?Utf-8?B?TWlrZSBNb29yZQ==?= ASP .Net 4 12-09-2004 05:09 AM
Using Summary Validation control with server Custom validation =?Utf-8?B?QmFyYmFyYSBBbGRlcnRvbg==?= ASP .Net 2 10-15-2004 06:15 PM
Displaying a Validation Error in a Validation Summary Control Lucas Tam ASP .Net 2 02-26-2004 07:49 PM
Validation Summary MessageBox Problem Aaron Dunfield ASP .Net Building Controls 0 07-25-2003 08:00 PM



Advertisments