Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Controls > LoadControl don'i fire event

Reply
Thread Tools

LoadControl don'i fire event

 
 
Stefano Rossi
Guest
Posts: n/a
 
      11-18-2003
I need load a lot of usercontrol runtime in a WebForm.
The controls are displayed correctly, but the event
definited inside doesn't work.

For example when I click on a button in the usercontrol
the webform is posted and reloaded but the usercontrol
code is not execute.

Why??? Please help me

Bye

Sorry for my English!
 
Reply With Quote
 
 
 
 
Guest
Posts: n/a
 
      11-18-2003
COuld it be that your user control is not associated with
the right codebehind? Look at the:
<%@ Control... %>
directive at the top of your page.
Make sure that the Codebehind and Inherits attributes are
correct. (I had this problem when I copy and paste
controls...)

>-----Original Message-----
>I need load a lot of usercontrol runtime in a WebForm.
>The controls are displayed correctly, but the event
>definited inside doesn't work.
>
>For example when I click on a button in the usercontrol
>the webform is posted and reloaded but the usercontrol
>code is not execute.
>
>Why??? Please help me
>
>Bye
>
>Sorry for my English!
>.
>

 
Reply With Quote
 
 
 
 
Guest
Posts: n/a
 
      11-21-2003
The control is OK.

If I include the control in the webform directly the
usercontrol works properly (the events are fired), but if
the webform load runtime the usercontrol the events aren't
fired.


>-----Original Message-----
>COuld it be that your user control is not associated with
>the right codebehind? Look at the:
><%@ Control... %>
>directive at the top of your page.
>Make sure that the Codebehind and Inherits attributes are
>correct. (I had this problem when I copy and paste
>controls...)
>
>>-----Original Message-----
>>I need load a lot of usercontrol runtime in a WebForm.
>>The controls are displayed correctly, but the event
>>definited inside doesn't work.
>>
>>For example when I click on a button in the usercontrol
>>the webform is posted and reloaded but the usercontrol
>>code is not execute.
>>
>>Why??? Please help me
>>
>>Bye
>>
>>Sorry for my English!
>>.
>>

>.
>

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ImageButton event doesn't fire but Button event does suzanne.boyle@gmail.com ASP .Net 4 06-13-2007 09:19 PM
load event doesn't fire unless init event is present Andy Fish ASP .Net Web Controls 2 07-07-2005 06:16 PM
Fire server side event before client side event ASP .Net Web Controls 3 03-18-2005 03:20 PM
How does Page_Load fire when control loaded with LoadControl?? just_jt ASP .Net Web Controls 1 08-25-2004 09:21 PM
onmousedown event causing body onload event to fire Bender Javascript 2 10-22-2003 10:29 PM



Advertisments