Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Controls > Serious issues with webcontrols...

Reply
Thread Tools

Serious issues with webcontrols...

 
 
Nicolas LeBlanc
Guest
Posts: n/a
 
      10-26-2003
Hi,

First of all, sorry for cross-posting, but some groups look more active than
others, and I sure need to find an answer to this.

I recently rebuilt my website using ASP.NET and I did my forum system using
a datagrid and template columns. I was asked by many users to remove the
LinkButton in order to be able to "open in a new window", so instead I used
the hyperlink control to allow users to access the message page from the
topic list page.

But for some reason, and don't ask me why, some users don't see the
hyperlinks at ALL!

One user mailed me, and the HTML generated by IIS for him, the code:

<a id="dgList__ctl8_hlThreadName"

Is replaced by:

<!--d="dgList__ctl8_hlThreadName"

You see? HTML comment! I have no idea why it does that!!! And that is under
Windows 98 using IE (don't know which version, but he said "old")

Another use, I'm using HyperLink controls with an image, and they simply
don't see the image at all.. is there a problem with the HyperLink control?

This is not counting the multiple viewstate problem I'm having.. I love
programming in .NET, but there are serious issues when it comes to
multi-platform.. should I be surprised that the WIDTH/HEIGHT tags of an
imagebutton control are lost when a user uses Netscape?

If some people want to see them live to see what's wrong, then...

http://www.neworderonline.com/Thread...spx?ForumID=11

This is the technical support forum, most issues are posted there.. and I
receive all errors by email, so I can tell there are not many in the forum
system, I do however receive corrupted viewstate errors from time to time...


 
Reply With Quote
 
 
 
 
Mark Fitzpatrick
Guest
Posts: n/a
 
      10-26-2003
Try adjusting the target browser. You've got the browser schema set to IE 5
or above. Try setting it for a more neutral HTML 3.2 compliant browser.

Hope this helps,
Mark Fitzpatrick
Microsoft MVP - FrontPage

"Nicolas LeBlanc" <(E-Mail Removed)> wrote in message
news:eUtHtJ%(E-Mail Removed)...
> Hi,
>
> First of all, sorry for cross-posting, but some groups look more active

than
> others, and I sure need to find an answer to this.
>
> I recently rebuilt my website using ASP.NET and I did my forum system

using
> a datagrid and template columns. I was asked by many users to remove the
> LinkButton in order to be able to "open in a new window", so instead I

used
> the hyperlink control to allow users to access the message page from the
> topic list page.
>
> But for some reason, and don't ask me why, some users don't see the
> hyperlinks at ALL!
>
> One user mailed me, and the HTML generated by IIS for him, the code:
>
> <a id="dgList__ctl8_hlThreadName"
>
> Is replaced by:
>
> <!--d="dgList__ctl8_hlThreadName"
>
> You see? HTML comment! I have no idea why it does that!!! And that is

under
> Windows 98 using IE (don't know which version, but he said "old")
>
> Another use, I'm using HyperLink controls with an image, and they simply
> don't see the image at all.. is there a problem with the HyperLink

control?
>
> This is not counting the multiple viewstate problem I'm having.. I love
> programming in .NET, but there are serious issues when it comes to
> multi-platform.. should I be surprised that the WIDTH/HEIGHT tags of an
> imagebutton control are lost when a user uses Netscape?
>
> If some people want to see them live to see what's wrong, then...
>
> http://www.neworderonline.com/Thread...spx?ForumID=11
>
> This is the technical support forum, most issues are posted there.. and I
> receive all errors by email, so I can tell there are not many in the forum
> system, I do however receive corrupted viewstate errors from time to

time...
>
>



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Serious Cisco issues Dan Cisco 2 08-21-2004 03:42 AM
SNMP Issues in Cisco Routers; Vulnerability Issues in TCP =?iso-8859-1?Q?Frisbee=AE?= MCSE 0 04-21-2004 03:00 PM
Re: a serious question for a non-serious cause... henry DVD Video 1 11-08-2003 04:38 PM
Serious issues with webcontrols... Nicolas LeBlanc ASP .Net 1 10-26-2003 06:00 PM
Serious issues with webcontrols... Nicolas LeBlanc ASP .Net Datagrid Control 1 10-26-2003 06:00 PM



Advertisments