Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Web Controls > TreeView: Checkbox data not appearing in Request / POST data

Reply
Thread Tools

TreeView: Checkbox data not appearing in Request / POST data

 
 
Kris Oye
Guest
Posts: n/a
 
      07-25-2003
I am creating a TreeView programatically in C# and then using the
RenderControl() method to send it back to the browser. I am attempting to
use the resulting checkboxes in an existing form, but when the data is
submitted back to the server for processing, none of the checkbox data
appears in my Request. Anyone know why this might happen? I've tried it a
number of ways to get it working but with no success. The tree renders
correctly and each checkbox has the correct ID and Name, but no go. Any
help would be greatly appreciated:

Brief code fragment:

<form action="ViewReport.aspx"
method="post"
name="Criteria"
id="Criteria"

....
<% RenderTree() %>

....
</form>

FYI: RenderTree() method constructs a TreeView control and then calls
RenderControl(new HtmlTextWriter(Response.Output, " "))


Anyway... any help would be appreciated (again!)


 
Reply With Quote
 
 
 
 
Yosias Selemon
Guest
Posts: n/a
 
      07-30-2003
Kris

I don't know if this will help but in my Access 2000 form I had the
same problem. It seems to be a timing issue. The only way I was able
to fix it was to put a timer and go through the TreeView control but
this time just handle the checkboxes . hope this helps

"Kris Oye" <(E-Mail Removed)> wrote in message news:<3f2092f3$(E-Mail Removed)>...
> I am creating a TreeView programatically in C# and then using the
> RenderControl() method to send it back to the browser. I am attempting to
> use the resulting checkboxes in an existing form, but when the data is
> submitted back to the server for processing, none of the checkbox data
> appears in my Request. Anyone know why this might happen? I've tried it a
> number of ways to get it working but with no success. The tree renders
> correctly and each checkbox has the correct ID and Name, but no go. Any
> help would be greatly appreciated:
>
> Brief code fragment:
>
> <form action="ViewReport.aspx"
> method="post"
> name="Criteria"
> id="Criteria"
>
> ...
> <% RenderTree() %>
>
> ...
> </form>
>
> FYI: RenderTree() method constructs a TreeView control and then calls
> RenderControl(new HtmlTextWriter(Response.Output, " "))
>
>
> Anyway... any help would be appreciated (again!)

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Checkbox Column Not Appearing Ben ASP .Net 1 01-02-2008 03:58 PM
Links in Outlook Express not working,page not appearing Thaqalain Computer Support 7 09-30-2005 12:48 PM
ad.uk.doucleclick.net - hell...apologies if this post is appearing twice! Extracoconut Computer Support 4 05-17-2005 06:29 PM
CheckBoxList values not appearing and State not maintained when ne jmhmaine ASP .Net Web Controls 0 01-20-2005 04:25 PM
Re: Accessing Request.InputStream / Request.BinaryRead *as the request is occuring*: How??? Brian Birtle ASP .Net 2 10-16-2003 02:11 PM



Advertisments