Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Security > Cookiecontainer problem with HTTPS

Reply
Thread Tools

Cookiecontainer problem with HTTPS

 
 
Arne Garvander
Guest
Posts: n/a
 
      12-26-2007
The code below works fine in HTTP but does not work with HTTPS. I get no
cookies in VS Studio 2005 when changing to HTTPS, but I get them in Fiddler.
WHY?

Imports System.Web
Imports System.net

Public Class CookieTest
Public Sub test()
Dim CC As New CookieContainer()
Dim Req As HttpWebRequest
Dim res As HttpWebResponse
Req =
WebRequest.Create("http://localhost:1209/AIMSSystem/cookietest.aspx")
Req.Proxy = Nothing

Req.CookieContainer = CC
res = Req.GetResponse()

Dim c As Cookie
For Each c In res.Cookies
Console.WriteLine(c.ToString())
Next c

End Sub

End Class
--
Arne Garvander
Certified Geek
Professional Data Dude
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CookieContainer GetCookies fails on multiple Set-Cookies guyhey ASP .Net 2 01-12-2008 04:55 PM
HttpWebRequest / CookieContainer - not deleting cookies. macro ASP .Net 4 03-29-2006 07:48 PM
Axis 1.2/1.3 interop .NET-CookieContainer problem. VEJIKYUULYCY@spammotel.com ASP .Net Web Services 2 12-21-2005 12:00 PM
HttpWebRequest (CookieContainer) vs. AxWebBrowser Martin Madreza ASP .Net 0 11-17-2003 09:44 AM
CookieContainer with WebClient Martin Kuba ASP .Net 0 08-05-2003 04:51 PM



Advertisments