Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Security > aspnet_regiis permissions needed

Reply
Thread Tools

aspnet_regiis permissions needed

 
 
PeterP
Guest
Posts: n/a
 
      12-12-2007
following scenario:

I am using aspnet_regiis to encrypt parts of my web.config. this works fine
on the development machine. Now I move to the integration machine which is
based on a hardened server image. The user I am logged in with is in the
local administrators group. Creating the key container succeeds, but when I
try to encrypt the web.config section, I get the error:

Failed to encrypt the section 'appSettings' using provider
'RsaProtectedConfigurationProvider'. Error message from the provider: The RSA
key container could not be opened.
Failed!

With a second account that is in the same domain as the first and as well in
the local administrators group. When I execute the exact same steps (create
container and then encrypt) everything works as expected.

My suspision now is that in the hardened server image a specific right was
explicitly granted to the second administrative account and not to the first
one.

Can anyone elaborate on the specific permissions needed for an account when
encrypting with aspnet_regiis?

Any help is strongly appreciated.
Peter


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
In-depth documenation on User Permissions, Group Permissions, ACLs, DCLs etc. Curt K ASP .Net 0 11-03-2006 04:54 PM
ASPX file returning obscur runtime error - after changing permissions to a subweb (.net app) to different permissions than on its parent ? Isabelle ASP .Net 0 08-11-2004 02:04 PM
Re: Permissions - giving "everyone" full permissions is bad ? Scott Allen ASP .Net 0 07-13-2004 08:54 PM
Permissions needed to run aspnet_regiis.exe -c Eric Caron ASP .Net 3 04-05-2004 04:57 PM
Ran aspnet_regiis.exe -i from 1.1 dir, but iis is not running 1.1 Kyle Jedrusiak ASP .Net 1 08-19-2003 01:19 AM



Advertisments