Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Security > App fails to load resource assembly with "Setup failed with hr =0x80070005"

Reply
Thread Tools

App fails to load resource assembly with "Setup failed with hr =0x80070005"

 
 
Achim Domma
Guest
Posts: n/a
 
      08-22-2006
Hi,

I try to develop a localized Asp.Net 1.1 application. I have added two
resource files to my app, which are called 'Labels.resx' and
'Labels.de.resx'. If I compile the app, I see a 'de' subfolder in my
'bin' folder and the folder contains the resource dll.

Accessing the german strings does not work. After a lot of debugging I
managed to get fuslogvw.exe to work and got a result like this:


[...]

LOG: Attempting download of new URL
file:///C:/WINDOWS/[...]/Administration.resources.DLL.

LOG: Attempting download of new URL
file:///C:/develop/[...]/bin/de/Administration.resources.DLL.

LOG: Assembly download was successful. Attempting setup of file:
C:\develop\[...]\bin\de\Administration.resources.DLL

LOG: Entering download cache setup phase.

ERR: Setup failed with hr = 0x80070005.

ERR: Failed to complete setup of assembly (hr = 0x80070005). Probing
terminated.



So it looks like Asp.Net tries to load the correct assembly, but setting
up the assembly fails for mysterious reasons. Using the sysinternals
file monitor, I can see that the assembly is accessed but filemon does
not display an error. If I disable anonymous access and login as admin,
it works fine.

Any hint what might be going wrong?

regards,
Achim
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Exception occured While loading dynamically EXE assembly in C++/CLI(Could not load file or assembly ', Version=1.0.3836.39802, Culture=neutral,PublicKeyToken=null' ...) glitteringsounds C++ 1 07-03-2010 07:49 PM
Failed to load expression host assembly. SecurityPermission ReportViewer 9.0.0.0 colinvella ASP .Net 1 10-26-2009 04:48 PM
App fails to load resource assembly with "Setup failed with hr =0x80070005" Achim Domma ASP .Net 0 08-21-2006 06:36 PM
Setup Error: Failed to load resources from resource file =?Utf-8?B?YnJ1Y2U=?= ASP .Net 0 08-10-2005 03:46 PM
Referencing assembly from GAC using @assembly fails Brent ASP .Net 1 01-23-2004 08:23 PM



Advertisments