Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Security > Using useuri with security: Keep returning to login page

Reply
Thread Tools

Using useuri with security: Keep returning to login page

 
 
Peter Vogel
Guest
Posts: n/a
 
      10-24-2005
I've tried turning off cookies in FireFox and turning on cookieless
sessions in the forms element inside the authentication element (I set
the cookieless attribute to UseUri). I'm generating the security token
in the URL F(guid).

I can log on successfully and get to the second page in my application
(the page after the login page). However, when I attempt to request
another page (by, for instance, clicking on one of the links in the
Menu control), I find myself right back at the login page with the
query string set to the page that I requested. Sure enough if I log on
again, I find myself at the requested page.

I suspect that this is related to a problem that I'm having with
cookieless sessions. When I set the cookieless attribute in the
sessionState attribute to UseUri, the SessionId in the address bad
seems to keep changing. As a result, I can't reconnect to the data that
I've put in my Session object. In other words, I'll login and, in the
address bar, I'll see S(someguid). After clicking a link to go to
another page I'll see S(someotherguid).

Any thoughts?
Or
Help!

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to do forms authentication with cookieless=UseUri? gnewsgroup ASP .Net 5 01-26-2008 04:38 AM
login page stays on login page Shannon ASP .Net 2 01-09-2008 10:51 PM
Can't create simple login page using asp:login control Sasquatch ASP .Net 2 10-03-2006 09:22 PM
Keep getting "Your login attempt was not successful...." from <asp:Login> control - but it works on Dev box. Jack ASP .Net Web Controls 1 07-16-2006 06:08 AM
Forms authentication not returning to login page BillGatesFan ASP .Net 3 01-03-2005 10:03 PM



Advertisments