Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Security > IE prompts for password, even though Forms Authentication is used

Reply
Thread Tools

IE prompts for password, even though Forms Authentication is used

 
 
Charles Forsyth
Guest
Posts: n/a
 
      10-09-2005
Hi all,

I have an ASP.Net application that has worked swell on both my
development environment and production for some time now. Development
is running on a WinXP Pro box, Production is running on a Win 2000
Server.

However, the other day we had to move the application to another
server. The new server is Windows 2003 box.

The problem is that when you visit any page that requires forms
authorization IE will prompt the user to log in to that box. This
doesn't make sense since I'm not using Windows Authentication, I'm
using Forms Authentication.

For the heck of it, I went to IIS and checked. Anonymous authentication
is enabled, and all other forms are disabled. That includes Windows
Integrated and Basic.

Then for the heck of it, I made sure that the local "ASPNET" account
had full control on every single file and folder on that box. Just in
case it's some ACL permission issue.

Still, the browser prompts for logon.

What is strange is, when you click cancel on the logon prompt, it still
lets you in and the page runs. But as soon as you try to access another
page, IE prompts you again to log on.

One thing though, the app works fine if I VPN in to the network, and
access it via IP address instead of using the web domain name assigned
to the app in the DNS.

This gives me a clue that it could have something to do with our ISA
server. Or perhaps DNS?

Has anyone else had this problem? How did you fix it?

 
Reply With Quote
 
 
 
 
Charles Forsyth
Guest
Posts: n/a
 
      10-09-2005
I was able to resolve this problem by first running aspnet_regiis.exe
-i

Then granting ACLs to the directory: /aspnet_client/ that was created
under InetPub

Then in IIS I opened properties on /aspnet_client/ folder and set it up
to allow anonymous access.

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CPU Usage frequently 100% even though it seems not even close tototal memory Newcomer Computer Support 3 11-15-2009 06:51 AM
CPU Usage frequently 100% even though it seems not even close tototal memory Newcomer Computer Support 0 11-14-2009 11:21 PM
Windows prompts for login but using Forms Authentication charles@charlesforsyth.com ASP .Net 1 10-09-2005 05:02 AM
Windows logon dialog appears even though authentication mode is set to None?!? Joergen Bech ASP .Net 2 07-02-2005 03:47 PM
request.forms sporadically returns no data even though the user entered data Mike ASP General 1 10-21-2004 09:24 PM



Advertisments