Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Security > Configuration Error in web.config

Reply
Thread Tools

Configuration Error in web.config

 
 
alex444
Guest
Posts: n/a
 
      09-27-2005
I would appreciate any help with the following error. I'd like to mention
that application works on my Dev server no problems at all but not on the 3d
party host server (they saying it's coding problem).
=====================================
Server Error in '/' Application
--------------------------------------------------------------------------------
Configuration Error
Description: An error occurred during the processing of a configuration file
required to service this request. Please review the specific error details
below and modify your configuration file appropriately.

Parser Error Message: The XML file \\path\webroot\web.config could not be
loaded. Logon failure: unknown user name or bad password.

Source Error:

[No relevant source lines]

Source File: \\path\webroot\web.config Line: 0
--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:1.1.4322.2300; ASP.NET
Version:1.1.4322.2300
======================================

My web.config file:
===================
<?xml version="1.0" encoding="utf-8" ?>
<configuration>
<appSettings>
<add key="new" value="10" />
</appSettings>
<system.web>
<compilation defaultLanguage="c#" debug="false" />
<customErrors mode="Off" />
<authentication mode="None" />
<authorization>
<allow users="*" /> <!-- Allow all users -->
</authorization>
<globalization requestEncoding="utf-8" responseEncoding="windows-1251" />
</system.web>
</configuration>
===================
 
Reply With Quote
 
 
 
 
Tasos Vogiatzoglou
Guest
Posts: n/a
 
      09-27-2005
Is this a shared folder ? Most probably ASPNET worker cannot access the
folder.

 
Reply With Quote
 
 
 
 
Martin
Guest
Posts: n/a
 
      09-27-2005
Or maybe moved the file web.config so Access Rights arent inherited from
folder.

"Tasos Vogiatzoglou" <(E-Mail Removed)> schreef in bericht
news:(E-Mail Removed) ups.com...
> Is this a shared folder ? Most probably ASPNET worker cannot access the
> folder.
>



 
Reply With Quote
 
Paul Glavich [MVP ASP.NET]
Guest
Posts: n/a
 
      10-02-2005
Try changing your authentication mode to "Windows"

--
- Paul Glavich
MVP ASP.NET
http://weblogs.asp.net/pglavich
ASPInsiders member - http://www.aspinsiders.com


"alex444" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed)...
>I would appreciate any help with the following error. I'd like to mention
> that application works on my Dev server no problems at all but not on the
> 3d
> party host server (they saying it's coding problem).
> =====================================
> Server Error in '/' Application.
> --------------------------------------------------------------------------------
> Configuration Error
> Description: An error occurred during the processing of a configuration
> file
> required to service this request. Please review the specific error details
> below and modify your configuration file appropriately.
>
> Parser Error Message: The XML file \\path\webroot\web.config could not be
> loaded. Logon failure: unknown user name or bad password.
>
> Source Error:
>
> [No relevant source lines]
>
> Source File: \\path\webroot\web.config Line: 0
> --------------------------------------------------------------------------------
> Version Information: Microsoft .NET Framework Version:1.1.4322.2300;
> ASP.NET
> Version:1.1.4322.2300
> ======================================
>
> My web.config file:
> ===================
> <?xml version="1.0" encoding="utf-8" ?>
> <configuration>
> <appSettings>
> <add key="new" value="10" />
> </appSettings>
> <system.web>
> <compilation defaultLanguage="c#" debug="false" />
> <customErrors mode="Off" />
> <authentication mode="None" />
> <authorization>
> <allow users="*" /> <!-- Allow all users -->
> </authorization>
> <globalization requestEncoding="utf-8" responseEncoding="windows-1251"
> />
> </system.web>
> </configuration>
> ===================



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Caught Exception: System.Configuration.ConfigurationErrorsException: An error occurred loading a configuration file: Request for the permission of type 'System.Security.Permissions.FileIOPermission, mscorlib, Version=2.0.0.0, Culture=neutral, PublicK Mike ASP .Net 5 08-15-2007 08:57 AM
Enterprise Library exception: The configuration section securityCryptographyConfiguration is not defined in the current configuration for the AppDomain. Jess Chadwick ASP .Net 1 09-21-2006 09:18 AM
Configuration reverted to previous configuration after power loss ward@sciinc.com Cisco 0 03-03-2006 04:14 PM
Microsoft Configuration Block and Enterprise library configuration tool Mark ASP .Net 0 02-15-2006 11:27 PM
PEAP Configuration Woes - PEAP configuration help jester Cisco 1 12-20-2005 02:04 PM



Advertisments