Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Security > CryptographicException - Bad Data when changing from SSL to no secure connection

Reply
Thread Tools

CryptographicException - Bad Data when changing from SSL to no secure connection

 
 
z f
Guest
Posts: n/a
 
      03-05-2005
Hi,

in a asp-vb.net web application, i have a login page.
when i use the login page with http:// url, everything is fine,
authentication works.
when i work with https:// it also works.
when i change from https to http after the login (only login works with SSL)
i get the error
[System.Security.Cryptography.CryptographicExceptio n] - Bad Data
on the following line in the global.asax authenticateRequest

Dim authTicket As FormsAuthenticationTicket =
FormsAuthentication.Decrypt(authCookie.Value)

what can i do? please help.
TIA, z.


 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CryptographicException: Bad Data. Any idea why this happens? simonmarkjones@gmail.com ASP .Net Security 1 08-27-2006 01:17 AM
CryptographicException Bad Data in Windo =?Utf-8?B?ZnJlcXVuZW5jeQ==?= ASP .Net 0 07-20-2005 03:05 AM
Re: "System.Security.Cryptography.CryptographicException: Bad Data" Message Dei401 ASP .Net 0 02-02-2005 04:30 PM
CryptographicException: Bad Data - when storing public key only in key store on encrypting machine pmkatz ASP .Net Security 0 08-25-2004 08:55 PM
CryptographicException: Bad Data jaekim ASP .Net Security 3 09-07-2003 09:16 AM



Advertisments