Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Security > Problems when joining a domain

Reply
Thread Tools

Problems when joining a domain

 
 
Paul
Guest
Posts: n/a
 
      07-21-2004
OK - here's the situation.
We have a Win 2K Server running IIS and MSSQL with the .NET 1.1
framework.
Everything works just fine when the machine is not a member of a
domain.
Everything works just fine when we join the server to our test domain.
However, when we join the machine to our production domain we get the
following error:

aspnet_wp.exe could not be started. The error code for the failure is
80070545. This error can be caused when the worker process account has
insufficient rights to read the .NET Framework files. Please ensure
that the .NET Framework is correctly installed and that the ACLs on
the installation directory allow access to the configured account.

I've been through the solution outlined in KB article 315158
http://support.microsoft.com/default...b;en-us;315158

While interesting - I don't think this applies because the framework
is not installed on either or the Active Directory machines.

Could there be something in a group policy that is causing this
behavior?

thanks,
-paul
 
Reply With Quote
 
 
 
 
Shaun
Guest
Posts: n/a
 
      07-22-2004
I had a similar problem a short time back and found I needed to changed the ACLs for the framework files etc for the domain account used for the process. Here's the batch file content I used (change domain and user as required), hope it helps ...


cacls "C:\WINNT\Microsoft.NET" /T /E /C /P domain\user:R

cacls "C:\WINNT\Microsoft.NET\Framework\v1.1.4322\Tempor ary ASP.NET Files" /T /E /C /P domain\user:C

cacls "C:\WINNT\temp" /T /E /C /P domain\user:C

cacls "C:\inetpub\wwwroot" /T /E /C /P domain\user:R

cacls "e:\" /T /E /C /P domain\user:R

cacls "C:\WINNT\assembly" /T /E /C /P domain\user:R





--------------------------
Shaun Venus

emailid: sunevnuahs
domain: hotmail.com
--------------------------


"Paul" wrote:

> OK - here's the situation.
> We have a Win 2K Server running IIS and MSSQL with the .NET 1.1
> framework.
> Everything works just fine when the machine is not a member of a
> domain.
> Everything works just fine when we join the server to our test domain.
> However, when we join the machine to our production domain we get the
> following error:
>
> aspnet_wp.exe could not be started. The error code for the failure is
> 80070545. This error can be caused when the worker process account has
> insufficient rights to read the .NET Framework files. Please ensure
> that the .NET Framework is correctly installed and that the ACLs on
> the installation directory allow access to the configured account.
>
> I've been through the solution outlined in KB article 315158
> http://support.microsoft.com/default...b;en-us;315158
>
> While interesting - I don't think this applies because the framework
> is not installed on either or the Active Directory machines.
>
> Could there be something in a group policy that is causing this
> behavior?
>
> thanks,
> -paul
>

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Making a server on one domain the domain controller of a new domain Limited Wisdom MCSA 7 09-13-2006 02:18 AM
Problems Joining the Domain =?Utf-8?B?SGFsbw==?= Windows 64bit 4 12-21-2005 07:30 PM



Advertisments