Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Mobile > Are they known issues of Openwave 5.0 with ASP.NET mobile controls?

Reply
Thread Tools

Are they known issues of Openwave 5.0 with ASP.NET mobile controls?

 
 
Dominic
Guest
Posts: n/a
 
      11-18-2004
I have come across a few weird issues when testing with Openwave
browser 5.0 (included in Openwave SDK 5.1). The issues are:

1. System.FormatException
Input string was not in a correct format.
Method: ParseInt32.

- The page doesn't even do Int32.Parse at all.

2. System.ArgumentException
Form not found:
'MyFormName**'
Method:GetForm

- The form name is appeneded with some weird characters.

I have found reports of these issues in this newsgroup two years ago.

http://groups.google.ca/groups?hl=en...l%3Den%26lr%3D

http://groups.google.ca/groups?hl=en...%2BNot%2BFOund

According to the first reply, Openwave 5.0 is not officially supported
by Microsoft ASP.NET mobile control. However, I've checked the latest
list. It is really supported.

http://www.asp.net/mobile/testeddevices.aspx?tabindex=6

Do you know how I can solve the above issues? Thanks

Dominic
 
Reply With Quote
 
 
 
 
JuanDG
Guest
Posts: n/a
 
      11-19-2004
are you running v1.1 with device updtade 4???

you can download DU4 here:

http://www.microsoft.com/downloads/d...displaylang=en

cheers!!!

--

Juan David Gomez A.
Microsoft Certified Professional
Analista de Desarrollo - PSL S.A.
Web and Wireless Banking
Medellin - Colombia


"Dominic" wrote:

> I have come across a few weird issues when testing with Openwave
> browser 5.0 (included in Openwave SDK 5.1). The issues are:
>
> 1. System.FormatException
> Input string was not in a correct format.
> Method: ParseInt32.
>
> - The page doesn't even do Int32.Parse at all.
>
> 2. System.ArgumentException
> Form not found:
> 'MyFormName**'
> Method:GetForm
>
> - The form name is appeneded with some weird characters.
>
> I have found reports of these issues in this newsgroup two years ago.
>
> http://groups.google.ca/groups?hl=en...l%3Den%26lr%3D
>
> http://groups.google.ca/groups?hl=en...%2BNot%2BFOund
>
> According to the first reply, Openwave 5.0 is not officially supported
> by Microsoft ASP.NET mobile control. However, I've checked the latest
> list. It is really supported.
>
> http://www.asp.net/mobile/testeddevices.aspx?tabindex=6
>
> Do you know how I can solve the above issues? Thanks
>
> Dominic
>

 
Reply With Quote
 
 
 
 
Dominic
Guest
Posts: n/a
 
      11-19-2004
I forgot to mention that these issues do not appear in Openwave 4.1
and 6.2, Pocket PC 2002 / 2003, and Smartphone 2003 emulators.

I thought it was related to the language that it renders. However,
both Openwave 4.1 and 5.0 use WML 1.1, but only Openwave 5.0 has those
issues.

Any suggestion is much appreciated.

Dom
http://www.velocityreviews.com/forums/(E-Mail Removed) (Dominic) wrote in message news:<(E-Mail Removed). com>...
> I have come across a few weird issues when testing with Openwave
> browser 5.0 (included in Openwave SDK 5.1). The issues are:
>
> 1. System.FormatException
> Input string was not in a correct format.
> Method: ParseInt32.
>
> - The page doesn't even do Int32.Parse at all.
>
> 2. System.ArgumentException
> Form not found:
> 'MyFormName**'
> Method:GetForm
>
> - The form name is appeneded with some weird characters.
>
> I have found reports of these issues in this newsgroup two years ago.
>
> http://groups.google.ca/groups?hl=en...l%3Den%26lr%3D
>
> http://groups.google.ca/groups?hl=en...%2BNot%2BFOund
>
> According to the first reply, Openwave 5.0 is not officially supported
> by Microsoft ASP.NET mobile control. However, I've checked the latest
> list. It is really supported.
>
> http://www.asp.net/mobile/testeddevices.aspx?tabindex=6
>
> Do you know how I can solve the above issues? Thanks
>
> Dominic

 
Reply With Quote
 
Dominic
Guest
Posts: n/a
 
      11-23-2004
Yes, I'm running V1.1 with device update 4. Is there any newer patch?

Thanks for your reminder though

JuanDG <(E-Mail Removed)> wrote in message news:<(E-Mail Removed)>...
> are you running v1.1 with device updtade 4???
>
> you can download DU4 here:
>
> http://www.microsoft.com/downloads/d...displaylang=en
>
> cheers!!!
>
> --
>
> Juan David Gomez A.
> Microsoft Certified Professional
> Analista de Desarrollo - PSL S.A.
> Web and Wireless Banking
> Medellin - Colombia
>
>
> "Dominic" wrote:
>
> > I have come across a few weird issues when testing with Openwave
> > browser 5.0 (included in Openwave SDK 5.1). The issues are:
> >
> > 1. System.FormatException
> > Input string was not in a correct format.
> > Method: ParseInt32.
> >
> > - The page doesn't even do Int32.Parse at all.
> >
> > 2. System.ArgumentException
> > Form not found:
> > 'MyFormName**'
> > Method:GetForm
> >
> > - The form name is appeneded with some weird characters.
> >
> > I have found reports of these issues in this newsgroup two years ago.
> >
> > http://groups.google.ca/groups?hl=en...l%3Den%26lr%3D
> >
> > http://groups.google.ca/groups?hl=en...%2BNot%2BFOund
> >
> > According to the first reply, Openwave 5.0 is not officially supported
> > by Microsoft ASP.NET mobile control. However, I've checked the latest
> > list. It is really supported.
> >
> > http://www.asp.net/mobile/testeddevices.aspx?tabindex=6
> >
> > Do you know how I can solve the above issues? Thanks
> >
> > Dominic
> >

 
Reply With Quote
 
JuanDG
Guest
Posts: n/a
 
      11-24-2004
Currently NO, we wont have a Device Update beyond v4, mostly because the
faith of Mobile Controls is being decided for .NET 2.0 (maybe mobile
controls will be deprecated by ASP.NET 2.0) currently in .NET 2.0 Beta 1
there are no Mobile Controls, ASP.NET 2.0 renders a special version of your
website specifically for mobile devices without you having to write a single
extra
line of code, in Beta 2 it wont be so and they (ASP.NET Team) recommend us
to keep using Mobile Controls as in v1.x.

As you can see it's not still very clear what it's going to happen but all
rumors point to the extinction of Mobile Controls for .NET 2.0 RTM (that
means NO more Device Updates).

Nevertheless you can build the Profiles for the Devices you want here:
http://www.asp.net/mobile/profile/default.aspx
it's a very cool wizard that will guide you through building the profiles,
Hope it Helps!!!

Good Luck!!!

--

Juan David Gomez A.
Microsoft Certified Professional
Analista de Desarrollo - PSL S.A.
Web and Wireless Banking
Medellin - Colombia

"Dominic" <(E-Mail Removed)> wrote in message
news:(E-Mail Removed) om...
> Yes, I'm running V1.1 with device update 4. Is there any newer patch?
>
> Thanks for your reminder though
>
> JuanDG <(E-Mail Removed)> wrote in message
> news:<(E-Mail Removed)>...
>> are you running v1.1 with device updtade 4???
>>
>> you can download DU4 here:
>>
>> http://www.microsoft.com/downloads/d...displaylang=en
>>
>> cheers!!!
>>
>> --
>>
>> Juan David Gomez A.
>> Microsoft Certified Professional
>> Analista de Desarrollo - PSL S.A.
>> Web and Wireless Banking
>> Medellin - Colombia
>>
>>
>> "Dominic" wrote:
>>
>> > I have come across a few weird issues when testing with Openwave
>> > browser 5.0 (included in Openwave SDK 5.1). The issues are:
>> >
>> > 1. System.FormatException
>> > Input string was not in a correct format.
>> > Method: ParseInt32.
>> >
>> > - The page doesn't even do Int32.Parse at all.
>> >
>> > 2. System.ArgumentException
>> > Form not found:
>> > 'MyFormName**'
>> > Method:GetForm
>> >
>> > - The form name is appeneded with some weird characters.
>> >
>> > I have found reports of these issues in this newsgroup two years ago.
>> >
>> > http://groups.google.ca/groups?hl=en...l%3Den%26lr%3D
>> >
>> > http://groups.google.ca/groups?hl=en...%2BNot%2BFOund
>> >
>> > According to the first reply, Openwave 5.0 is not officially supported
>> > by Microsoft ASP.NET mobile control. However, I've checked the latest
>> > list. It is really supported.
>> >
>> > http://www.asp.net/mobile/testeddevices.aspx?tabindex=6
>> >
>> > Do you know how I can solve the above issues? Thanks
>> >
>> > Dominic
>> >



 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
iPhone4,iPhone3,Ipad,Apple Mobile,Blackberry Mobile,HTC Mobile,LGMobile,Motorola Mobile,Nokia Mobile,Samsung Mobile chen selina C++ 0 07-13-2010 08:53 AM



Advertisments