Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Mobile > Changes to Machine.Config to default to WAP output

Reply
Thread Tools

Changes to Machine.Config to default to WAP output

 
 
Salo
Guest
Posts: n/a
 
      06-08-2004
Hi there - thanks in advance.

I'm developing an app using asp.net mobile web controls.

Trying to test it using yospace smartphone emulator 4.0.

My problem is that when I send my request from the emulator, on lots
of phones I get a 406 ...its expecting wml and getting html.

Example is a SonyEricsson t610.

I found the t610 in device update 4 though - so MMIT should know to
return wap to it right?

Hmmmm... in deviceupdate.config, theres these lines for the T610:

preferredRenderingMime = "application/xhtml+xml"
preferredRenderingType = "xhtml-basic"


My questions are :

a) is it more likely that the guys that implemented the emulator got
their support wrong (and the T610 really does support xhtml)? or did
MS get it wrong? [[or is my understanding wrong!?]]

b) how can I fix it so that the emulators work for my demo?

Thanks so much for any help.

Salo.
 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Output Parameter not being returned correctly - DAAB in ASP.NET WAP Alec MacLean ASP .Net 8 09-18-2006 08:46 PM
WAP secure, what about WAP keys in wireless settings? Jac Wireless Networking 1 02-11-2006 04:54 AM
changes I would like to see in the default Firefox installation trevor_smithson@yahoo.com Firefox 1 11-15-2005 11:20 PM
Default timezone changes out of nowhere? Werner Lehmann Java 6 07-02-2005 12:28 AM
Help Reqd: WAP payment gateway, premium SMS and WAP usernames Aaron Whiffin HTML 0 09-04-2003 10:39 AM



Advertisments