Velocity Reviews - Computer Hardware Reviews

Velocity Reviews > Newsgroups > Programming > ASP .Net > ASP .Net Datagrid Control > problem with adding IDs to webcontrols in datagrid

Reply
Thread Tools

problem with adding IDs to webcontrols in datagrid

 
 
rob.bowley@gmail.com
Guest
Posts: n/a
 
      09-16-2005
I have programatically created textboxes with IDs within my datagrid.
This appears to work fine as when I view source it all looks good. The
problem is that I now can't return the bound values contained in the
textboxes. They are there as they're displayed on the page, but when I
debug it simply comes up with an empty text field. I can return the
values if I remove the IDs, but I want to be able to fire a JavaScript
event which calculates row totals and it would be very difficult to
locate the textboxes without IDs.

Has anyone else had the same problem?

 
Reply With Quote
 
 
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Adding a System.Web.UI.WebControls.Panel to a DataGrid Cell kito ASP .Net 2 09-10-2006 07:33 PM
Object reference not set to an instance of an object. System.Web.UI.WebControls.ListItemCollection.SaveViewState() System.Web.UI.WebControls.ListControl.SaveViewState() Brano ASP .Net 3 11-08-2005 12:29 PM
Control IDs in DataGrid/TemplateColumn JV ASP .Net 1 06-23-2005 05:24 PM
after transfer of data from MS-outlook(mail ids) to application,mail ids are consisting of strange characters vamsikrishna_b@coolgoose.com Python 2 06-21-2005 12:41 PM
DataGrid appending to my ItemTemplate IDs? Jim Bancroft ASP .Net 0 12-28-2004 03:51 PM



Advertisments